libmosquitto: Update from 1.5 to 1.5.1
This commit is contained in:
parent
aa37845374
commit
b0eee78abb
12
packages/libmosquitto/CMakeLists.txt.patch
Normal file
12
packages/libmosquitto/CMakeLists.txt.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -u -r ../mosquitto-1.5.1/src/CMakeLists.txt ./src/CMakeLists.txt
|
||||
--- ../mosquitto-1.5.1/src/CMakeLists.txt 2018-08-16 16:05:26.000000000 +0000
|
||||
+++ ./src/CMakeLists.txt 2018-08-19 15:42:58.946457265 +0000
|
||||
@@ -160,7 +160,7 @@
|
||||
endif(NOT APPLE)
|
||||
|
||||
add_executable(mosquitto ${MOSQ_SRCS})
|
||||
-target_link_libraries(mosquitto ${MOSQ_LIBS})
|
||||
+target_link_libraries(mosquitto ${MOSQ_LIBS} log)
|
||||
|
||||
if (UNIX)
|
||||
if (APPLE)
|
@ -1,12 +0,0 @@
|
||||
diff -u -r ../mosquitto-1.4.10/src/CMakeLists.txt ./src/CMakeLists.txt
|
||||
--- ../mosquitto-1.4.10/src/CMakeLists.txt 2016-08-17 13:05:14.000000000 +0200
|
||||
+++ ./src/CMakeLists.txt 2017-01-24 23:40:30.787022276 +0100
|
||||
@@ -107,7 +111,7 @@
|
||||
endif (UUID_HEADER)
|
||||
endif(NOT APPLE)
|
||||
|
||||
-target_link_libraries(mosquitto ${MOSQ_LIBS})
|
||||
+target_link_libraries(mosquitto ${MOSQ_LIBS} log)
|
||||
|
||||
if (UNIX)
|
||||
if (APPLE)
|
@ -1,8 +1,7 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://mosquitto.org/
|
||||
TERMUX_PKG_DESCRIPTION="MQTT library"
|
||||
TERMUX_PKG_VERSION=1.5
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SHA256=80c9606a906c736fe582b67bdfb650ee45239fea058fe34927f81277d3486e21
|
||||
TERMUX_PKG_VERSION=1.5.1
|
||||
TERMUX_PKG_SHA256=8557bc7ae34dfaf32a0fb56d2491b7a7f731269c88337227233013502df4d5b0
|
||||
TERMUX_PKG_SRCURL=https://mosquitto.org/files/source/mosquitto-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_DEPENDS="c-ares, openssl"
|
||||
TERMUX_PKG_MAINTAINER="Nathaniel Wesley Filardo @nwf"
|
||||
|
Loading…
Reference in New Issue
Block a user