nodejs: Just keep a single current package
Drop the LTS version of node.js for now and keep only a single current node package.
This commit is contained in:
parent
fd72a74c42
commit
b1a9c9c562
@ -1,7 +1,7 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
|
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
|
||||||
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
|
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
|
||||||
TERMUX_PKG_VERSION=10.9.0
|
TERMUX_PKG_VERSION=8.12.0
|
||||||
TERMUX_PKG_SHA256=d17ef8eb72d6a31f50a663d554beb9bcb55aa2ce57cf189abfc9b1ba20530d02
|
TERMUX_PKG_SHA256=5a9dff58016c18fb4bf902d963b124ff058a550ebcd9840c677757387bce419a
|
||||||
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
|
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
|
||||||
# Note that we do not use a shared libuv to avoid an issue with the Android
|
# Note that we do not use a shared libuv to avoid an issue with the Android
|
||||||
# linker, which does not use symbols of linked shared libraries when resolving
|
# linker, which does not use symbols of linked shared libraries when resolving
|
||||||
@ -12,7 +12,6 @@ TERMUX_PKG_BUILD_IN_SRC=yes
|
|||||||
TERMUX_PKG_CONFLICTS="nodejs"
|
TERMUX_PKG_CONFLICTS="nodejs"
|
||||||
|
|
||||||
termux_step_configure () {
|
termux_step_configure () {
|
||||||
local DEST_CPU
|
|
||||||
if [ $TERMUX_ARCH = "arm" ]; then
|
if [ $TERMUX_ARCH = "arm" ]; then
|
||||||
DEST_CPU="arm"
|
DEST_CPU="arm"
|
||||||
elif [ $TERMUX_ARCH = "i686" ]; then
|
elif [ $TERMUX_ARCH = "i686" ]; then
|
||||||
@ -26,9 +25,6 @@ termux_step_configure () {
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
export GYP_DEFINES="host_os=linux"
|
export GYP_DEFINES="host_os=linux"
|
||||||
export CC_host=gcc
|
|
||||||
export CXX_host=g++
|
|
||||||
export LINK_host=g++
|
|
||||||
|
|
||||||
# See note above TERMUX_PKG_DEPENDS why we do not use a shared libuv.
|
# See note above TERMUX_PKG_DEPENDS why we do not use a shared libuv.
|
||||||
./configure \
|
./configure \
|
||||||
@ -42,7 +38,4 @@ termux_step_configure () {
|
|||||||
--without-intl \
|
--without-intl \
|
||||||
--without-snapshot \
|
--without-snapshot \
|
||||||
--cross-compiling
|
--cross-compiling
|
||||||
|
|
||||||
perl -p -i -e 's/LIBS := \$\(LIBS\)/LIBS := -lpthread/' \
|
|
||||||
$TERMUX_PKG_SRCDIR/out/deps/v8/gypfiles/torque.host.mk
|
|
||||||
}
|
}
|
@ -1,6 +1,6 @@
|
|||||||
diff -u -r ../node-v9.7.1/deps/uv/uv.gyp ./deps/uv/uv.gyp
|
diff -u -r ../node-v8.12.0/deps/uv/uv.gyp ./deps/uv/uv.gyp
|
||||||
--- ../node-v9.7.1/deps/uv/uv.gyp 2018-03-02 01:58:02.000000000 +0000
|
--- ../node-v8.12.0/deps/uv/uv.gyp 2018-09-10 18:46:54.000000000 +0000
|
||||||
+++ ./deps/uv/uv.gyp 2018-03-05 10:51:15.530165566 +0000
|
+++ ./deps/uv/uv.gyp 2018-09-11 20:52:40.320690510 +0000
|
||||||
@@ -39,7 +39,7 @@
|
@@ -39,7 +39,7 @@
|
||||||
{
|
{
|
||||||
'target_name': 'libuv',
|
'target_name': 'libuv',
|
12
disabled-packages/nodejs-lts/lib-os.js.patch
Normal file
12
disabled-packages/nodejs-lts/lib-os.js.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -u -r ../node-v5.10.0/lib/os.js ./lib/os.js
|
||||||
|
--- ../node-v5.10.0/lib/os.js 2016-03-31 21:52:17.000000000 -0400
|
||||||
|
+++ ./lib/os.js 2016-04-04 04:46:05.148105544 -0400
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
path = process.env.TMPDIR ||
|
||||||
|
process.env.TMP ||
|
||||||
|
process.env.TEMP ||
|
||||||
|
- '/tmp';
|
||||||
|
+ '@TERMUX_PREFIX@/tmp';
|
||||||
|
if (path.length > 1 && path.endsWith('/'))
|
||||||
|
path = path.slice(0, -1);
|
||||||
|
}
|
@ -1,7 +1,7 @@
|
|||||||
diff -u -r ../node-v10.9.0/node.gyp ./node.gyp
|
diff -u -r ../node-v8.12.0/node.gyp ./node.gyp
|
||||||
--- ../node-v10.9.0/node.gyp 2018-08-15 13:53:34.000000000 +0000
|
--- ../node-v8.12.0/node.gyp 2018-09-10 18:47:03.000000000 +0000
|
||||||
+++ ./node.gyp 2018-08-23 20:43:38.262489188 +0000
|
+++ ./node.gyp 2018-09-11 20:53:55.711827836 +0000
|
||||||
@@ -925,72 +925,6 @@
|
@@ -889,70 +889,6 @@
|
||||||
],
|
],
|
||||||
} ],
|
} ],
|
||||||
]
|
]
|
||||||
@ -41,8 +41,6 @@ diff -u -r ../node-v10.9.0/node.gyp ./node.gyp
|
|||||||
- 'test/cctest/test_base64.cc',
|
- 'test/cctest/test_base64.cc',
|
||||||
- 'test/cctest/test_node_postmortem_metadata.cc',
|
- 'test/cctest/test_node_postmortem_metadata.cc',
|
||||||
- 'test/cctest/test_environment.cc',
|
- 'test/cctest/test_environment.cc',
|
||||||
- 'test/cctest/test_platform.cc',
|
|
||||||
- 'test/cctest/test_traced_value.cc',
|
|
||||||
- 'test/cctest/test_util.cc',
|
- 'test/cctest/test_util.cc',
|
||||||
- 'test/cctest/test_url.cc'
|
- 'test/cctest/test_url.cc'
|
||||||
- ],
|
- ],
|
52
disabled-packages/nodejs-lts/src-node.cc.patch
Normal file
52
disabled-packages/nodejs-lts/src-node.cc.patch
Normal file
@ -0,0 +1,52 @@
|
|||||||
|
Without this patch functions such as process.getgroups
|
||||||
|
are not built on Android, which breaks things such as
|
||||||
|
npm/node_modules/which/which.js.
|
||||||
|
|
||||||
|
diff -u -r ../node-v4.0.0/src/node.cc ./src/node.cc
|
||||||
|
--- ../node-v4.0.0/src/node.cc 2015-09-08 11:30:45.000000000 -0400
|
||||||
|
+++ ./src/node.cc 2015-09-08 19:06:39.415724588 -0400
|
||||||
|
@@ -69,7 +69,7 @@
|
||||||
|
#include <unistd.h> // setuid, getuid
|
||||||
|
#endif
|
||||||
|
|
||||||
|
-#if defined(__POSIX__) && !defined(__ANDROID__)
|
||||||
|
+#if defined(__POSIX__)
|
||||||
|
#include <pwd.h> // getpwnam()
|
||||||
|
#include <grp.h> // getgrnam()
|
||||||
|
#endif
|
||||||
|
@@ -1590,7 +1590,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-#if defined(__POSIX__) && !defined(__ANDROID__)
|
||||||
|
+#if defined(__POSIX__)
|
||||||
|
|
||||||
|
static const uid_t uid_not_found = static_cast<uid_t>(-1);
|
||||||
|
static const gid_t gid_not_found = static_cast<gid_t>(-1);
|
||||||
|
@@ -1910,7 +1910,7 @@
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
-#endif // __POSIX__ && !defined(__ANDROID__)
|
||||||
|
+#endif // __POSIX__
|
||||||
|
|
||||||
|
|
||||||
|
void Exit(const FunctionCallbackInfo<Value>& args) {
|
||||||
|
@@ -2866,7 +2866,7 @@
|
||||||
|
|
||||||
|
env->SetMethod(process, "umask", Umask);
|
||||||
|
|
||||||
|
-#if defined(__POSIX__) && !defined(__ANDROID__)
|
||||||
|
+#if defined(__POSIX__)
|
||||||
|
env->SetMethod(process, "getuid", GetUid);
|
||||||
|
env->SetMethod(process, "geteuid", GetEUid);
|
||||||
|
env->SetMethod(process, "setuid", SetUid);
|
||||||
|
@@ -2880,7 +2880,7 @@
|
||||||
|
env->SetMethod(process, "getgroups", GetGroups);
|
||||||
|
env->SetMethod(process, "setgroups", SetGroups);
|
||||||
|
env->SetMethod(process, "initgroups", InitGroups);
|
||||||
|
-#endif // __POSIX__ && !defined(__ANDROID__)
|
||||||
|
+#endif // __POSIX__
|
||||||
|
|
||||||
|
env->SetMethod(process, "_kill", Kill);
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -u -r ../node-v10.9.0/lib/os.js ./lib/os.js
|
|
||||||
--- ../node-v10.9.0/lib/os.js 2018-08-15 13:53:34.000000000 +0000
|
|
||||||
+++ ./lib/os.js 2018-08-23 20:42:39.611186774 +0000
|
|
||||||
@@ -130,7 +130,7 @@
|
|
||||||
path = safeGetenv('TMPDIR') ||
|
|
||||||
safeGetenv('TMP') ||
|
|
||||||
safeGetenv('TEMP') ||
|
|
||||||
- '/tmp';
|
|
||||||
+ '@TERMUX_PREFIX@/tmp';
|
|
||||||
if (path.length > 1 && path.endsWith('/'))
|
|
||||||
path = path.slice(0, -1);
|
|
||||||
}
|
|
@ -1,37 +0,0 @@
|
|||||||
diff -u -r ../node-v10.9.0/src/node.cc ./src/node.cc
|
|
||||||
--- ../node-v10.9.0/src/node.cc 2018-08-15 13:53:34.000000000 +0000
|
|
||||||
+++ ./src/node.cc 2018-08-23 20:49:59.353995878 +0000
|
|
||||||
@@ -106,7 +106,7 @@
|
|
||||||
#include <unistd.h> // setuid, getuid
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#if defined(__POSIX__) && !defined(__ANDROID__) && !defined(__CloudABI__)
|
|
||||||
+#if defined(__POSIX__) && !defined(__CloudABI__)
|
|
||||||
#include <pwd.h> // getpwnam()
|
|
||||||
#include <grp.h> // getgrnam()
|
|
||||||
#endif
|
|
||||||
@@ -690,7 +690,7 @@
|
|
||||||
|
|
||||||
// Look up environment variable unless running as setuid root.
|
|
||||||
bool SafeGetenv(const char* key, std::string* text) {
|
|
||||||
-#if !defined(__CloudABI__) && !defined(_WIN32)
|
|
||||||
+#if !defined(__CloudABI__) && !defined(_WIN32) && !defined(__ANDROID__)
|
|
||||||
if (linux_at_secure || getuid() != geteuid() || getgid() != getegid())
|
|
||||||
goto fail;
|
|
||||||
#endif
|
|
||||||
@@ -2402,13 +2402,13 @@
|
|
||||||
env->SetMethod(process, "reallyExit", Exit);
|
|
||||||
env->SetMethodNoSideEffect(process, "uptime", Uptime);
|
|
||||||
|
|
||||||
-#if defined(__POSIX__) && !defined(__ANDROID__) && !defined(__CloudABI__)
|
|
||||||
+#if defined(__POSIX__) && !defined(__CloudABI__)
|
|
||||||
env->SetMethodNoSideEffect(process, "getuid", GetUid);
|
|
||||||
env->SetMethodNoSideEffect(process, "geteuid", GetEUid);
|
|
||||||
env->SetMethodNoSideEffect(process, "getgid", GetGid);
|
|
||||||
env->SetMethodNoSideEffect(process, "getegid", GetEGid);
|
|
||||||
env->SetMethodNoSideEffect(process, "getgroups", GetGroups);
|
|
||||||
-#endif // __POSIX__ && !defined(__ANDROID__) && !defined(__CloudABI__)
|
|
||||||
+#endif // __POSIX__ && !defined(__CloudABI__)
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
@ -1,8 +1,7 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
|
TERMUX_PKG_HOMEPAGE=https://nodejs.org/
|
||||||
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
|
TERMUX_PKG_DESCRIPTION="Platform built on Chrome's JavaScript runtime for easily building fast, scalable network applications"
|
||||||
TERMUX_PKG_VERSION=8.11.4
|
TERMUX_PKG_VERSION=10.10.0
|
||||||
TERMUX_PKG_REVISION=1
|
TERMUX_PKG_SHA256=860eff976d83dd619849c0b4fab4cadb093ece2c718aaa5af8fb5ebbfa7d8a80
|
||||||
TERMUX_PKG_SHA256=fbce7de6d96b0bcb0db0bf77f0e6ea999b6755e6930568aedaab06847552a609
|
|
||||||
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
|
TERMUX_PKG_SRCURL=https://nodejs.org/dist/v${TERMUX_PKG_VERSION}/node-v${TERMUX_PKG_VERSION}.tar.xz
|
||||||
# Note that we do not use a shared libuv to avoid an issue with the Android
|
# Note that we do not use a shared libuv to avoid an issue with the Android
|
||||||
# linker, which does not use symbols of linked shared libraries when resolving
|
# linker, which does not use symbols of linked shared libraries when resolving
|
||||||
@ -11,8 +10,10 @@ TERMUX_PKG_DEPENDS="openssl, c-ares"
|
|||||||
TERMUX_PKG_RM_AFTER_INSTALL="lib/node_modules/npm/html lib/node_modules/npm/make.bat share/systemtap lib/dtrace"
|
TERMUX_PKG_RM_AFTER_INSTALL="lib/node_modules/npm/html lib/node_modules/npm/make.bat share/systemtap lib/dtrace"
|
||||||
TERMUX_PKG_BUILD_IN_SRC=yes
|
TERMUX_PKG_BUILD_IN_SRC=yes
|
||||||
TERMUX_PKG_CONFLICTS="nodejs-current"
|
TERMUX_PKG_CONFLICTS="nodejs-current"
|
||||||
|
TERMUX_PKG_REPLACES="nodejs-current"
|
||||||
|
|
||||||
termux_step_configure () {
|
termux_step_configure () {
|
||||||
|
local DEST_CPU
|
||||||
if [ $TERMUX_ARCH = "arm" ]; then
|
if [ $TERMUX_ARCH = "arm" ]; then
|
||||||
DEST_CPU="arm"
|
DEST_CPU="arm"
|
||||||
elif [ $TERMUX_ARCH = "i686" ]; then
|
elif [ $TERMUX_ARCH = "i686" ]; then
|
||||||
@ -26,6 +27,9 @@ termux_step_configure () {
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
export GYP_DEFINES="host_os=linux"
|
export GYP_DEFINES="host_os=linux"
|
||||||
|
export CC_host=gcc
|
||||||
|
export CXX_host=g++
|
||||||
|
export LINK_host=g++
|
||||||
|
|
||||||
# See note above TERMUX_PKG_DEPENDS why we do not use a shared libuv.
|
# See note above TERMUX_PKG_DEPENDS why we do not use a shared libuv.
|
||||||
./configure \
|
./configure \
|
||||||
@ -39,4 +43,7 @@ termux_step_configure () {
|
|||||||
--without-intl \
|
--without-intl \
|
||||||
--without-snapshot \
|
--without-snapshot \
|
||||||
--cross-compiling
|
--cross-compiling
|
||||||
|
|
||||||
|
perl -p -i -e 's/LIBS := \$\(LIBS\)/LIBS := -lpthread/' \
|
||||||
|
$TERMUX_PKG_SRCDIR/out/deps/v8/gypfiles/torque.host.mk
|
||||||
}
|
}
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -u -r ../node-v8.1.4/deps/uv/uv.gyp ./deps/uv/uv.gyp
|
diff -u -r ../node-v9.7.1/deps/uv/uv.gyp ./deps/uv/uv.gyp
|
||||||
--- ../node-v8.1.4/deps/uv/uv.gyp 2017-07-11 05:48:01.000000000 +0200
|
--- ../node-v9.7.1/deps/uv/uv.gyp 2018-03-02 01:58:02.000000000 +0000
|
||||||
+++ ./deps/uv/uv.gyp 2017-07-19 01:25:10.988614742 +0200
|
+++ ./deps/uv/uv.gyp 2018-03-05 10:51:15.530165566 +0000
|
||||||
@@ -45,12 +45,12 @@
|
@@ -39,7 +39,7 @@
|
||||||
{
|
{
|
||||||
'target_name': 'libuv',
|
'target_name': 'libuv',
|
||||||
'type': '<(uv_library)',
|
'type': '<(uv_library)',
|
||||||
@ -10,9 +10,12 @@ diff -u -r ../node-v8.1.4/deps/uv/uv.gyp ./deps/uv/uv.gyp
|
|||||||
'include',
|
'include',
|
||||||
'src/',
|
'src/',
|
||||||
],
|
],
|
||||||
'direct_dependent_settings': {
|
@@ -54,7 +54,7 @@
|
||||||
|
'<@(shared_unix_defines)',
|
||||||
|
'<@(shared_zos_defines)',
|
||||||
|
],
|
||||||
- 'include_dirs': [ 'include' ],
|
- 'include_dirs': [ 'include' ],
|
||||||
+ 'include_dirs+': [ 'include' ],
|
+ 'include_dirs+': [ 'include' ],
|
||||||
'conditions': [
|
'conditions': [
|
||||||
['OS != "win"', {
|
['OS == "linux"', {
|
||||||
'defines': [
|
'defines': [ '_POSIX_C_SOURCE=200112' ],
|
||||||
|
@ -1,10 +1,10 @@
|
|||||||
diff -u -r ../node-v5.10.0/lib/os.js ./lib/os.js
|
diff -u -r ../node-v10.9.0/lib/os.js ./lib/os.js
|
||||||
--- ../node-v5.10.0/lib/os.js 2016-03-31 21:52:17.000000000 -0400
|
--- ../node-v10.9.0/lib/os.js 2018-08-15 13:53:34.000000000 +0000
|
||||||
+++ ./lib/os.js 2016-04-04 04:46:05.148105544 -0400
|
+++ ./lib/os.js 2018-08-23 20:42:39.611186774 +0000
|
||||||
@@ -36,7 +36,7 @@
|
@@ -130,7 +130,7 @@
|
||||||
path = process.env.TMPDIR ||
|
path = safeGetenv('TMPDIR') ||
|
||||||
process.env.TMP ||
|
safeGetenv('TMP') ||
|
||||||
process.env.TEMP ||
|
safeGetenv('TEMP') ||
|
||||||
- '/tmp';
|
- '/tmp';
|
||||||
+ '@TERMUX_PREFIX@/tmp';
|
+ '@TERMUX_PREFIX@/tmp';
|
||||||
if (path.length > 1 && path.endsWith('/'))
|
if (path.length > 1 && path.endsWith('/'))
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -u -r ../node-v8.11.2/node.gyp ./node.gyp
|
diff -u -r ../node-v10.9.0/node.gyp ./node.gyp
|
||||||
--- ../node-v8.11.2/node.gyp 2018-05-15 19:09:49.000000000 +0000
|
--- ../node-v10.9.0/node.gyp 2018-08-15 13:53:34.000000000 +0000
|
||||||
+++ ./node.gyp 2018-05-18 01:32:14.331981675 +0000
|
+++ ./node.gyp 2018-08-23 20:43:38.262489188 +0000
|
||||||
@@ -876,191 +876,6 @@
|
@@ -925,72 +925,6 @@
|
||||||
],
|
],
|
||||||
} ],
|
} ],
|
||||||
]
|
]
|
||||||
@ -11,7 +11,7 @@ diff -u -r ../node-v8.11.2/node.gyp ./node.gyp
|
|||||||
- 'type': 'executable',
|
- 'type': 'executable',
|
||||||
-
|
-
|
||||||
- 'dependencies': [
|
- 'dependencies': [
|
||||||
- '<(node_core_target_name)',
|
- '<(node_lib_target_name)',
|
||||||
- 'rename_node_bin_win',
|
- 'rename_node_bin_win',
|
||||||
- 'deps/gtest/gtest.gyp:gtest',
|
- 'deps/gtest/gtest.gyp:gtest',
|
||||||
- 'node_js2c#host',
|
- 'node_js2c#host',
|
||||||
@ -20,39 +20,6 @@ diff -u -r ../node-v8.11.2/node.gyp ./node.gyp
|
|||||||
- 'node_dtrace_provider',
|
- 'node_dtrace_provider',
|
||||||
- ],
|
- ],
|
||||||
-
|
-
|
||||||
- 'variables': {
|
|
||||||
- 'OBJ_PATH': '<(OBJ_DIR)/<(node_lib_target_name)/src',
|
|
||||||
- 'OBJ_GEN_PATH': '<(OBJ_DIR)/<(node_lib_target_name)/gen',
|
|
||||||
- 'OBJ_TRACING_PATH': '<(OBJ_DIR)/<(node_lib_target_name)/src/tracing',
|
|
||||||
- 'OBJ_SUFFIX': 'o',
|
|
||||||
- 'OBJ_SEPARATOR': '/',
|
|
||||||
- 'conditions': [
|
|
||||||
- ['OS=="win"', {
|
|
||||||
- 'OBJ_SUFFIX': 'obj',
|
|
||||||
- }],
|
|
||||||
- ['GENERATOR=="ninja"', {
|
|
||||||
- 'OBJ_PATH': '<(OBJ_DIR)/src',
|
|
||||||
- 'OBJ_GEN_PATH': '<(OBJ_DIR)/gen',
|
|
||||||
- 'OBJ_TRACING_PATH': '<(OBJ_DIR)/src/tracing',
|
|
||||||
- 'OBJ_SEPARATOR': '/<(node_lib_target_name).',
|
|
||||||
- }, {
|
|
||||||
- 'conditions': [
|
|
||||||
- ['OS=="win"', {
|
|
||||||
- 'OBJ_PATH': '<(OBJ_DIR)/<(node_lib_target_name)',
|
|
||||||
- 'OBJ_GEN_PATH': '<(OBJ_DIR)/<(node_lib_target_name)',
|
|
||||||
- 'OBJ_TRACING_PATH': '<(OBJ_DIR)/<(node_lib_target_name)',
|
|
||||||
- }],
|
|
||||||
- ['OS=="aix"', {
|
|
||||||
- 'OBJ_PATH': '<(OBJ_DIR)/<(node_lib_target_name)/src',
|
|
||||||
- 'OBJ_GEN_PATH': '<(OBJ_DIR)/<(node_lib_target_name)/gen',
|
|
||||||
- 'OBJ_TRACING_PATH':
|
|
||||||
- '<(OBJ_DIR)/<(node_lib_target_name)/src/tracing',
|
|
||||||
- }],
|
|
||||||
- ]}
|
|
||||||
- ]
|
|
||||||
- ],
|
|
||||||
- },
|
|
||||||
-
|
|
||||||
- 'includes': [
|
- 'includes': [
|
||||||
- 'node.gypi'
|
- 'node.gypi'
|
||||||
- ],
|
- ],
|
||||||
@ -69,127 +36,41 @@ diff -u -r ../node-v8.11.2/node.gyp ./node.gyp
|
|||||||
- 'defines': [ 'NODE_WANT_INTERNALS=1' ],
|
- 'defines': [ 'NODE_WANT_INTERNALS=1' ],
|
||||||
-
|
-
|
||||||
- 'sources': [
|
- 'sources': [
|
||||||
- 'test/cctest/node_module_reg.cc',
|
|
||||||
- 'test/cctest/node_test_fixture.cc',
|
- 'test/cctest/node_test_fixture.cc',
|
||||||
- 'test/cctest/test_aliased_buffer.cc',
|
- 'test/cctest/test_aliased_buffer.cc',
|
||||||
- 'test/cctest/test_base64.cc',
|
- 'test/cctest/test_base64.cc',
|
||||||
|
- 'test/cctest/test_node_postmortem_metadata.cc',
|
||||||
- 'test/cctest/test_environment.cc',
|
- 'test/cctest/test_environment.cc',
|
||||||
|
- 'test/cctest/test_platform.cc',
|
||||||
|
- 'test/cctest/test_traced_value.cc',
|
||||||
- 'test/cctest/test_util.cc',
|
- 'test/cctest/test_util.cc',
|
||||||
- 'test/cctest/test_url.cc'
|
- 'test/cctest/test_url.cc'
|
||||||
- ],
|
- ],
|
||||||
-
|
-
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)async_wrap.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)env.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_buffer.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_debug_options.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_i18n.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_perf.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_platform.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_url.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)util.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)string_bytes.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)string_search.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)stream_base.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_constants.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_TRACING_PATH)<(OBJ_SEPARATOR)agent.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_TRACING_PATH)<(OBJ_SEPARATOR)node_trace_buffer.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_TRACING_PATH)<(OBJ_SEPARATOR)node_trace_writer.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_TRACING_PATH)<(OBJ_SEPARATOR)trace_event.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_GEN_PATH)<(OBJ_SEPARATOR)node_javascript.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
-
|
|
||||||
- 'conditions': [
|
- 'conditions': [
|
||||||
- [ 'node_use_openssl=="true"', {
|
- [ 'node_use_openssl=="true"', {
|
||||||
- 'conditions': [
|
|
||||||
- ['node_target_type!="static_library"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_crypto.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_crypto_bio.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_crypto_clienthello.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)tls_wrap.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
- }],
|
|
||||||
- ],
|
|
||||||
- 'defines': [
|
- 'defines': [
|
||||||
- 'HAVE_OPENSSL=1',
|
- 'HAVE_OPENSSL=1',
|
||||||
- ],
|
- ],
|
||||||
- }],
|
- }],
|
||||||
- [ 'node_use_perfctr=="true"', {
|
- [ 'node_use_perfctr=="true"', {
|
||||||
- 'defines': [ 'HAVE_PERFCTR=1' ],
|
- 'defines': [ 'HAVE_PERFCTR=1' ],
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_counters.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)'
|
|
||||||
- 'node_win32_perfctr_provider.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
- }],
|
- }],
|
||||||
- ['v8_enable_inspector==1', {
|
- ['v8_enable_inspector==1', {
|
||||||
- 'sources': [
|
- 'sources': [
|
||||||
- 'test/cctest/test_inspector_socket.cc',
|
- 'test/cctest/test_inspector_socket.cc',
|
||||||
- 'test/cctest/test_inspector_socket_server.cc'
|
- 'test/cctest/test_inspector_socket_server.cc'
|
||||||
- ],
|
- ],
|
||||||
- 'conditions': [
|
|
||||||
- ['node_target_type!="static_library"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)inspector_agent.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)inspector_io.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)inspector_js_api.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)inspector_socket.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)inspector_socket_server.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
- }],
|
|
||||||
- ],
|
|
||||||
- 'defines': [
|
- 'defines': [
|
||||||
- 'HAVE_INSPECTOR=1',
|
- 'HAVE_INSPECTOR=1',
|
||||||
- ],
|
- ],
|
||||||
- }],
|
|
||||||
- [ 'node_use_dtrace=="true" and node_target_type!="static_library"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_dtrace.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
- 'conditions': [
|
|
||||||
- ['OS!="mac" and OS!="linux"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_dtrace_provider.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_dtrace_ustack.<(OBJ_SUFFIX)',
|
|
||||||
- ]
|
|
||||||
- }],
|
|
||||||
- ['OS=="linux"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(SHARED_INTERMEDIATE_DIR)<(OBJ_SEPARATOR)'
|
|
||||||
- 'node_dtrace_provider.<(OBJ_SUFFIX)',
|
|
||||||
- ]
|
|
||||||
- }],
|
|
||||||
- ],
|
|
||||||
- }, {
|
- }, {
|
||||||
- 'conditions': [
|
- 'defines': [ 'HAVE_INSPECTOR=0' ]
|
||||||
- [ 'node_use_etw=="true" and OS=="win"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)node_dtrace.<(OBJ_SUFFIX)',
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)'
|
|
||||||
- 'node_win32_etw_provider.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
- }]
|
|
||||||
- ]
|
|
||||||
- }],
|
|
||||||
- [ 'OS=="win" and node_target_type!="static_library"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)backtrace_win32.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
- }, {
|
|
||||||
- 'conditions': [
|
|
||||||
- ['node_target_type!="static_library"', {
|
|
||||||
- 'libraries': [
|
|
||||||
- '<(OBJ_PATH)<(OBJ_SEPARATOR)backtrace_posix.<(OBJ_SUFFIX)',
|
|
||||||
- ],
|
|
||||||
- }],
|
|
||||||
- ],
|
|
||||||
- }],
|
- }],
|
||||||
- ['OS=="solaris"', {
|
- ['OS=="solaris"', {
|
||||||
- 'ldflags': [ '-I<(SHARED_INTERMEDIATE_DIR)' ]
|
- 'ldflags': [ '-I<(SHARED_INTERMEDIATE_DIR)' ]
|
||||||
- }],
|
- }],
|
||||||
- ]
|
- ],
|
||||||
}
|
}
|
||||||
], # end targets
|
], # end targets
|
||||||
|
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -u -r ../node-v0.12.7/deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js ./deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js
|
|
||||||
--- ../node-v0.12.7/deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js 2015-07-09 18:41:19.000000000 -0400
|
|
||||||
+++ ./deps/npm/node_modules/osenv/node_modules/os-tmpdir/index.js 2015-07-24 20:56:42.278310940 -0400
|
|
||||||
@@ -14,7 +14,7 @@
|
|
||||||
path = process.env.TMPDIR ||
|
|
||||||
process.env.TMP ||
|
|
||||||
process.env.TEMP ||
|
|
||||||
- '/tmp';
|
|
||||||
+ '@TERMUX_PREFIX@/tmp';
|
|
||||||
}
|
|
||||||
|
|
||||||
if (trailingSlashRe.test(path)) {
|
|
@ -1,52 +1,37 @@
|
|||||||
Without this patch functions such as process.getgroups
|
diff -u -r ../node-v10.9.0/src/node.cc ./src/node.cc
|
||||||
are not built on Android, which breaks things such as
|
--- ../node-v10.9.0/src/node.cc 2018-08-15 13:53:34.000000000 +0000
|
||||||
npm/node_modules/which/which.js.
|
+++ ./src/node.cc 2018-08-23 20:49:59.353995878 +0000
|
||||||
|
@@ -106,7 +106,7 @@
|
||||||
diff -u -r ../node-v4.0.0/src/node.cc ./src/node.cc
|
|
||||||
--- ../node-v4.0.0/src/node.cc 2015-09-08 11:30:45.000000000 -0400
|
|
||||||
+++ ./src/node.cc 2015-09-08 19:06:39.415724588 -0400
|
|
||||||
@@ -69,7 +69,7 @@
|
|
||||||
#include <unistd.h> // setuid, getuid
|
#include <unistd.h> // setuid, getuid
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
-#if defined(__POSIX__) && !defined(__ANDROID__)
|
-#if defined(__POSIX__) && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||||
+#if defined(__POSIX__)
|
+#if defined(__POSIX__) && !defined(__CloudABI__)
|
||||||
#include <pwd.h> // getpwnam()
|
#include <pwd.h> // getpwnam()
|
||||||
#include <grp.h> // getgrnam()
|
#include <grp.h> // getgrnam()
|
||||||
#endif
|
#endif
|
||||||
@@ -1590,7 +1590,7 @@
|
@@ -690,7 +690,7 @@
|
||||||
|
|
||||||
|
// Look up environment variable unless running as setuid root.
|
||||||
|
bool SafeGetenv(const char* key, std::string* text) {
|
||||||
|
-#if !defined(__CloudABI__) && !defined(_WIN32)
|
||||||
|
+#if !defined(__CloudABI__) && !defined(_WIN32) && !defined(__ANDROID__)
|
||||||
|
if (linux_at_secure || getuid() != geteuid() || getgid() != getegid())
|
||||||
|
goto fail;
|
||||||
|
#endif
|
||||||
|
@@ -2402,13 +2402,13 @@
|
||||||
|
env->SetMethod(process, "reallyExit", Exit);
|
||||||
|
env->SetMethodNoSideEffect(process, "uptime", Uptime);
|
||||||
|
|
||||||
|
-#if defined(__POSIX__) && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||||
|
+#if defined(__POSIX__) && !defined(__CloudABI__)
|
||||||
|
env->SetMethodNoSideEffect(process, "getuid", GetUid);
|
||||||
|
env->SetMethodNoSideEffect(process, "geteuid", GetEUid);
|
||||||
|
env->SetMethodNoSideEffect(process, "getgid", GetGid);
|
||||||
|
env->SetMethodNoSideEffect(process, "getegid", GetEGid);
|
||||||
|
env->SetMethodNoSideEffect(process, "getgroups", GetGroups);
|
||||||
|
-#endif // __POSIX__ && !defined(__ANDROID__) && !defined(__CloudABI__)
|
||||||
|
+#endif // __POSIX__ && !defined(__CloudABI__)
|
||||||
}
|
}
|
||||||
|
|
||||||
|
|
||||||
-#if defined(__POSIX__) && !defined(__ANDROID__)
|
|
||||||
+#if defined(__POSIX__)
|
|
||||||
|
|
||||||
static const uid_t uid_not_found = static_cast<uid_t>(-1);
|
|
||||||
static const gid_t gid_not_found = static_cast<gid_t>(-1);
|
|
||||||
@@ -1910,7 +1910,7 @@
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
-#endif // __POSIX__ && !defined(__ANDROID__)
|
|
||||||
+#endif // __POSIX__
|
|
||||||
|
|
||||||
|
|
||||||
void Exit(const FunctionCallbackInfo<Value>& args) {
|
|
||||||
@@ -2866,7 +2866,7 @@
|
|
||||||
|
|
||||||
env->SetMethod(process, "umask", Umask);
|
|
||||||
|
|
||||||
-#if defined(__POSIX__) && !defined(__ANDROID__)
|
|
||||||
+#if defined(__POSIX__)
|
|
||||||
env->SetMethod(process, "getuid", GetUid);
|
|
||||||
env->SetMethod(process, "geteuid", GetEUid);
|
|
||||||
env->SetMethod(process, "setuid", SetUid);
|
|
||||||
@@ -2880,7 +2880,7 @@
|
|
||||||
env->SetMethod(process, "getgroups", GetGroups);
|
|
||||||
env->SetMethod(process, "setgroups", SetGroups);
|
|
||||||
env->SetMethod(process, "initgroups", InitGroups);
|
|
||||||
-#endif // __POSIX__ && !defined(__ANDROID__)
|
|
||||||
+#endif // __POSIX__
|
|
||||||
|
|
||||||
env->SetMethod(process, "_kill", Kill);
|
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://yarnpkg.com/
|
TERMUX_PKG_HOMEPAGE=https://yarnpkg.com/
|
||||||
TERMUX_PKG_DESCRIPTION="Fast, reliable, and secure dependency management"
|
TERMUX_PKG_DESCRIPTION="Fast, reliable, and secure dependency management"
|
||||||
TERMUX_PKG_MAINTAINER="Pierre Rudloff @Rudloff"
|
TERMUX_PKG_MAINTAINER="Pierre Rudloff @Rudloff"
|
||||||
TERMUX_PKG_DEPENDS="nodejs | nodejs-current"
|
TERMUX_PKG_DEPENDS="nodejs"
|
||||||
TERMUX_PKG_VERSION=1.9.4
|
TERMUX_PKG_VERSION=1.9.4
|
||||||
TERMUX_PKG_SHA256=7667eb715077b4bad8e2a832e7084e0e6f1ba54d7280dc573c8f7031a7fb093e
|
TERMUX_PKG_SHA256=7667eb715077b4bad8e2a832e7084e0e6f1ba54d7280dc573c8f7031a7fb093e
|
||||||
TERMUX_PKG_SRCURL=https://yarnpkg.com/downloads/${TERMUX_PKG_VERSION}/yarn-v${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://yarnpkg.com/downloads/${TERMUX_PKG_VERSION}/yarn-v${TERMUX_PKG_VERSION}.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user