fix build failure for thunar and xfdesktop

This commit is contained in:
Leonid Pliushch 2020-06-22 16:29:38 +03:00 committed by Yaksh Bariya
parent 0689c680c3
commit b4a997c837
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
5 changed files with 35 additions and 12 deletions

View File

@ -7,3 +7,8 @@ TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://gitlab.xfce.org/xfce/thunar/-/archive/thunar-${TERMUX_PKG_VERSION}/thunar-thunar-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=c9b99606cad98fdaad039bae052ce9ee4376ef7b4844bbd458d1390342a8299e
TERMUX_PKG_DEPENDS="desktop-file-utils, exo, hicolor-icon-theme, libexif, libnotify, libpng, libxfce4ui, libxfce4util"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-maintainer-mode"
termux_step_pre_configure() {
NOCONFIGURE=1 ./autogen.sh
}

View File

@ -1,11 +1,12 @@
--- ./icons/Makefile.in.orig 2019-08-12 15:22:05.567441602 +0300
+++ ./icons/Makefile.in 2019-08-12 15:22:21.499874003 +0300
@@ -448,7 +448,7 @@
diff -uNr thunar-thunar-4.15.0/icons/Makefile.am thunar-thunar-4.15.0.mod/icons/Makefile.am
--- thunar-thunar-4.15.0/icons/Makefile.am 2020-06-19 01:50:01.000000000 +0300
+++ thunar-thunar-4.15.0.mod/icons/Makefile.am 2020-06-22 15:54:54.826868756 +0300
@@ -5,7 +5,7 @@
128x128 \
scalable
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+gtk_update_icon_cache = true
all: all-recursive
.SUFFIXES:
install-data-hook:
@-if test -z "$(DESTDIR)"; then \

View File

@ -0,0 +1,12 @@
diff -uNr thunar-thunar-4.15.0/plugins/thunar-uca/Makefile.am thunar-thunar-4.15.0.mod/plugins/thunar-uca/Makefile.am
--- thunar-thunar-4.15.0/plugins/thunar-uca/Makefile.am 2020-06-19 01:50:01.000000000 +0300
+++ thunar-thunar-4.15.0.mod/plugins/thunar-uca/Makefile.am 2020-06-22 16:18:21.197997945 +0300
@@ -57,7 +57,7 @@
thunar_uca_templates = \
thunar-uca-ui.xml
-GLIB_COMPILE_RESOURCES = $(shell $(PKG_CONFIG) --variable=glib_compile_resources gio-2.0)
+GLIB_COMPILE_RESOURCES = glib-compile-resources
resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/thunar-uca.gresource.xml)

View File

@ -3,8 +3,12 @@ TERMUX_PKG_DESCRIPTION="A desktop manager for XFCE environment"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="Leonid Pliushch <leonid.pliushch@gmail.com>"
TERMUX_PKG_VERSION=4.15.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://gitlab.xfce.org/lastonestanding/xfdesktop/-/archive/xfdesktop-${TERMUX_PKG_VERSION}/xfdesktop-xfdesktop-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=d1b44662fe4f063f349a4f72d1edebfdbf50697be29ee1055ee0c9c162080d62
TERMUX_PKG_DEPENDS="exo, garcon, hicolor-icon-theme, libwnck, libxfce4ui, startup-notification, thunar"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-notifications"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-notifications --enable-maintainer-mode"
termux_step_pre_configure() {
NOCONFIGURE=1 ./autogen.sh
}

View File

@ -1,11 +1,12 @@
--- xfdesktop-4.12.4/pixmaps/Makefile.in 2017-06-26 19:22:42.000000000 +0530
+++ xfdesktop/pixmaps/Makefile.in 2019-02-02 11:30:38.239600497 +0530
@@ -409,7 +409,7 @@
diff -uNr xfdesktop-xfdesktop-4.15.0/pixmaps/Makefile.am xfdesktop-xfdesktop-4.15.0.mod/pixmaps/Makefile.am
--- xfdesktop-xfdesktop-4.15.0/pixmaps/Makefile.am 2020-06-19 02:20:25.000000000 +0300
+++ xfdesktop-xfdesktop-4.15.0.mod/pixmaps/Makefile.am 2020-06-22 16:03:49.597436313 +0300
@@ -40,7 +40,7 @@
$(pixmaps_DATA) \
$(pixmapsx_DATA)
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+gtk_update_icon_cache = true
all: all-am
.SUFFIXES:
install-data-hook:
@-if test -z "$(DESTDIR)"; then \