libepoxy: remove unneeded patches
This commit is contained in:
parent
398ff36ff3
commit
b4d69be837
@ -3,12 +3,14 @@ TERMUX_PKG_DESCRIPTION="Library handling OpenGL function pointer management"
|
||||
TERMUX_PKG_LICENSE="MIT"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=1.5.3
|
||||
TERMUX_PKG_REVISION=3
|
||||
TERMUX_PKG_REVISION=4
|
||||
TERMUX_PKG_SRCURL=https://github.com/anholt/libepoxy/releases/download/${TERMUX_PKG_VERSION}/libepoxy-${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=002958c5528321edd53440235d3c44e71b5b1e09b9177e8daf677450b6c4433d
|
||||
TERMUX_PKG_DEPENDS="mesa"
|
||||
|
||||
termux_step_pre_configure () {
|
||||
export EGL_CFLAGS=${CFLAGS}
|
||||
export EGL_LIBS="-L${TERMUX_STANDALONE_TOOLCHAIN}/sysroot/lib -lEGL"
|
||||
}
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
-Dglx=yes
|
||||
-Degl=no
|
||||
-Dx11=true
|
||||
-Dtests=false
|
||||
"
|
||||
|
@ -1,9 +0,0 @@
|
||||
diff -uNr libepoxy-1.5.3/epoxy.pc.in libepoxy-1.5.3.mod/epoxy.pc.in
|
||||
--- libepoxy-1.5.3/epoxy.pc.in 2018-10-05 02:40:48.000000000 +0300
|
||||
+++ libepoxy-1.5.3.mod/epoxy.pc.in 2018-10-06 21:07:20.967823671 +0300
|
||||
@@ -13,4 +13,4 @@
|
||||
Cflags: -I${includedir}
|
||||
Libs: -L${libdir} -lepoxy
|
||||
Libs.private: @DLOPEN_LIBS@
|
||||
-Requires.private: @GL_REQS@
|
||||
+Requires.private: gl
|
@ -1,20 +0,0 @@
|
||||
diff -uNr libepoxy-1.5.3/meson.build libepoxy-1.5.3.mod/meson.build
|
||||
--- libepoxy-1.5.3/meson.build 2018-10-05 02:40:48.000000000 +0300
|
||||
+++ libepoxy-1.5.3.mod/meson.build 2018-10-06 21:13:18.854247131 +0300
|
||||
@@ -36,7 +36,7 @@
|
||||
# support on Linux and Unix
|
||||
enable_glx = get_option('glx')
|
||||
if enable_glx == 'auto'
|
||||
- build_glx = not ['windows', 'darwin', 'android', 'haiku'].contains(host_system)
|
||||
+ build_glx = not ['windows', 'darwin', 'haiku'].contains(host_system)
|
||||
else
|
||||
build_glx = enable_glx == 'yes'
|
||||
endif
|
||||
@@ -211,6 +211,7 @@
|
||||
wgl_registry = files('registry/wgl.xml')
|
||||
|
||||
libepoxy_inc = [
|
||||
+ include_directories('@TERMUX_PREFIX@/include'),
|
||||
include_directories('include'),
|
||||
include_directories('src'),
|
||||
]
|
@ -1,25 +0,0 @@
|
||||
diff -uNr libepoxy-1.5.3/meson_options.txt libepoxy-1.5.3.mod/meson_options.txt
|
||||
--- libepoxy-1.5.3/meson_options.txt 2018-10-05 02:40:48.000000000 +0300
|
||||
+++ libepoxy-1.5.3.mod/meson_options.txt 2018-10-06 21:10:32.422811017 +0300
|
||||
@@ -4,12 +4,12 @@
|
||||
option('glx',
|
||||
type: 'combo',
|
||||
choices: [ 'auto', 'yes', 'no' ],
|
||||
- value: 'auto',
|
||||
+ value: 'yes',
|
||||
description: 'Enable GLX support')
|
||||
option('egl',
|
||||
type: 'combo',
|
||||
choices: [ 'auto', 'yes', 'no' ],
|
||||
- value: 'auto',
|
||||
+ value: 'no',
|
||||
description: 'Enable EGL support')
|
||||
option('x11',
|
||||
type: 'boolean',
|
||||
@@ -17,5 +17,5 @@
|
||||
description: 'Enable X11 support (GLX or EGL-X11)')
|
||||
option('tests',
|
||||
type: 'boolean',
|
||||
- value: true,
|
||||
+ value: false,
|
||||
description: 'Build the test suite')
|
Loading…
Reference in New Issue
Block a user