emscripten: update patches

This commit is contained in:
Jia Yuan Lo 2021-11-27 14:07:35 +08:00 committed by Henrik Grimler
parent a8d89fe3a3
commit b4ef578a82
3 changed files with 10 additions and 10 deletions

View File

@ -1,7 +1,7 @@
diff -uNr llvm-project/clang/lib/Driver/ToolChain.cpp llvm-project.mod/clang/lib/Driver/ToolChain.cpp
--- llvm-project/clang/lib/Driver/ToolChain.cpp 2021-11-04 18:24:28.000000000 +0800
+++ llvm-project.mod/clang/lib/Driver/ToolChain.cpp 2021-11-14 21:15:21.092854100 +0800
@@ -406,7 +406,7 @@
--- llvm-project/clang/lib/Driver/ToolChain.cpp 2021-11-27 10:21:24.849951600 +0800
+++ llvm-project.mod/clang/lib/Driver/ToolChain.cpp 2021-11-27 12:35:59.478509300 +0800
@@ -403,7 +403,7 @@
case llvm::Triple::AIX:
return "aix";
default:
@ -10,7 +10,7 @@ diff -uNr llvm-project/clang/lib/Driver/ToolChain.cpp llvm-project.mod/clang/lib
}
}
@@ -944,7 +944,7 @@
@@ -941,7 +941,7 @@
switch (Type) {
case ToolChain::CST_Libcxx:

View File

@ -1,6 +1,6 @@
diff -uNr llvm-project/compiler-rt/CMakeLists.txt llvm-project.mod/compiler-rt/CMakeLists.txt
--- llvm-project/compiler-rt/CMakeLists.txt 2021-10-20 02:24:04.000000000 +0800
+++ llvm-project.mod/compiler-rt/CMakeLists.txt 2021-10-29 15:54:24.623927409 +0800
--- llvm-project/compiler-rt/CMakeLists.txt 2021-11-27 10:22:13.468604500 +0800
+++ llvm-project.mod/compiler-rt/CMakeLists.txt 2021-11-27 12:36:17.443010100 +0800
@@ -201,6 +201,9 @@
elseif (FUCHSIA)
set(${var}_LIBNAME "libc++")
@ -20,7 +20,7 @@ diff -uNr llvm-project/compiler-rt/CMakeLists.txt llvm-project.mod/compiler-rt/C
set_property(CACHE SANITIZER_CXX_ABI PROPERTY STRINGS ;${CXXABIS})
handle_default_cxx_lib(SANITIZER_CXX_ABI)
@@ -524,6 +527,8 @@
@@ -526,6 +529,8 @@
list(APPEND SANITIZER_CXX_ABI_LIBRARIES "c++abi")
elseif (SANITIZER_CXX_ABI_LIBNAME STREQUAL "libstdc++")
append_list_if(COMPILER_RT_HAS_LIBSTDCXX stdc++ SANITIZER_CXX_ABI_LIBRARIES)

View File

@ -1,7 +1,7 @@
diff -uNr llvm-project/libunwind/CMakeLists.txt llvm-project.mod/libunwind/CMakeLists.txt
--- llvm-project/libunwind/CMakeLists.txt 2021-10-20 02:24:04.000000000 +0800
+++ llvm-project.mod/libunwind/CMakeLists.txt 2021-10-29 10:02:54.163942494 +0800
@@ -194,6 +194,10 @@
--- llvm-project/libunwind/CMakeLists.txt 2021-11-27 10:22:36.327950400 +0800
+++ llvm-project.mod/libunwind/CMakeLists.txt 2021-11-27 12:36:37.310685400 +0800
@@ -212,6 +212,10 @@
add_compile_flags_if_supported(-Werror=return-type)
if (LIBUNWIND_ENABLE_CET)