add package wireless-tools

This commit is contained in:
Leonid Plyushch 2017-11-05 11:15:36 +02:00 committed by Yaksh Bariya
parent 4441aaa75e
commit b531f68564
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
2 changed files with 53 additions and 0 deletions

View File

@ -0,0 +1,38 @@
diff -uNr wireless_tools.30/Makefile wireless_tools.30.mod2/Makefile
--- wireless_tools.30/Makefile 2009-11-24 20:53:40.000000000 +0200
+++ wireless_tools.30.mod2/Makefile 2017-10-17 11:55:09.020967925 +0300
@@ -5,11 +5,11 @@
## Installation directory. By default, go in /usr/local.
## Distributions should probably use /, but they probably know better...
ifndef PREFIX
- PREFIX = /usr/local
+ PREFIX = /data/data/com.termux/files/usr
endif
## Compiler to use (modify this for cross compile).
-CC = gcc
+CC ?= clang
## Other tools you need to modify for cross compile (static lib only).
AR = ar
RANLIB = ranlib
@@ -73,10 +73,10 @@
DYNAMIC_LINK= libiw.so
# Install directories
-INSTALL_DIR= $(PREFIX)/sbin
+INSTALL_DIR= $(PREFIX)/bin
INSTALL_LIB= $(PREFIX)/lib
INSTALL_INC= $(PREFIX)/include
-INSTALL_MAN= $(PREFIX)/man
+INSTALL_MAN= $(PREFIX)/share/man
# Various commands
RM = rm -f
@@ -205,6 +205,7 @@
clean::
$(RM_CMD)
+ $(RM) $(PROGS)
realclean::
$(RM_CMD)

View File

@ -0,0 +1,15 @@
TERMUX_PKG_HOMEPAGE=https://hewlettpackard.github.io/wireless-tools/Tools.html
TERMUX_PKG_DESCRIPTION="Tools allowing to manipulate the Wireless Extensions"
TERMUX_PKG_VERSION=30pre9
TERMUX_PKG_SRCURL=https://hewlettpackard.github.io/wireless-tools/wireless_tools.30.pre9.tar.gz
TERMUX_PKG_SHA256=abd9c5c98abf1fdd11892ac2f8a56737544fe101e1be27c6241a564948f34c63
TERMUX_PKG_BUILD_IN_SRC=yes
termux_step_make () {
make \
CC="$CC" \
CFLAGS="$CFLAGS $CPPFLAGS -fPIE -pie" \
LDFLAGS="$LDFLAGS -fPIE -pie" \
PREFIX="${TERMUX_PREFIX}"
}