add xfce components
This commit is contained in:
parent
6ee26a6f10
commit
b84e74e2ce
13
x11-packages/exo/build.sh
Normal file
13
x11-packages/exo/build.sh
Normal file
@ -0,0 +1,13 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Application library for XFCE"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0, LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=0.12.8
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/exo/${TERMUX_PKG_VERSION:0:4}/exo-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=3400a2e64aa41ede25bedaca4909bde7ea4f8698d9598d1b80f02a40ac89fcde
|
||||
TERMUX_PKG_DEPENDS="hicolor-icon-theme, libxfce4ui"
|
||||
TERMUX_PKG_CONFLICTS="libexo"
|
||||
TERMUX_PKG_REPLACES="libexo"
|
||||
TERMUX_PKG_PROVIDES="libexo"
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="share/icons/hicolor/icon-theme.cache"
|
11
x11-packages/garcon/build.sh
Normal file
11
x11-packages/garcon/build.sh
Normal file
@ -0,0 +1,11 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Implementation of the freedesktop.org menu specification"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=0.6.4
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/garcon/${TERMUX_PKG_VERSION:0:3}/garcon-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=d75e4753037a74733c07b71b8db7a656d869869f0f107f6411a306bbc87a762d
|
||||
TERMUX_PKG_DEPENDS="libxfce4ui"
|
||||
TERMUX_PKG_CONFLICTS="libgarcon"
|
||||
TERMUX_PKG_REPLACES="libgarcon"
|
||||
TERMUX_PKG_PROVIDES="libgarcon"
|
18
x11-packages/iso-codes/build.sh
Normal file
18
x11-packages/iso-codes/build.sh
Normal file
@ -0,0 +1,18 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://salsa.debian.org/iso-codes-team/iso-codes
|
||||
TERMUX_PKG_DESCRIPTION="Lists of the country, language, and currency names"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=4.1
|
||||
TERMUX_PKG_SRCURL=https://salsa.debian.org/iso-codes-team/iso-codes/uploads/049ce6aac94d842be809f4063950646c/iso-codes-$TERMUX_PKG_VERSION.tar.xz
|
||||
TERMUX_PKG_SHA256=67117fb76f32c8fb5e37d2d60bce238f1f8e865cc7b569a57cbc3017ca15488a
|
||||
TERMUX_PKG_PLATFORM_INDEPENDENT=true
|
||||
|
||||
#If you install ISO codes over a previous installed version, the install step will fail when creating some symlinks
|
||||
|
||||
termux_step_post_configure() {
|
||||
sed -i '/^LN_S/s/s/sfvn/' */Makefile
|
||||
}
|
||||
|
||||
termux_step_make_install() {
|
||||
make pkgconfigdir=$TERMUX_PREFIX/lib/pkgconfig install
|
||||
}
|
@ -1,9 +0,0 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Exo is a support library used in the Xfce desktop. It also has some helper applications that are used throughout Xfce."
|
||||
TERMUX_PKG_VERSION=0.12.8
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/exo/0.12/exo-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=3400a2e64aa41ede25bedaca4909bde7ea4f8698d9598d1b80f02a40ac89fcde
|
||||
TERMUX_PKG_DEPENDS="gtk3, libxfce4ui, libxfce4util"
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="share/icons/hicolor/icon-theme.cache"
|
13
x11-packages/libwnck/build.sh
Normal file
13
x11-packages/libwnck/build.sh
Normal file
@ -0,0 +1,13 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://gitlab.gnome.org/GNOME/libwnck
|
||||
TERMUX_PKG_DESCRIPTION="Window Navigator Construction Kit"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=3.32.0
|
||||
TERMUX_PKG_SRCURL=http://ftp.gnome.org/pub/gnome/sources/libwnck/${TERMUX_PKG_VERSION:0:4}/libwnck-$TERMUX_PKG_VERSION.tar.xz
|
||||
TERMUX_PKG_SHA256=9595835cf28d0fc6af5526a18f77f2fcf3ca8c09e36741bb33915b6e69b8e3ca
|
||||
TERMUX_PKG_DEPENDS="gtk2, startup-notification"
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="lib/locale"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
}
|
@ -1,11 +1,12 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="The libxfce4ui package contains GTK+ 2 widgets that are used by other Xfce applications."
|
||||
TERMUX_PKG_VERSION=4.14.1
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Commonly used XFCE widgets among XFCE applications"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/libxfce4ui/4.14/libxfce4ui-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_VERSION=4.14.1
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/libxfce4ui/${TERMUX_PKG_VERSION:0:4}/libxfce4ui-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=c449075eaeae4d1138d22eeed3d2ad7032b87fb8878eada9b770325bed87f2da
|
||||
TERMUX_PKG_DEPENDS="xfconf, gtk2, gtk3, startup-notification, libice, libsm"
|
||||
TERMUX_PKG_DEPENDS="gtk2, gtk3, hicolor-icon-theme, libsm, libxfce4util, startup-notification, xfconf"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--enable-gtk3
|
||||
--with-vendor-info=Termux
|
||||
|
@ -1,8 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://git.xfce.org/xfce/libxfce4util/tree/README
|
||||
TERMUX_PKG_DESCRIPTION="The libxfce4util package is a basic utility library for the Xfce desktop environment."
|
||||
TERMUX_PKG_VERSION=4.14.0
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Basic utility non-GUI functions for XFCE"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/libxfce4util/4.14/libxfce4util-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_VERSION=4.14.0
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/libxfce4util/${TERMUX_PKG_VERSION:0:4}/libxfce4util-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=32ad79b7992ec3fd863e8ff2f03eebda8740363ef9d7d910a35963ac1c1a6324
|
||||
TERMUX_PKG_DEPENDS="glib"
|
||||
|
9
x11-packages/libxklavier/build.sh
Normal file
9
x11-packages/libxklavier/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.freedesktop.org/wiki/Software/LibXklavier/
|
||||
TERMUX_PKG_DESCRIPTION="High-level API for X Keyboard Extension"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=5.3
|
||||
TERMUX_PKG_SRCURL=https://ftp.gnome.org/pub/GNOME/sources/libxklavier/${TERMUX_PKG_VERSION}/libxklavier-${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=ebec3bc54b5652838502b96223152fb1cd8fcb14ace5cb02d718fc3276bbd404
|
||||
TERMUX_PKG_DEPENDS="glib, iso-codes, libxi, libxkbfile, libxml2, xkeyboard-config"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-xkb-base=$TERMUX_PREFIX/share/X11/xkb"
|
10
x11-packages/lxde-icon-theme/build.sh
Normal file
10
x11-packages/lxde-icon-theme/build.sh
Normal file
@ -0,0 +1,10 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://lxde.org/
|
||||
TERMUX_PKG_DESCRIPTION="LXDE default icon theme based on nuoveXT2"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=0.5.1
|
||||
TERMUX_PKG_SRCURL=https://downloads.sourceforge.net/lxde/lxde-icon-theme-${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=e3d0b7399f28a360a3755171c9a08147d68f853f518be5485f5064675037916c
|
||||
TERMUX_PKG_DEPENDS="gtk-update-icon-cache"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_PLATFORM_INDEPENDENT=true
|
@ -1,8 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://thunar.xfce.org
|
||||
TERMUX_PKG_DESCRIPTION="Modern file manager for Xfce"
|
||||
TERMUX_PKG_VERSION=1.8.9
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_HOMEPAGE=https://docs.xfce.org/xfce/thunar/start
|
||||
TERMUX_PKG_DESCRIPTION="Modern file manager for XFCE environment"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0, LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/thunar/1.8/Thunar-$TERMUX_PKG_VERSION.tar.bz2
|
||||
TERMUX_PKG_VERSION=1.8.9
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/thunar/${TERMUX_PKG_VERSION:0:3}/Thunar-$TERMUX_PKG_VERSION.tar.bz2
|
||||
TERMUX_PKG_SHA256=7a758e7ac03501c520c304f8845353315c954d429b17d591b8eea8b14f1350b9
|
||||
TERMUX_PKG_DEPENDS="libandroid-shmem, libxfce4ui, libexo, hicolor-icon-theme, libexif, libnotify, libpng"
|
||||
TERMUX_PKG_DEPENDS="desktop-file-utils, exo, hicolor-icon-theme, libexif, libnotify, libpng, libxfce4ui, libxfce4util"
|
||||
|
9
x11-packages/xfce4-panel/build.sh
Normal file
9
x11-packages/xfce4-panel/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Panel for the XFCE environment"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=4.14.0
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/xfce4-panel/${TERMUX_PKG_VERSION:0:4}/xfce4-panel-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=d5f8f3bd7e142139987e5e62cda26135a424baabb5e47aa0c23b4169d0a66ef4
|
||||
TERMUX_PKG_DEPENDS="desktop-file-utils, exo, hicolor-icon-theme, garcon, libwnck, libxfce4ui, xfconf"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-gtk3"
|
11
x11-packages/xfce4-panel/dont-update-icon-cache.patch
Normal file
11
x11-packages/xfce4-panel/dont-update-icon-cache.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- xfce4-panel-4.12.2/icons/Makefile.in 2017-12-14 04:44:33.000000000 +0530
|
||||
+++ xfce-panel/icons/Makefile.in 2019-02-02 11:13:58.275076551 +0530
|
||||
@@ -426,7 +426,7 @@
|
||||
48x48 \
|
||||
scalable
|
||||
|
||||
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
|
||||
+gtk_update_icon_cache = true
|
||||
all: all-recursive
|
||||
|
||||
.SUFFIXES:
|
34
x11-packages/xfce4-session/build.sh
Normal file
34
x11-packages/xfce4-session/build.sh
Normal file
@ -0,0 +1,34 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="A session manager for XFCE environment"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=4.14.0
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/xfce4-session/${TERMUX_PKG_VERSION:0:4}/xfce4-session-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=14fb6db74eb69eb400673856ba307a0e57f577cf77c3561a5910151e3d52043f
|
||||
TERMUX_PKG_DEPENDS="gnupg, hicolor-icon-theme, libsm, libwnck, libxfce4ui, xfce4-settings, xfdesktop, xorg-iceauth, xorg-xrdb"
|
||||
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
ac_cv_path_ICEAUTH=${TERMUX_PREFIX}/bin/iceauth
|
||||
--with-xsession-prefix=$TERMUX_PREFIX
|
||||
"
|
||||
|
||||
termux_step_create_debscripts() {
|
||||
cat <<- EOF > ./postinst
|
||||
#!$TERMUX_PREFIX/bin/sh
|
||||
if [ "\$1" = "configure" ] || [ "\$1" = "abort-upgrade" ]; then
|
||||
if [ -x "$TERMUX_PREFIX/bin/update-alternatives" ]; then
|
||||
update-alternatives --install \
|
||||
$TERMUX_PREFIX/bin/x-session-manager x-session-manager $TERMUX_PREFIX/bin/xfce4-session 50
|
||||
fi
|
||||
fi
|
||||
EOF
|
||||
|
||||
cat <<- EOF > ./prerm
|
||||
#!$TERMUX_PREFIX/bin/sh
|
||||
if [ "\$1" != "upgrade" ]; then
|
||||
if [ -x "$TERMUX_PREFIX/bin/update-alternatives" ]; then
|
||||
update-alternatives --remove x-session-manager $TERMUX_PREFIX/bin/xfce4-session
|
||||
fi
|
||||
fi
|
||||
EOF
|
||||
}
|
11
x11-packages/xfce4-session/dont-update-icon-cache.patch
Normal file
11
x11-packages/xfce4-session/dont-update-icon-cache.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- xfce4-session-4.12.1/icons/Makefile.in 2015-03-16 12:59:44.000000000 +0530
|
||||
+++ xfce4-session/icons/Makefile.in 2019-02-02 11:27:12.459284514 +0530
|
||||
@@ -384,7 +384,7 @@
|
||||
128x128 \
|
||||
scalable
|
||||
|
||||
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
|
||||
+gtk_update_icon_cache = true
|
||||
all: all-recursive
|
||||
|
||||
.SUFFIXES:
|
11
x11-packages/xfce4-session/xfsm-shutdown-fallback.c.patch
Normal file
11
x11-packages/xfce4-session/xfsm-shutdown-fallback.c.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- xfce4-session-4.12.1/xfce4-session/xfsm-shutdown-fallback.c 2014-12-07 13:18:40.000000000 +0530
|
||||
+++ xfce4-session/xfce4-session/xfsm-shutdown-fallback.c 2019-02-04 11:10:01.104865553 +0530
|
||||
@@ -135,7 +135,7 @@
|
||||
|
||||
|
||||
|
||||
-#ifdef BACKEND_TYPE_LINUX
|
||||
+#ifdef BACKEND_TYPE_LINUX && !defined(__ANDROID__) /* Dont support in ANDROID */
|
||||
static gboolean
|
||||
linux_supports_sleep_state (const gchar *state)
|
||||
{
|
17
x11-packages/xfce4-settings/build.sh
Normal file
17
x11-packages/xfce4-settings/build.sh
Normal file
@ -0,0 +1,17 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Settings manager for XFCE environment"
|
||||
TERMUX_PKG_LICENSE="LGPL-2.1"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=4.14.0
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/xfce4-settings/${TERMUX_PKG_VERSION:0:4}/xfce4-settings-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=e03040d623abda0222ad04f226582277a1936507ddfa927ec8e87927debc113c
|
||||
TERMUX_PKG_DEPENDS="exo, garcon, libnotify, libxfce4ui, libxklavier, lxde-icon-theme"
|
||||
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--enable-xrandr
|
||||
--enable-xcursor
|
||||
--enable-libnotify
|
||||
--enable-libxklavier
|
||||
--enable-pluggable-dialogs
|
||||
--enable-sound-settings
|
||||
"
|
@ -0,0 +1,11 @@
|
||||
--- xfce4-settings-4.12.4/dialogs/mouse-settings/main.c 2018-06-19 07:18:13.000000000 +0530
|
||||
+++ xfce4-settings/dialogs/mouse-settings/main.c 2019-01-30 12:51:13.820439696 +0530
|
||||
@@ -421,7 +421,7 @@
|
||||
|
||||
/* get the cursor paths */
|
||||
#if XCURSOR_LIB_MAJOR == 1 && XCURSOR_LIB_MINOR < 1
|
||||
- path = "~/.icons:/usr/share/icons:/usr/share/pixmaps:/usr/X11R6/lib/X11/icons";
|
||||
+ path = "~/.icons:@TERMUX_PREFIX@/share/icons:@TERMUX_PREFIX@/share/pixmaps:@TERMUX_PREFIX@/X11R6/lib/X11/icons";
|
||||
#else
|
||||
path = XcursorLibraryPath ();
|
||||
#endif
|
@ -1,8 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="simple client-server configuration storage and query system"
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Flexible, easy-to-use configuration management system"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=4.14.1
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/xfconf/4.14/xfconf-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/xfconf/${TERMUX_PKG_VERSION:0:4}/xfconf-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=b893e0a329aee00902fec2f0509f56916c9dcc7844e1b1f9e3c7399458290d59
|
||||
TERMUX_PKG_DEPENDS="libxfce4util, dbus-glib"
|
||||
TERMUX_PKG_DEPENDS="libxfce4util"
|
||||
|
9
x11-packages/xfdesktop/build.sh
Normal file
9
x11-packages/xfdesktop/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="A desktop manager for XFCE environment"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=4.14.1
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/xfdesktop/${TERMUX_PKG_VERSION:0:4}/xfdesktop-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=f705a016246ec54ab0c688d1a0577f6c2b45a446690aa8d9e5a7ac23efebf882
|
||||
TERMUX_PKG_DEPENDS="exo, garcon, hicolor-icon-theme, libwnck, libxfce4ui, startup-notification, thunar"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-notifications"
|
11
x11-packages/xfdesktop/dont-update-icon-cache.patch
Normal file
11
x11-packages/xfdesktop/dont-update-icon-cache.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- xfdesktop-4.12.4/pixmaps/Makefile.in 2017-06-26 19:22:42.000000000 +0530
|
||||
+++ xfdesktop/pixmaps/Makefile.in 2019-02-02 11:30:38.239600497 +0530
|
||||
@@ -409,7 +409,7 @@
|
||||
$(pixmaps_DATA) \
|
||||
$(pixmapsx_DATA)
|
||||
|
||||
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
|
||||
+gtk_update_icon_cache = true
|
||||
all: all-am
|
||||
|
||||
.SUFFIXES:
|
15
x11-packages/xfwm4/build.sh
Normal file
15
x11-packages/xfwm4/build.sh
Normal file
@ -0,0 +1,15 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://www.xfce.org/
|
||||
TERMUX_PKG_DESCRIPTION="Window manager for XFCE environment"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=4.14.0
|
||||
TERMUX_PKG_SRCURL=http://archive.xfce.org/src/xfce/xfwm4/${TERMUX_PKG_VERSION:0:4}/xfwm4-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=b4182bf8dc63d092f120a51fcae0eb54b9bd4aa4f8486f47e5a65a108322b615
|
||||
TERMUX_PKG_DEPENDS="hicolor-icon-theme, libepoxy, libwnck, libxfce4ui, startup-notification, xfconf"
|
||||
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--enable-startup-notification
|
||||
--enable-randr
|
||||
--enable-compositor
|
||||
--enable-xsync
|
||||
"
|
9
x11-packages/xorg-iceauth/build.sh
Normal file
9
x11-packages/xorg-iceauth/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://xorg.freedesktop.org/
|
||||
TERMUX_PKG_DESCRIPTION="ICE authority file utility"
|
||||
TERMUX_PKG_LICENSE="MIT"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=1.0.8
|
||||
TERMUX_PKG_SRCURL=https://www.x.org/archive/individual/app/iceauth-$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=25b94613173a6dd28d7b18d9479194aae3d9392f5a4a072f499bd48d3ca00740
|
||||
TERMUX_PKG_DEPENDS="libice"
|
||||
TERMUX_PKG_BUILD_DEPENDS="xorg-util-macros"
|
9
x11-packages/xorg-xrdb/build.sh
Normal file
9
x11-packages/xorg-xrdb/build.sh
Normal file
@ -0,0 +1,9 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://xorg.freedesktop.org/
|
||||
TERMUX_PKG_DESCRIPTION="X server resource database utility"
|
||||
TERMUX_PKG_LICENSE="MIT"
|
||||
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
|
||||
TERMUX_PKG_VERSION=1.2.0
|
||||
TERMUX_PKG_SRCURL=https://www.x.org/archive/individual/app/xrdb-$TERMUX_PKG_VERSION.tar.bz2
|
||||
TERMUX_PKG_SHA256=f23a65cfa1f7126040d68b6cf1e4567523edac10f8dc06f23d840d330c7c6946
|
||||
TERMUX_PKG_DEPENDS="libx11, libxmu"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-cpp=$TERMUX_PREFIX/bin/cpp"
|
20
x11-packages/xorg-xrdb/xrdb.c.patch
Normal file
20
x11-packages/xorg-xrdb/xrdb.c.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- xrdb-1.1.1/xrdb.c 2018-03-10 07:59:09.000000000 +0530
|
||||
+++ xrdb/xrdb.c 2019-01-30 13:02:44.618344843 +0530
|
||||
@@ -1085,7 +1085,7 @@
|
||||
strcpy(tmpname2, "xrdbD_XXXXXX");
|
||||
strcpy(tmpname3, "\\temp\\xrdbD_XXXXXX");
|
||||
#else
|
||||
- strcpy(tmpname2, "/tmp/xrdbD_XXXXXX");
|
||||
+ strcpy(tmpname2, "@TERMUX_PREFIX@/tmp/xrdbD_XXXXXX");
|
||||
#endif
|
||||
(void) mktemp(tmpname2);
|
||||
}
|
||||
@@ -1104,7 +1104,7 @@
|
||||
#ifdef WIN32
|
||||
strcpy(tmpname, "\\temp\\xrdb_XXXXXX");
|
||||
#else
|
||||
- strcpy(tmpname, "/tmp/xrdb_XXXXXX");
|
||||
+ strcpy(tmpname, "@TERMUX_PREFIX@/tmp/xrdb_XXXXXX");
|
||||
#endif
|
||||
#ifndef HAVE_MKSTEMP
|
||||
(void) mktemp(tmpname);
|
Loading…
Reference in New Issue
Block a user