toxic: update cfg-checks-audio.mk.patch

This commit is contained in:
Leonid Pliushch 2020-11-22 22:30:49 +02:00
parent 590db11e74
commit ba4338c5cd
1 changed files with 6 additions and 8 deletions

View File

@ -1,14 +1,12 @@
Do not try to use audio even if openal-soft has been built.
diff -u -r ../toxic-0.8.2/cfg/checks/audio.mk ./cfg/checks/audio.mk
--- ../toxic-0.8.2/cfg/checks/audio.mk 2018-02-27 23:46:56.000000000 +0000
+++ ./cfg/checks/audio.mk 2018-08-21 11:10:53.212956416 +0000
diff -uNr toxic-0.9.0/cfg/checks/audio.mk toxic-0.9.0.mod/cfg/checks/audio.mk
--- toxic-0.9.0/cfg/checks/audio.mk 2020-11-14 21:30:56.000000000 +0200
+++ toxic-0.9.0.mod/cfg/checks/audio.mk 2020-11-22 22:29:53.688081812 +0200
@@ -8,7 +8,7 @@
endif
# Check if we can build audio support
-CHECK_AUDIO_LIBS = $(shell $(PKG_CONFIG) --exists $(AUDIO_LIBS) || echo -n "error")
+CHECK_AUDIO_LIBS = $(shell echo -n "error")
-CHECK_AUDIO_LIBS := $(shell $(PKG_CONFIG) --exists $(AUDIO_LIBS) || echo -n "error")
+CHECK_AUDIO_LIBS := $(shell echo -n "error")
ifneq ($(CHECK_AUDIO_LIBS), error)
LIBS += $(AUDIO_LIBS)
CFLAGS += $(AUDIO_CFLAGS)
LDFLAGS += -lm