remove ccnet as it's been deleted upstream
This commit is contained in:
parent
3962defbb9
commit
bae74ec4ab
@ -1,22 +0,0 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://github.com/haiwen/ccnet
|
||||
TERMUX_PKG_DESCRIPTION="Ccnet is a framework for writing networked applications in C"
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=6.1.8
|
||||
TERMUX_PKG_REVISION=2
|
||||
TERMUX_PKG_SRCURL=https://github.com/haiwen/ccnet/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=b55636bf95232dc1db70d3604d0bebb7c3d730292d15b9b6c5b951307eb69762
|
||||
TERMUX_PKG_DEPENDS="libuuid, libevent, libsearpc, libsqlite, openssl"
|
||||
TERMUX_PKG_BREAKS="ccnet-dev"
|
||||
TERMUX_PKG_REPLACES="ccnet-dev"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
termux_step_pre_configure() {
|
||||
./autogen.sh
|
||||
}
|
||||
|
||||
termux_step_post_configure() {
|
||||
# the package has trouble to prepare some headers
|
||||
cd $TERMUX_PKG_SRCDIR/lib
|
||||
python $TERMUX_PREFIX/bin/searpc-codegen.py ../lib/rpc_table.py
|
||||
}
|
@ -1,11 +0,0 @@
|
||||
--- ./net/common/ccnet-config.h.orig 2020-01-19 20:33:55.463089854 +0000
|
||||
+++ ./net/common/ccnet-config.h 2020-01-19 20:34:02.763214014 +0000
|
||||
@@ -4,7 +4,7 @@
|
||||
#define SEAFILE_CONFIG_H
|
||||
|
||||
#include "session.h"
|
||||
-#include "db.h"
|
||||
+#include "../../lib/db.h"
|
||||
|
||||
/*
|
||||
* Returns: config value in string. The string should be freed by caller.
|
@ -1,11 +0,0 @@
|
||||
--- ./net/common/ccnet-db.h.orig 2020-01-19 20:35:46.504992486 +0000
|
||||
+++ ./net/common/ccnet-db.h 2020-01-19 20:36:10.155403556 +0000
|
||||
@@ -3,7 +3,7 @@
|
||||
#ifndef CCNET_DB_H
|
||||
#define CCNET_DB_H
|
||||
|
||||
-#include "db.h"
|
||||
+#include "../../lib/db.h"
|
||||
|
||||
#ifdef CCNET_SERVER
|
||||
|
@ -1,28 +0,0 @@
|
||||
--- ../ccnet/configure.ac 2018-04-26 19:00:41.309901710 +0200
|
||||
+++ ./configure.ac 2018-04-28 10:50:43.956523129 +0200
|
||||
@@ -76,7 +76,7 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
-AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
|
||||
+#AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
|
||||
AC_CHECK_LIB(sqlite3, sqlite3_open,[echo "found library sqlite3"] , AC_MSG_ERROR([*** Unable to find sqlite3 library]), )
|
||||
AC_CHECK_LIB(crypto, SHA1_Init, [echo "found library crypto"], AC_MSG_ERROR([*** Unable to find openssl crypto library]), )
|
||||
|
||||
@@ -98,6 +98,7 @@
|
||||
PTHREAD_LIBS=-lpthread
|
||||
fi
|
||||
|
||||
+PTHREAD_LIBS=
|
||||
AC_SUBST(PTHREAD_CFLAGS)
|
||||
AC_SUBST(PTHREAD_LIBS)
|
||||
|
||||
@@ -153,6 +154,8 @@
|
||||
LIB_DIRWATCH=
|
||||
fi
|
||||
|
||||
+LIB_RESOLV=""
|
||||
+
|
||||
AC_SUBST(LIB_WS32)
|
||||
AC_SUBST(LIB_GDI32)
|
||||
AC_SUBST(LIB_RT)
|
@ -3,11 +3,12 @@ TERMUX_PKG_DESCRIPTION="Seafile is a file syncing and sharing software with file
|
||||
TERMUX_PKG_LICENSE="Apache-2.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=8.0.3
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=https://github.com/haiwen/seafile/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=a83d5d301cf54819ab96ea0ab53824980efdf6727460b969ce3176b4c5109f6b
|
||||
TERMUX_PKG_DEPENDS="ccnet, libcurl, python"
|
||||
TERMUX_PKG_BREAKS="seafile-client-dev"
|
||||
TERMUX_PKG_REPLACES="seafile-client-dev"
|
||||
TERMUX_PKG_DEPENDS="libcurl, libevent, libsearpc, libsqlite, libuuid, openssl, python"
|
||||
TERMUX_PKG_BREAKS="seafile-client-dev, ccnet"
|
||||
TERMUX_PKG_REPLACES="seafile-client-dev, ccnet"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
termux_step_pre_configure() {
|
||||
|
@ -68,7 +68,7 @@ PACKAGES+=" ed"
|
||||
# Provides utility hexdump which is needed by package bitcoin.
|
||||
PACKAGES+=" bsdmainutils"
|
||||
|
||||
# Needed by package ccnet.
|
||||
# Needed by package seafile-client.
|
||||
PACKAGES+=" valac"
|
||||
|
||||
# Needed by package libgcrypt.
|
||||
|
@ -58,7 +58,6 @@ c-ares|c-ares/c-ares|\d+.\d+.\d+
|
||||
cava|karlstav/cava
|
||||
cavif-rs|kornelski/cavif-rs
|
||||
ccache|ccache/ccache
|
||||
ccnet|haiwen/ccnet
|
||||
check|libcheck/check
|
||||
chezmoi|twpayne/chezmoi
|
||||
chromaprint|acoustid/chromaprint
|
||||
|
Loading…
Reference in New Issue
Block a user