arp-scan: add hsearch patch
This commit is contained in:
parent
760539da12
commit
bb4a2d6dcc
11
root-packages/arp-scan/Makefile.am.patch
Normal file
11
root-packages/arp-scan/Makefile.am.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../Makefile.am.orig 2018-12-10 09:34:44.539940037 +0100
|
||||
+++ ./Makefile.am 2018-12-10 09:35:23.876606447 +0100
|
||||
@@ -10,7 +10,7 @@
|
||||
#
|
||||
dist_man_MANS = arp-scan.1 get-oui.1 get-iab.1 arp-fingerprint.1 mac-vendor.5
|
||||
#
|
||||
-arp_scan_SOURCES = arp-scan.c arp-scan.h error.c wrappers.c utils.c mt19937ar.c
|
||||
+arp_scan_SOURCES = arp-scan.c arp-scan.h error.c wrappers.c utils.c mt19937ar.c hcreate.c hcreate_r.c hsearch_r.c hdestroy_r.c
|
||||
arp_scan_LDADD = $(LIBOBJS)
|
||||
#
|
||||
dist_pkgdata_DATA = ieee-oui.txt ieee-iab.txt mac-vendor.txt
|
13
root-packages/arp-scan/arp-scan.h.patch
Normal file
13
root-packages/arp-scan/arp-scan.h.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- ../arp-scan.h.orig 2018-12-10 09:28:18.243276170 +0100
|
||||
+++ ./arp-scan.h 2018-12-10 09:32:43.409940919 +0100
|
||||
@@ -122,9 +122,7 @@
|
||||
#endif
|
||||
#endif
|
||||
|
||||
-#ifdef HAVE_SEARCH_H
|
||||
-#include <search.h>
|
||||
-#endif
|
||||
+#include "search.h"
|
||||
|
||||
/* Defines */
|
||||
|
@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="arp-scan is a command-line tool for system discovery and
|
||||
TERMUX_PKG_VERSION=1.9.5
|
||||
TERMUX_PKG_SRCURL=https://github.com/royhills/arp-scan/archive/${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=aa9498af84158a315b7e0ea6c2cddfa746660ca3987cbe7e32c0c90f5382d9d2
|
||||
TERMUX_PKG_DEPENDS="libpcap" #make
|
||||
TERMUX_PKG_DEPENDS="libpcap"
|
||||
TERMUX_PKG_BUILD_DEPENDS="libpcap-dev"
|
||||
|
||||
if [[ ${TERMUX_ARCH_BITS} == 32 ]]; then
|
||||
@ -12,6 +12,7 @@ if [[ ${TERMUX_ARCH_BITS} == 32 ]]; then
|
||||
fi
|
||||
|
||||
termux_step_pre_configure () {
|
||||
cp ${TERMUX_PKG_BUILDER_DIR}/hsearch/* ${TERMUX_PKG_SRCDIR}/
|
||||
aclocal
|
||||
autoheader
|
||||
automake --add-missing
|
||||
|
1
root-packages/arp-scan/hsearch/README.md
Normal file
1
root-packages/arp-scan/hsearch/README.md
Normal file
@ -0,0 +1 @@
|
||||
This hsearch(3) implementation is mostly based on the one present in FreeBSD 11.1.
|
72
root-packages/arp-scan/hsearch/hcreate.c
Normal file
72
root-packages/arp-scan/hsearch/hcreate.c
Normal file
@ -0,0 +1,72 @@
|
||||
/*-
|
||||
* Copyright (c) 2015 Nuxi, https://nuxi.nl/
|
||||
*
|
||||
* Redistribution and use in source and binary forms, with or without
|
||||
* modification, are permitted provided that the following conditions
|
||||
* are met:
|
||||
* 1. Redistributions of source code must retain the above copyright
|
||||
* notice, this list of conditions and the following disclaimer.
|
||||
* 2. Redistributions in binary form must reproduce the above copyright
|
||||
* notice, this list of conditions and the following disclaimer in the
|
||||
* documentation and/or other materials provided with the distribution.
|
||||
*
|
||||
* THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
|
||||
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
|
||||
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
|
||||
* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
|
||||
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
|
||||
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
|
||||
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
|
||||
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
* SUCH DAMAGE.
|
||||
*/
|
||||
|
||||
#include <sys/cdefs.h>
|
||||
|
||||
#include "search.h"
|
||||
#include <stdbool.h>
|
||||
#include <stddef.h>
|
||||
|
||||
/*
|
||||
* Thread unsafe interface: use a single process-wide hash table and
|
||||
* forward calls to *_r() functions.
|
||||
*/
|
||||
|
||||
static struct hsearch_data global_hashtable;
|
||||
static bool global_hashtable_initialized = false;
|
||||
|
||||
int
|
||||
hcreate(size_t nel)
|
||||
{
|
||||
|
||||
return (1);
|
||||
}
|
||||
|
||||
void
|
||||
hdestroy(void)
|
||||
{
|
||||
|
||||
/* Destroy global hash table if present. */
|
||||
if (global_hashtable_initialized) {
|
||||
hdestroy_r(&global_hashtable);
|
||||
global_hashtable_initialized = false;
|
||||
}
|
||||
}
|
||||
|
||||
ENTRY *
|
||||
hsearch(ENTRY item, ACTION action)
|
||||
{
|
||||
ENTRY *retval;
|
||||
|
||||
/* Create global hash table if needed. */
|
||||
if (!global_hashtable_initialized) {
|
||||
if (hcreate_r(0, &global_hashtable) == 0)
|
||||
return (NULL);
|
||||
global_hashtable_initialized = true;
|
||||
}
|
||||
if (hsearch_r(item, action, &retval, &global_hashtable) == 0)
|
||||
return (NULL);
|
||||
return (retval);
|
||||
}
|
63
root-packages/arp-scan/hsearch/hcreate_r.c
Normal file
63
root-packages/arp-scan/hsearch/hcreate_r.c
Normal file
@ -0,0 +1,63 @@
|
||||
/*-
|
||||
* Copyright (c) 2015 Nuxi, https://nuxi.nl/
|
||||
*
|
||||
* Redistribution and use in source and binary forms, with or without
|
||||
* modification, are permitted provided that the following conditions
|
||||
* are met:
|
||||
* 1. Redistributions of source code must retain the above copyright
|
||||
* notice, this list of conditions and the following disclaimer.
|
||||
* 2. Redistributions in binary form must reproduce the above copyright
|
||||
* notice, this list of conditions and the following disclaimer in the
|
||||
* documentation and/or other materials provided with the distribution.
|
||||
*
|
||||
* THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
|
||||
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
|
||||
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
|
||||
* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
|
||||
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
|
||||
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
|
||||
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
|
||||
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
* SUCH DAMAGE.
|
||||
*/
|
||||
|
||||
#include <sys/cdefs.h>
|
||||
//__FBSDID("$FreeBSD$");
|
||||
|
||||
#include "search.h"
|
||||
#include <stdlib.h>
|
||||
|
||||
#include "hsearch.h"
|
||||
|
||||
int
|
||||
hcreate_r(size_t nel, struct hsearch_data *htab)
|
||||
{
|
||||
struct __hsearch *hsearch;
|
||||
|
||||
/*
|
||||
* Allocate a hash table object. Ignore the provided hint and start
|
||||
* off with a table of sixteen entries. In most cases this hint is
|
||||
* just a wild guess. Resizing the table dynamically if the use
|
||||
* increases a threshold does not affect the worst-case running time.
|
||||
*/
|
||||
hsearch = malloc(sizeof(*hsearch));
|
||||
if (hsearch == NULL)
|
||||
return 0;
|
||||
hsearch->entries = calloc(16, sizeof(ENTRY));
|
||||
if (hsearch->entries == NULL) {
|
||||
free(hsearch);
|
||||
return 0;
|
||||
}
|
||||
|
||||
/*
|
||||
* Pick a random initialization for the FNV-1a hashing. This makes it
|
||||
* hard to come up with a fixed set of keys to force hash collisions.
|
||||
*/
|
||||
arc4random_buf(&hsearch->offset_basis, sizeof(hsearch->offset_basis));
|
||||
hsearch->index_mask = 0xf;
|
||||
hsearch->entries_used = 0;
|
||||
htab->__hsearch = hsearch;
|
||||
return 1;
|
||||
}
|
43
root-packages/arp-scan/hsearch/hdestroy_r.c
Normal file
43
root-packages/arp-scan/hsearch/hdestroy_r.c
Normal file
@ -0,0 +1,43 @@
|
||||
/*-
|
||||
* Copyright (c) 2015 Nuxi, https://nuxi.nl/
|
||||
*
|
||||
* Redistribution and use in source and binary forms, with or without
|
||||
* modification, are permitted provided that the following conditions
|
||||
* are met:
|
||||
* 1. Redistributions of source code must retain the above copyright
|
||||
* notice, this list of conditions and the following disclaimer.
|
||||
* 2. Redistributions in binary form must reproduce the above copyright
|
||||
* notice, this list of conditions and the following disclaimer in the
|
||||
* documentation and/or other materials provided with the distribution.
|
||||
*
|
||||
* THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
|
||||
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
|
||||
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
|
||||
* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
|
||||
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
|
||||
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
|
||||
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
|
||||
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
* SUCH DAMAGE.
|
||||
*/
|
||||
|
||||
#include <sys/cdefs.h>
|
||||
//__FBSDID("$FreeBSD$");
|
||||
|
||||
#include "search.h"
|
||||
#include <stdlib.h>
|
||||
|
||||
#include "hsearch.h"
|
||||
|
||||
void
|
||||
hdestroy_r(struct hsearch_data *htab)
|
||||
{
|
||||
struct __hsearch *hsearch;
|
||||
|
||||
/* Free hash table object and its entries. */
|
||||
hsearch = htab->__hsearch;
|
||||
free(hsearch->entries);
|
||||
free(hsearch);
|
||||
}
|
40
root-packages/arp-scan/hsearch/hsearch.h
Normal file
40
root-packages/arp-scan/hsearch/hsearch.h
Normal file
@ -0,0 +1,40 @@
|
||||
/*-
|
||||
* Copyright (c) 2015 Nuxi, https://nuxi.nl/
|
||||
*
|
||||
* Redistribution and use in source and binary forms, with or without
|
||||
* modification, are permitted provided that the following conditions
|
||||
* are met:
|
||||
* 1. Redistributions of source code must retain the above copyright
|
||||
* notice, this list of conditions and the following disclaimer.
|
||||
* 2. Redistributions in binary form must reproduce the above copyright
|
||||
* notice, this list of conditions and the following disclaimer in the
|
||||
* documentation and/or other materials provided with the distribution.
|
||||
*
|
||||
* THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
|
||||
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
|
||||
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
|
||||
* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
|
||||
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
|
||||
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
|
||||
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
|
||||
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
* SUCH DAMAGE.
|
||||
*
|
||||
* $FreeBSD$
|
||||
*/
|
||||
|
||||
#ifndef HSEARCH_H
|
||||
#define HSEARCH_H
|
||||
|
||||
#include "search.h"
|
||||
|
||||
struct __hsearch {
|
||||
size_t offset_basis; /* Initial value for FNV-1a hashing. */
|
||||
size_t index_mask; /* Bitmask for indexing the table. */
|
||||
size_t entries_used; /* Number of entries currently used. */
|
||||
ENTRY *entries; /* Hash table entries. */
|
||||
};
|
||||
|
||||
#endif
|
150
root-packages/arp-scan/hsearch/hsearch_r.c
Normal file
150
root-packages/arp-scan/hsearch/hsearch_r.c
Normal file
@ -0,0 +1,150 @@
|
||||
/*-
|
||||
* Copyright (c) 2015 Nuxi, https://nuxi.nl/
|
||||
*
|
||||
* Redistribution and use in source and binary forms, with or without
|
||||
* modification, are permitted provided that the following conditions
|
||||
* are met:
|
||||
* 1. Redistributions of source code must retain the above copyright
|
||||
* notice, this list of conditions and the following disclaimer.
|
||||
* 2. Redistributions in binary form must reproduce the above copyright
|
||||
* notice, this list of conditions and the following disclaimer in the
|
||||
* documentation and/or other materials provided with the distribution.
|
||||
*
|
||||
* THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
|
||||
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
|
||||
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
|
||||
* ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
|
||||
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
|
||||
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
|
||||
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
|
||||
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
|
||||
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
|
||||
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
* SUCH DAMAGE.
|
||||
*/
|
||||
|
||||
#include <sys/cdefs.h>
|
||||
//__FBSDID("$FreeBSD$");
|
||||
|
||||
#include <errno.h>
|
||||
#include <limits.h>
|
||||
#include "search.h"
|
||||
#include <stdint.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
|
||||
#include "hsearch.h"
|
||||
|
||||
/*
|
||||
* Look up an unused entry in the hash table for a given hash. For this
|
||||
* implementation we use quadratic probing. Quadratic probing has the
|
||||
* advantage of preventing primary clustering.
|
||||
*/
|
||||
static ENTRY *
|
||||
hsearch_lookup_free(struct __hsearch *hsearch, size_t hash)
|
||||
{
|
||||
size_t index, i;
|
||||
|
||||
for (index = hash, i = 0;; index += ++i) {
|
||||
ENTRY *entry = &hsearch->entries[index & hsearch->index_mask];
|
||||
if (entry->key == NULL)
|
||||
return (entry);
|
||||
}
|
||||
}
|
||||
|
||||
/*
|
||||
* Computes an FNV-1a hash of the key. Depending on the pointer size, this
|
||||
* either uses the 32- or 64-bit FNV prime.
|
||||
*/
|
||||
static size_t
|
||||
hsearch_hash(size_t offset_basis, const char *str)
|
||||
{
|
||||
size_t hash;
|
||||
|
||||
hash = offset_basis;
|
||||
while (*str != '\0') {
|
||||
hash ^= (uint8_t)*str++;
|
||||
if (sizeof(size_t) * CHAR_BIT <= 32)
|
||||
hash *= UINT32_C(16777619);
|
||||
else
|
||||
hash *= UINT64_C(1099511628211);
|
||||
}
|
||||
return (hash);
|
||||
}
|
||||
|
||||
int
|
||||
hsearch_r(ENTRY item, ACTION action, ENTRY **retval, struct hsearch_data *htab)
|
||||
{
|
||||
struct __hsearch *hsearch;
|
||||
ENTRY *entry, *old_entries, *new_entries;
|
||||
size_t hash, index, i, old_hash, old_count, new_count;
|
||||
|
||||
hsearch = htab->__hsearch;
|
||||
hash = hsearch_hash(hsearch->offset_basis, item.key);
|
||||
|
||||
/*
|
||||
* Search the hash table for an existing entry for this key.
|
||||
* Stop searching if we run into an unused hash table entry.
|
||||
*/
|
||||
for (index = hash, i = 0;; index += ++i) {
|
||||
entry = &hsearch->entries[index & hsearch->index_mask];
|
||||
if (entry->key == NULL)
|
||||
break;
|
||||
if (strcmp(entry->key, item.key) == 0) {
|
||||
*retval = entry;
|
||||
return (1);
|
||||
}
|
||||
}
|
||||
|
||||
/* Only perform the insertion if action is set to ENTER. */
|
||||
if (action == FIND) {
|
||||
errno = ESRCH;
|
||||
return (0);
|
||||
}
|
||||
|
||||
if (hsearch->entries_used * 2 >= hsearch->index_mask) {
|
||||
/* Preserve the old hash table entries. */
|
||||
old_count = hsearch->index_mask + 1;
|
||||
old_entries = hsearch->entries;
|
||||
|
||||
/*
|
||||
* Allocate and install a new table if insertion would
|
||||
* yield a hash table that is more than 50% used. By
|
||||
* using 50% as a threshold, a lookup will only take up
|
||||
* to two steps on average.
|
||||
*/
|
||||
new_count = (hsearch->index_mask + 1) * 2;
|
||||
new_entries = calloc(new_count, sizeof(ENTRY));
|
||||
if (new_entries == NULL)
|
||||
return (0);
|
||||
hsearch->entries = new_entries;
|
||||
hsearch->index_mask = new_count - 1;
|
||||
|
||||
/* Copy over the entries from the old table to the new table. */
|
||||
for (i = 0; i < old_count; ++i) {
|
||||
entry = &old_entries[i];
|
||||
if (entry->key != NULL) {
|
||||
old_hash = hsearch_hash(hsearch->offset_basis,
|
||||
entry->key);
|
||||
*hsearch_lookup_free(hsearch, old_hash) =
|
||||
*entry;
|
||||
}
|
||||
}
|
||||
|
||||
/* Destroy the old hash table entries. */
|
||||
free(old_entries);
|
||||
|
||||
/*
|
||||
* Perform a new lookup for a free table entry, so that
|
||||
* we insert the entry into the new hash table.
|
||||
*/
|
||||
hsearch = htab->__hsearch;
|
||||
entry = hsearch_lookup_free(hsearch, hash);
|
||||
}
|
||||
|
||||
/* Insert the new entry into the hash table. */
|
||||
*entry = item;
|
||||
++hsearch->entries_used;
|
||||
*retval = entry;
|
||||
return (1);
|
||||
}
|
86
root-packages/arp-scan/hsearch/search.h
Normal file
86
root-packages/arp-scan/hsearch/search.h
Normal file
@ -0,0 +1,86 @@
|
||||
/*-
|
||||
* Written by J.T. Conklin <jtc@NetBSD.org>
|
||||
* Public domain.
|
||||
*
|
||||
* $NetBSD: search.h,v 1.16 2005/02/03 04:39:32 perry Exp $
|
||||
* $FreeBSD$
|
||||
*/
|
||||
|
||||
#ifndef _SEARCH_H_
|
||||
#define _SEARCH_H_
|
||||
|
||||
#include <stddef.h>
|
||||
//#include <sys/cdefs.h>
|
||||
//#include <sys/types.h>
|
||||
|
||||
#ifndef _SIZE_T_DECLARED
|
||||
//typedef __size_t size_t;
|
||||
#define _SIZE_T_DECLARED
|
||||
#endif
|
||||
|
||||
typedef struct entry {
|
||||
char *key;
|
||||
void *data;
|
||||
} ENTRY;
|
||||
|
||||
typedef enum {
|
||||
FIND, ENTER
|
||||
} ACTION;
|
||||
|
||||
typedef enum {
|
||||
preorder,
|
||||
postorder,
|
||||
endorder,
|
||||
leaf
|
||||
} VISIT;
|
||||
|
||||
#ifdef _SEARCH_PRIVATE
|
||||
typedef struct __posix_tnode {
|
||||
void *key;
|
||||
struct __posix_tnode *llink, *rlink;
|
||||
signed char balance;
|
||||
} posix_tnode;
|
||||
|
||||
struct que_elem {
|
||||
struct que_elem *next;
|
||||
struct que_elem *prev;
|
||||
};
|
||||
#else
|
||||
typedef void posix_tnode;
|
||||
#endif
|
||||
|
||||
//#if __BSD_VISIBLE
|
||||
struct hsearch_data {
|
||||
struct __hsearch *__hsearch;
|
||||
};
|
||||
//#endif
|
||||
|
||||
__BEGIN_DECLS
|
||||
int hcreate(size_t);
|
||||
void hdestroy(void);
|
||||
ENTRY *hsearch(ENTRY, ACTION);
|
||||
void insque(void *, void *);
|
||||
void *lfind(const void *, const void *, size_t *, size_t,
|
||||
int (*)(const void *, const void *));
|
||||
void *lsearch(const void *, void *, size_t *, size_t,
|
||||
int (*)(const void *, const void *));
|
||||
void remque(void *);
|
||||
void *tdelete(const void * __restrict, posix_tnode ** __restrict,
|
||||
int (*)(const void *, const void *));
|
||||
posix_tnode *
|
||||
tfind(const void *, posix_tnode * const *,
|
||||
int (*)(const void *, const void *));
|
||||
posix_tnode *
|
||||
tsearch(const void *, posix_tnode **,
|
||||
int (*)(const void *, const void *));
|
||||
void twalk(const posix_tnode *, void (*)(const posix_tnode *, VISIT, int));
|
||||
|
||||
//#if __BSD_VISIBLE
|
||||
int hcreate_r(size_t, struct hsearch_data *);
|
||||
void hdestroy_r(struct hsearch_data *);
|
||||
int hsearch_r(ENTRY, ACTION, ENTRY **, struct hsearch_data *);
|
||||
//#endif
|
||||
|
||||
__END_DECLS
|
||||
|
||||
#endif /* !_SEARCH_H_ */
|
Loading…
Reference in New Issue
Block a user