torsocks: Update from 2.2.0 to 2.3.0
This commit is contained in:
parent
e951dcf596
commit
bc6c203729
@ -1,75 +0,0 @@
|
||||
From 3b78843ee18a3099196a61c7d07c0e2d24d1fe84 Mon Sep 17 00:00:00 2001
|
||||
From: vishalbiswas <vshlbiswas@ymail.com>
|
||||
Date: Tue, 17 Jan 2017 10:10:23 +0530
|
||||
Subject: [PATCH] syscall: Add clone
|
||||
|
||||
Signed-off-by: vishalbiswas <vshlbiswas@ymail.com>
|
||||
---
|
||||
src/common/compat.h | 4 ++++
|
||||
src/lib/syscall.c | 21 +++++++++++++++++++++
|
||||
2 files changed, 25 insertions(+)
|
||||
|
||||
diff --git a/src/common/compat.h b/src/common/compat.h
|
||||
index f490113..bf42f07 100644
|
||||
--- a/src/common/compat.h
|
||||
+++ b/src/common/compat.h
|
||||
@@ -126,6 +126,9 @@ void tsocks_once(tsocks_once_t *o, void (*init_routine)(void));
|
||||
#ifndef __NR_fork
|
||||
#define __NR_fork -18
|
||||
#endif
|
||||
+#ifndef __NR_clone
|
||||
+#define __NR_clone -19
|
||||
+#endif
|
||||
|
||||
#define TSOCKS_NR_SOCKET __NR_socket
|
||||
#define TSOCKS_NR_CONNECT __NR_connect
|
||||
@@ -145,6 +148,7 @@ void tsocks_once(tsocks_once_t *o, void (*init_routine)(void));
|
||||
#define TSOCKS_NR_GETTIMEOFDAY __NR_gettimeofday
|
||||
#define TSOCKS_NR_CLOCK_GETTIME __NR_clock_gettime
|
||||
#define TSOCKS_NR_FORK __NR_fork
|
||||
+#define TSOCKS_NR_CLONE __NR_clone
|
||||
|
||||
/*
|
||||
* Despite glibc providing wrappers for these calls for a long time
|
||||
diff --git a/src/lib/syscall.c b/src/lib/syscall.c
|
||||
index d0fdaaa..c8a9b46 100644
|
||||
--- a/src/lib/syscall.c
|
||||
+++ b/src/lib/syscall.c
|
||||
@@ -423,6 +423,24 @@ static LIBC_SYSCALL_RET_TYPE handle_fork(void)
|
||||
{
|
||||
return tsocks_libc_syscall(TSOCKS_NR_FORK);
|
||||
}
|
||||
+
|
||||
+/*
|
||||
+ * * Handle clone(2) syscall.
|
||||
+ * */
|
||||
+static LIBC_SYSCALL_RET_TYPE handle_clone(va_list args)
|
||||
+{
|
||||
+ int (*fn)(void*);
|
||||
+ void* child_stack;
|
||||
+ int flags;
|
||||
+ void* arg;
|
||||
+
|
||||
+ fn = va_arg(args, __typeof__(fn));
|
||||
+ child_stack = va_arg(args, __typeof__(child_stack));
|
||||
+ flags = va_arg(args, __typeof__(flags));
|
||||
+ arg = va_arg(args, __typeof__(arg));
|
||||
+
|
||||
+ return tsocks_libc_syscall(TSOCKS_NR_CLONE, fn, child_stack, flags, arg);
|
||||
+}
|
||||
#endif /* __linux__ */
|
||||
|
||||
/*
|
||||
@@ -541,6 +559,9 @@ LIBC_SYSCALL_RET_TYPE tsocks_syscall(long int number, va_list args)
|
||||
case TSOCKS_NR_FORK:
|
||||
ret = handle_fork();
|
||||
break;
|
||||
+ case TSOCKS_NR_CLONE:
|
||||
+ ret = handle_clone(args);
|
||||
+ break;
|
||||
#endif /* __linux__ */
|
||||
default:
|
||||
/*
|
||||
--
|
||||
2.11.0
|
||||
|
11
packages/torsocks/Makefile.am.patch
Normal file
11
packages/torsocks/Makefile.am.patch
Normal file
@ -0,0 +1,11 @@
|
||||
diff -u -r ../torsocks-2.3.0/Makefile.am ./Makefile.am
|
||||
--- ../torsocks-2.3.0/Makefile.am 2018-11-19 15:42:40.000000000 +0000
|
||||
+++ ./Makefile.am 2018-11-21 22:42:40.280616653 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
ACLOCAL_AMFLAGS = -I config
|
||||
|
||||
-SUBDIRS = src doc tests extras
|
||||
+SUBDIRS = src doc extras
|
||||
|
||||
dist_doc_DATA = ChangeLog
|
||||
|
@ -1,9 +1,8 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://github.com/dgoulet/torsocks
|
||||
TERMUX_PKG_DESCRIPTION="Wrapper to safely torify applications"
|
||||
TERMUX_PKG_VERSION=2.2.0.2017.1.17
|
||||
__TORSOCKS_REF=87b075dd16c675606adee792ef1e22691c51475b
|
||||
TERMUX_PKG_SRCURL=https://github.com/dgoulet/torsocks/archive/${__TORSOCKS_REF}.tar.gz
|
||||
TERMUX_PKG_SHA256=61302919dee9b909f36288d7b2759c74885f7edb06a860a398b8791716d3fda1
|
||||
TERMUX_PKG_VERSION=2.3.0
|
||||
TERMUX_PKG_SHA256=817c143e8a9d217f41a223a85139c6ca28e1b99556c547fcdb4c72dbc170b6c9
|
||||
TERMUX_PKG_SRCURL=https://github.com/dgoulet/torsocks/archive/v$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_DEPENDS="tor"
|
||||
|
||||
termux_step_pre_configure () {
|
||||
|
21
packages/torsocks/src-common-compat.h.patch
Normal file
21
packages/torsocks/src-common-compat.h.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -u -r ../torsocks-2.3.0/src/common/compat.h ./src/common/compat.h
|
||||
--- ../torsocks-2.3.0/src/common/compat.h 2018-11-19 15:42:40.000000000 +0000
|
||||
+++ ./src/common/compat.h 2018-11-21 22:39:33.390432043 +0000
|
||||
@@ -129,6 +129,9 @@
|
||||
#ifndef __NR_memfd_create
|
||||
#define __NR_memfd_create -19
|
||||
#endif
|
||||
+#ifndef __NR_clone
|
||||
+#define __NR_clone -19
|
||||
+#endif
|
||||
|
||||
#define TSOCKS_NR_SOCKET __NR_socket
|
||||
#define TSOCKS_NR_CONNECT __NR_connect
|
||||
@@ -149,6 +152,7 @@
|
||||
#define TSOCKS_NR_CLOCK_GETTIME __NR_clock_gettime
|
||||
#define TSOCKS_NR_FORK __NR_fork
|
||||
#define TSOCKS_NR_MEMFD_CREATE __NR_memfd_create
|
||||
+#define TSOCKS_NR_CLONE __NR_clone
|
||||
|
||||
/*
|
||||
* Despite glibc providing wrappers for these calls for a long time
|
38
packages/torsocks/src-lib-syscall.c.patch
Normal file
38
packages/torsocks/src-lib-syscall.c.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -u -r ../torsocks-2.3.0/src/lib/syscall.c ./src/lib/syscall.c
|
||||
--- ../torsocks-2.3.0/src/lib/syscall.c 2018-11-19 15:42:40.000000000 +0000
|
||||
+++ ./src/lib/syscall.c 2018-11-21 22:37:53.867404833 +0000
|
||||
@@ -437,6 +437,24 @@
|
||||
|
||||
return tsocks_libc_syscall(TSOCKS_NR_MEMFD_CREATE, name, flags);
|
||||
}
|
||||
+
|
||||
+/*
|
||||
+ * * Handle clone(2) syscall.
|
||||
+ * */
|
||||
+static LIBC_SYSCALL_RET_TYPE handle_clone(va_list args)
|
||||
+{
|
||||
+ int (*fn)(void*);
|
||||
+ void* child_stack;
|
||||
+ int flags;
|
||||
+ void* arg;
|
||||
+
|
||||
+ fn = va_arg(args, __typeof__(fn));
|
||||
+ child_stack = va_arg(args, __typeof__(child_stack));
|
||||
+ flags = va_arg(args, __typeof__(flags));
|
||||
+ arg = va_arg(args, __typeof__(arg));
|
||||
+
|
||||
+ return tsocks_libc_syscall(TSOCKS_NR_CLONE, fn, child_stack, flags, arg);
|
||||
+}
|
||||
#endif /* __linux__ */
|
||||
|
||||
/*
|
||||
@@ -558,6 +576,9 @@
|
||||
case TSOCKS_NR_MEMFD_CREATE:
|
||||
ret = handle_memfd_create(args);
|
||||
break;
|
||||
+ case TSOCKS_NR_CLONE:
|
||||
+ ret = handle_clone(args);
|
||||
+ break;
|
||||
#endif /* __linux__ */
|
||||
default:
|
||||
/*
|
@ -1,12 +0,0 @@
|
||||
diff -u -r ../torsocks-2.2.0/tests/Makefile.am ./tests/Makefile.am
|
||||
--- ../torsocks-2.2.0/tests/Makefile.am 2016-10-18 12:44:01.000000000 -0400
|
||||
+++ ./tests/Makefile.am 2016-12-20 21:23:41.960184652 -0500
|
||||
@@ -29,7 +29,7 @@
|
||||
test_connect_LDADD = $(LIBTAP) $(LIBTORSOCKS)
|
||||
|
||||
test_fd_passing_SOURCES = test_fd_passing.c
|
||||
-test_fd_passing_LDADD = $(LIBTAP) $(LIBTORSOCKS) -lpthread
|
||||
+test_fd_passing_LDADD = $(LIBTAP) $(LIBTORSOCKS)
|
||||
|
||||
test_getpeername_SOURCES = test_getpeername.c
|
||||
test_getpeername_LDADD = $(LIBTAP) $(LIBTORSOCKS)
|
Loading…
Reference in New Issue
Block a user