Update coreutils from 8.23 to 8.24

This commit is contained in:
Fredrik Fornwall 2015-07-04 08:44:30 -04:00
parent 234b689c86
commit bc82430bf3
3 changed files with 11 additions and 30 deletions

View File

@ -1,10 +1,10 @@
Use man pages generated by help2man in the host build.
diff -u -r ../coreutils-8.23/Makefile.in ./Makefile.in
--- ../coreutils-8.23/Makefile.in 2014-07-19 00:22:24.000000000 +0200
+++ ./Makefile.in 2014-07-29 15:52:14.000000000 +0200
@@ -14062,29 +14062,7 @@
@AMDEP_TRUE@@am__include@ man/dynamic-deps.mk
diff -u -r ../coreutils-8.24/Makefile.in ./Makefile.in
--- ../coreutils-8.24/Makefile.in 2015-07-03 17:23:13.000000000 -0400
+++ ./Makefile.in 2015-07-04 07:38:25.901795437 -0400
@@ -14242,31 +14242,7 @@
@SINGLE_BINARY_FALSE@man/yes.1: src/yes$(EXEEXT)
.x.1:
- $(AM_V_GEN)name=`echo $@ | sed 's|.*/||; s|\.1$$||'` || exit 1; \
@ -17,12 +17,14 @@ diff -u -r ../coreutils-8.23/Makefile.in ./Makefile.in
- && t=$*.td \
- && rm -rf $$t \
- && $(MKDIR_P) $$t \
- && (cd $$t && $(LN_S) '$(abs_top_builddir)/src/'$$prog $$argv) \
- && (cd $$t && $(LN_S) '$(abs_top_builddir)/src/'$$prog$(EXEEXT) \
- $$argv$(EXEEXT)) \
- && $(run_help2man) \
- --source='$(PACKAGE_STRING)' \
- --include=$(srcdir)/man/$$name.x \
- --output=$$t/$$name.1 $$t/$$argv \
- --info-page='coreutils \(aq'$$name' invocation\(aq' \
- --output=$$t/$$name.1 \
- --info-page='\(aq(coreutils) '$$name' invocation\(aq' \
- $$t/$$argv$(EXEEXT) \
- && sed \
- -e 's|$*\.td/||g' \
- -e '/For complete documentation/d' \

View File

@ -1,6 +1,6 @@
TERMUX_PKG_HOMEPAGE=http://www.gnu.org/software/coreutils/
TERMUX_PKG_DESCRIPTION="Basic file, shell and text manipulation utilities from the GNU project"
TERMUX_PKG_VERSION=8.23
TERMUX_PKG_VERSION=8.24
TERMUX_PKG_SRCURL=http://ftp.gnu.org/gnu/coreutils/coreutils-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="ac_cv_func_mkfifo=yes gl_cv_host_operating_system=Android --without-gmp --enable-single-binary=symlinks"
TERMUX_PKG_EXTRA_HOSTBUILD_CONFIGURE_ARGS="$TERMUX_PKG_EXTRA_CONFIGURE_ARGS"

View File

@ -1,21 +0,0 @@
diff -u -r ../coreutils-8.22/lib/mountlist.c ./lib/mountlist.c
--- ../coreutils-8.22/lib/mountlist.c 2013-12-04 15:53:33.000000000 +0100
+++ ./lib/mountlist.c 2014-01-07 19:12:03.794066905 +0100
@@ -428,6 +428,9 @@
#ifdef MOUNTED_GETMNTENT1 /* GNU/Linux, 4.3BSD, SunOS, HP-UX, Dynix, Irix. */
{
+# ifdef __ANDROID__
+ return NULL;
+# else
struct mntent *mnt;
char const *table = MOUNTED;
FILE *fp;
@@ -454,6 +457,7 @@
if (endmntent (fp) == 0)
goto free_then_fail;
+# endif
}
#endif /* MOUNTED_GETMNTENT1. */