babl: update patches
bump yadm and imagemagick on CI too
This commit is contained in:
parent
14936b4754
commit
bcb1eeadc4
@ -3,10 +3,10 @@ diff -u -r ../babl-0.1.70/babl/meson.build ./babl/meson.build
|
||||
+++ ./babl/meson.build 2019-08-08 09:55:50.648892290 +0000
|
||||
@@ -128,7 +128,7 @@
|
||||
c_args: babl_c_args,
|
||||
link_whole: [ babl_base, ],
|
||||
link_args: [ babl_link_args, ],
|
||||
- dependencies: [ math, thread, dl, lcms, ],
|
||||
+ dependencies: [ math, thread, dl, lcms, log, ],
|
||||
link_depends: [ version_script_target, ],
|
||||
link_whole: babl_base,
|
||||
link_args: babl_link_args,
|
||||
- dependencies: [math, thread, dl, lcms],
|
||||
+ dependencies: [math, thread, dl, lcms, log],
|
||||
link_depends: version_script,
|
||||
version: so_version,
|
||||
install: true,
|
||||
|
@ -3,10 +3,10 @@ diff -u -r ../babl-0.1.70/tests/meson.build ./tests/meson.build
|
||||
+++ ./tests/meson.build 2019-08-08 09:58:14.015259147 +0000
|
||||
@@ -41,7 +41,7 @@
|
||||
test_name + '.c',
|
||||
include_directories: [ rootInclude, bablInclude, ],
|
||||
link_with: [ babl, ],
|
||||
- dependencies: [ thread, ],
|
||||
+ dependencies: [ thread, log, ],
|
||||
include_directories: [rootInclude, bablInclude],
|
||||
link_with: babl,
|
||||
- dependencies: thread,
|
||||
+ dependencies: [thread, log],
|
||||
export_dynamic: true,
|
||||
install: false,
|
||||
)
|
||||
|
@ -3,10 +3,10 @@ diff -u -r ../babl-0.1.70/tools/meson.build ./tools/meson.build
|
||||
+++ ./tools/meson.build 2019-08-08 09:59:07.362648769 +0000
|
||||
@@ -17,7 +17,7 @@
|
||||
tool_name + '.c',
|
||||
include_directories: [ rootInclude, bablInclude, ],
|
||||
link_with: [ babl, ],
|
||||
- dependencies: [ math, thread, ],
|
||||
+ dependencies: [ math, thread, log, ],
|
||||
include_directories: [rootInclude, bablInclude],
|
||||
link_with: babl,
|
||||
- dependencies: [math, thread],
|
||||
+ dependencies: [math, thread, log],
|
||||
install: false,
|
||||
)
|
||||
|
||||
|
@ -26,7 +26,7 @@ share/ImageMagick-7/francais.xml
|
||||
|
||||
termux_step_pre_configure() {
|
||||
if [ $TERMUX_ARCH = "i686" ]; then
|
||||
# Avoid "libMagickCore-7.Q16HDRI.so: error: undefined reference to '__atomic_load'":
|
||||
# Avoid "libMagickCore-7.Q16HDRI.so: error: undefined reference to '__atomic_load'"
|
||||
LDFLAGS+=" -latomic"
|
||||
fi
|
||||
}
|
||||
|
@ -8,8 +8,7 @@ TERMUX_PKG_DEPENDS="git"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
termux_step_make() {
|
||||
# Do not try to run 'make' as this causes
|
||||
# build failure.
|
||||
# Do not try to run 'make' as it causes a build failure.
|
||||
return
|
||||
}
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user