mosquitto: Update from 1.4.10 to 1.4.11
This commit is contained in:
parent
a247ffe2c8
commit
bfd9e967f9
@ -1,9 +1,8 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://mosquitto.org/
|
TERMUX_PKG_HOMEPAGE=https://mosquitto.org/
|
||||||
TERMUX_PKG_DESCRIPTION="MQTT library"
|
TERMUX_PKG_DESCRIPTION="MQTT library"
|
||||||
TERMUX_PKG_VERSION=1.4.10
|
TERMUX_PKG_VERSION=1.4.11
|
||||||
TERMUX_PKG_REVISION=1
|
|
||||||
TERMUX_PKG_SRCURL=https://mosquitto.org/files/source/mosquitto-${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://mosquitto.org/files/source/mosquitto-${TERMUX_PKG_VERSION}.tar.gz
|
||||||
TERMUX_PKG_SHA256=437648d68a4a781dd8d913814cd5451f59ab4a5fcf84cccaf7c36e6a07459770
|
TERMUX_PKG_SHA256=ca47533bbc1b7c5e15d6e5d96d3efc59677f2515b6692263c34b7c48f33280c5
|
||||||
TERMUX_PKG_DEPENDS="c-ares, openssl"
|
TERMUX_PKG_DEPENDS="c-ares, openssl"
|
||||||
TERMUX_PKG_MAINTAINER="Nathaniel Wesley Filardo @nwf"
|
TERMUX_PKG_MAINTAINER="Nathaniel Wesley Filardo @nwf"
|
||||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
Submitted for upstream inclusion at:
|
|
||||||
https://github.com/eclipse/mosquitto/pull/360
|
|
||||||
|
|
||||||
diff -u -r ../mosquitto-1.4.10/src/CMakeLists.txt ./src/CMakeLists.txt
|
|
||||||
--- ../mosquitto-1.4.10/src/CMakeLists.txt 2016-08-17 13:05:14.000000000 +0200
|
|
||||||
+++ ./src/CMakeLists.txt 2017-01-24 22:30:42.611308509 +0100
|
|
||||||
@@ -86,7 +86,11 @@
|
|
||||||
if (APPLE)
|
|
||||||
set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
|
|
||||||
else (APPLE)
|
|
||||||
- set (MOSQ_LIBS ${MOSQ_LIBS} rt dl m)
|
|
||||||
+ set (MOSQ_LIBS ${MOSQ_LIBS} dl m)
|
|
||||||
+ find_library(LIBRT rt)
|
|
||||||
+ if (LIBRT)
|
|
||||||
+ set (MOSQ_LIBS ${MOSQ_LIBS} rt)
|
|
||||||
+ endif (LIBRT)
|
|
||||||
endif (APPLE)
|
|
||||||
endif (UNIX)
|
|
||||||
|
|
||||||
diff -u -r ../mosquitto-1.4.10/lib/CMakeLists.txt ./lib/CMakeLists.txt
|
|
||||||
--- ../mosquitto-1.4.10/lib/CMakeLists.txt 2016-08-17 13:05:14.000000000 +0200
|
|
||||||
+++ ./lib/CMakeLists.txt 2017-01-15 21:09:21.548573341 +0100
|
|
||||||
@@ -7,7 +7,12 @@
|
|
||||||
set (PTHREAD_LIBRARIES C:\\pthreads\\Pre-built.2\\lib\\x86\\pthreadVC2.lib)
|
|
||||||
set (PTHREAD_INCLUDE_DIR C:\\pthreads\\Pre-built.2\\include)
|
|
||||||
else (WIN32)
|
|
||||||
- set (PTHREAD_LIBRARIES pthread)
|
|
||||||
+ find_library(LIBPTHREAD pthread)
|
|
||||||
+ if (LIBPTHREAD)
|
|
||||||
+ set (PTHREAD_LIBRARIES pthread)
|
|
||||||
+ else (LIBPTHREAD)
|
|
||||||
+ set (PTHREAD_LIBRARIES "")
|
|
||||||
+ endif()
|
|
||||||
set (PTHREAD_INCLUDE_DIR "")
|
|
||||||
endif (WIN32)
|
|
||||||
else (${WITH_THREADING} STREQUAL ON)
|
|
||||||
@@ -44,7 +49,10 @@
|
|
||||||
set (LIBRARIES ${OPENSSL_LIBRARIES} ${PTHREAD_LIBRARIES})
|
|
||||||
|
|
||||||
if (UNIX AND NOT APPLE)
|
|
||||||
- set (LIBRARIES ${LIBRARIES} rt)
|
|
||||||
+ find_library(LIBRT rt)
|
|
||||||
+ if (LIBRT)
|
|
||||||
+ set (LIBRARIES ${LIBRARIES} rt)
|
|
||||||
+ endif (LIBRT)
|
|
||||||
endif (UNIX AND NOT APPLE)
|
|
||||||
|
|
||||||
if (WIN32)
|
|
@ -1,15 +0,0 @@
|
|||||||
Submitted for upstream inclusion at:
|
|
||||||
https://github.com/eclipse/mosquitto/pull/361
|
|
||||||
|
|
||||||
diff -u -r ../mosquitto-1.4.10/src/conf.c ./src/conf.c
|
|
||||||
--- ../mosquitto-1.4.10/src/conf.c 2016-08-17 13:05:14.000000000 +0200
|
|
||||||
+++ ./src/conf.c 2017-01-24 10:50:34.011878190 +0100
|
|
||||||
@@ -36,7 +36,7 @@
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if !defined(WIN32) && !defined(__CYGWIN__)
|
|
||||||
-# include <sys/syslog.h>
|
|
||||||
+# include <syslog.h>
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#include <mosquitto_broker.h>
|
|
Loading…
x
Reference in New Issue
Block a user