librsync: Update from 2.0.1 to 2.0.2

This commit is contained in:
Fredrik Fornwall 2018-03-01 15:28:31 +01:00
parent c7ae5c2055
commit c05cd55285
2 changed files with 2 additions and 22 deletions

View File

@ -1,20 +0,0 @@
Patch submitted upstream at https://github.com/librsync/librsync/pull/136
diff -u -r ../librsync-2.0.1/CMakeLists.txt ./CMakeLists.txt
--- ../librsync-2.0.1/CMakeLists.txt 2017-10-17 03:45:57.000000000 +0200
+++ ./CMakeLists.txt 2017-12-23 23:34:02.239823106 +0100
@@ -108,8 +108,13 @@
check_type_size ( "unsigned short" SIZEOF_UNSIGNED_SHORT )
# Check for printf "%zu" size_t formating support.
-include(CheckCSourceRuns)
-check_c_source_runs("#include <stdio.h>\nint main(){char o[8];sprintf(o, \"%zu\", (size_t)7);return o[0] != '7';}" HAVE_PRINTF_Z)
+if(CMAKE_CROSSCOMPILING)
+ set(HAVE_PRINTF_Z ON)
+ message (STATUS "Cross compiling - assuming printf \"%zu\" size_t formating support")
+else()
+ include(CheckCSourceRuns)
+ check_c_source_runs("#include <stdio.h>\nint main(){char o[8];sprintf(o, \"%zu\", (size_t)7);return o[0] != '7';}" HAVE_PRINTF_Z)
+endif()
include (TestBigEndian)
TEST_BIG_ENDIAN(WORDS_BIGENDIAN)

View File

@ -1,7 +1,7 @@
TERMUX_PKG_HOMEPAGE=https://github.com/librsync/librsync
TERMUX_PKG_DESCRIPTION="Remote delta-compression library"
TERMUX_PKG_VERSION=2.0.1
TERMUX_PKG_SHA256=6fce69041aa4fc72a21f1ab280a7299b82df2b1fa0a25d8695fd527e6752625e
TERMUX_PKG_VERSION=2.0.2
TERMUX_PKG_SHA256=e67b9520ee84f7239be6e948795803bd95495091cc00bf6d0e8c6976032a4af1
TERMUX_PKG_SRCURL=https://github.com/librsync/librsync/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_DEPENDS="libbz2"
TERMUX_PKG_BUILD_DEPENDS="libpopt"