move from unstable: goaccess

This commit is contained in:
Leonid Pliushch 2019-11-18 21:37:22 +02:00
parent 83e5191f59
commit c0a78d58f6
5 changed files with 116 additions and 0 deletions

View File

@ -0,0 +1,16 @@
diff -uNr goaccess-1.3/Makefile.in goaccess-1.3.mod/Makefile.in
--- goaccess-1.3/Makefile.in 2018-11-23 07:35:59.000000000 +0200
+++ goaccess-1.3.mod/Makefile.in 2019-02-01 01:28:46.579671652 +0200
@@ -531,10 +531,9 @@
src/$(DEPDIR)/$(am__dirstamp):
@$(MKDIR_P) src/$(DEPDIR)
@: > src/$(DEPDIR)/$(am__dirstamp)
-src/bin2c.$(OBJEXT): src/$(am__dirstamp) src/$(DEPDIR)/$(am__dirstamp)
-bin2c$(EXEEXT): $(bin2c_OBJECTS) $(bin2c_DEPENDENCIES) $(EXTRA_bin2c_DEPENDENCIES)
+bin2c$(EXEEXT): $(bin2c_SOURCES)
@rm -f bin2c$(EXEEXT)
- $(LINK) $(bin2c_OBJECTS) $(bin2c_LDADD) $(LIBS)
+ gcc $(bin2c_SOURCES) $(bin2c_LDADD) $(LIBS) -o bin2c
src/base64.$(OBJEXT): src/$(am__dirstamp) \
src/$(DEPDIR)/$(am__dirstamp)
src/browsers.$(OBJEXT): src/$(am__dirstamp) \

View File

@ -0,0 +1,14 @@
TERMUX_PKG_HOMEPAGE=http://goaccess.io
TERMUX_PKG_DESCRIPTION="An open source real-time web log analyzer and interactive viewer"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com>"
TERMUX_PKG_VERSION=1.3
TERMUX_PKG_REVISION=6
TERMUX_PKG_SRCURL=https://tar.goaccess.io/goaccess-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=8c775c5c24bf85a933fd6f1249004847342d6542aa533e4ec02aaf7be41d7b9b
TERMUX_PKG_DEPENDS="ncurses, openssl"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--enable-utf8
--with-openssl"

View File

@ -0,0 +1,60 @@
diff -uNr goaccess-1.3/configure goaccess-1.3.mod/configure
--- goaccess-1.3/configure 2018-11-23 07:35:57.000000000 +0200
+++ goaccess-1.3.mod/configure 2019-02-01 01:24:41.379926604 +0200
@@ -6431,56 +6431,6 @@
fi
-# pthread
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pthread_create in -lpthread" >&5
-$as_echo_n "checking for pthread_create in -lpthread... " >&6; }
-if ${ac_cv_lib_pthread_pthread_create+:} false; then :
- $as_echo_n "(cached) " >&6
-else
- ac_check_lib_save_LIBS=$LIBS
-LIBS="-lpthread $LIBS"
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-/* Override any GCC internal prototype to avoid an error.
- Use char because int might match the return type of a GCC
- builtin and then its argument prototype would still apply. */
-#ifdef __cplusplus
-extern "C"
-#endif
-char pthread_create ();
-int
-main ()
-{
-return pthread_create ();
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_link "$LINENO"; then :
- ac_cv_lib_pthread_pthread_create=yes
-else
- ac_cv_lib_pthread_pthread_create=no
-fi
-rm -f core conftest.err conftest.$ac_objext \
- conftest$ac_exeext conftest.$ac_ext
-LIBS=$ac_check_lib_save_LIBS
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_pthread_pthread_create" >&5
-$as_echo "$ac_cv_lib_pthread_pthread_create" >&6; }
-if test "x$ac_cv_lib_pthread_pthread_create" = xyes; then :
- cat >>confdefs.h <<_ACEOF
-#define HAVE_LIBPTHREAD 1
-_ACEOF
-
- LIBS="-lpthread $LIBS"
-
-else
- as_fn_error $? "pthread is missing" "$LINENO" 5
-fi
-
-CFLAGS="$CFLAGS -pthread"
-
# DEBUG
# Check whether --enable-debug was given.
if test "${enable_debug+set}" = set; then :

View File

@ -0,0 +1,12 @@
diff -uNr goaccess-1.3/src/tcbtdb.h goaccess-1.3.mod/src/tcbtdb.h
--- goaccess-1.3/src/tcbtdb.h 2018-11-23 04:00:08.000000000 +0200
+++ goaccess-1.3.mod/src/tcbtdb.h 2019-02-01 01:30:19.191246767 +0200
@@ -46,7 +46,7 @@
#define TC_LMEMB 128
#define TC_NMEMB 256
#define TC_BNUM 32749
-#define TC_DBPATH "/tmp/goaccess"
+#define TC_DBPATH "@TERMUX_PREFIX@/tmp/goaccess"
#define TC_DBPMODE 0755
#define TC_ZLIB 1
#define TC_BZ2 2

View File

@ -0,0 +1,14 @@
diff -uNr goaccess-1.3/src/websocket.h goaccess-1.3.mod/src/websocket.h
--- goaccess-1.3/src/websocket.h 2018-11-23 04:00:08.000000000 +0200
+++ goaccess-1.3.mod/src/websocket.h 2019-02-01 01:30:02.260971076 +0200
@@ -90,8 +90,8 @@
#define MAX(a,b) (((a)>(b))?(a):(b))
#include "gslist.h"
-#define WS_PIPEIN "/tmp/wspipein.fifo"
-#define WS_PIPEOUT "/tmp/wspipeout.fifo"
+#define WS_PIPEIN "@TERMUX_PREFIX@/tmp/wspipein.fifo"
+#define WS_PIPEOUT "@TERMUX_PREFIX@/tmp/wspipeout.fifo"
#define WS_BAD_REQUEST_STR "HTTP/1.1 400 Invalid Request\r\n\r\n"
#define WS_SWITCH_PROTO_STR "HTTP/1.1 101 Switching Protocols"