add lxqt-session package

This commit is contained in:
Symeon Huang 2021-05-20 16:07:38 +01:00 committed by Yaksh Bariya
parent 0ce57ac497
commit c0b13b2ea7
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
3 changed files with 93 additions and 0 deletions

View File

@ -0,0 +1,10 @@
TERMUX_PKG_HOMEPAGE=https://lxqt.github.io
TERMUX_PKG_DESCRIPTION="The LXQt session manager"
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_MAINTAINER="Simeon Huang <symeon@librehat.com>"
TERMUX_PKG_VERSION=0.17.1
TERMUX_PKG_SRCURL="https://github.com/lxqt/lxqt-session/releases/download/${TERMUX_PKG_VERSION}/lxqt-session-${TERMUX_PKG_VERSION}.tar.xz"
TERMUX_PKG_SHA256=d9058ceedb355a43ea2ef070292fc30b0fb740640cf0b579131aaefbac779c47
TERMUX_PKG_DEPENDS="qt5-qtbase, qt5-qtx11extras, kwindowsystem, liblxqt, procps"
TERMUX_PKG_BUILD_DEPENDS="cmake, perl, lxqt-build-tools, qt5-qtbase-cross-tools, qt5-qttools-cross-tools"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-DWITH_LIBUDEV=OFF"

View File

@ -0,0 +1,51 @@
This patch removes the check on CMake system's name "Linux".
Because Termux is considered to be Q_OS_LINUX and not Q_OS_ANDROID.
This patch also removes the check on non-existent XdgUserDirs package.
--- src/CMakeLists.txt 2021-04-16 16:36:14.000000000 +0000
+++ src.mod/CMakeLists.txt 2021-05-20 14:57:23.675649000 +0000
@@ -32,12 +32,7 @@
find_package(X11 REQUIRED)
message(STATUS "Building with Qt${Qt5Core_VERSION}")
find_package(PkgConfig REQUIRED)
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
- pkg_search_module(PROCPS REQUIRED libprocps)
-endif()
-
-# Please don't move, must be after lxqt
-find_package(XdgUserDirs REQUIRED)
+pkg_search_module(PROCPS REQUIRED libprocps)
# Patch Version
set(LXQT_SESSION_PATCH_VERSION 1)
--- src/lxqt-session/CMakeLists.txt 2021-04-16 16:36:14.000000000 +0000
+++ src.mod/lxqt-session/CMakeLists.txt 2021-05-20 15:00:28.556372000 +0000
@@ -9,11 +9,9 @@
include_directories(
${X11_INCLUDE_DIR}
)
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
- include_directories(
- ${PROCPS_INCLUDE_DIRS}
- )
-endif()
+include_directories(
+ ${PROCPS_INCLUDE_DIRS}
+)
set(lxqt-session_HDRS "")
@@ -67,11 +65,9 @@
${X11_LIBRARIES}
KF5::WindowSystem
)
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
- target_link_libraries(lxqt-session
- ${PROCPS_LIBRARIES}
- )
-endif()
+target_link_libraries(lxqt-session
+ ${PROCPS_LIBRARIES}
+)
if (WITH_LIBUDEV)
target_link_libraries(lxqt-session ${UDEV_LIBS})

View File

@ -0,0 +1,32 @@
--- src/lxqt-session/src/lxqtmodman.cpp 2021-04-16 16:36:14.000000000 +0000
+++ src.mod/lxqt-session/src/lxqtmodman.cpp 2021-05-20 15:05:04.165344000 +0000
@@ -43,7 +43,6 @@
#include <QDateTime>
#include "wmselectdialog.h"
#include "windowmanager.h"
-#include <wordexp.h>
#include "log.h"
#include <KWindowSystem/KWindowSystem>
@@ -429,20 +428,7 @@
void lxqt_setenv(const char *env, const QByteArray &value)
{
- wordexp_t p;
- wordexp(value.constData(), &p, 0);
- if (p.we_wordc == 1)
- {
-
- qCDebug(SESSION) << "Environment variable" << env << "=" << p.we_wordv[0];
- qputenv(env, p.we_wordv[0]);
- }
- else
- {
- qCWarning(SESSION) << "Error expanding environment variable" << env << "=" << value;
- qputenv(env, value);
- }
- wordfree(&p);
+ qputenv(env, value);
}
void lxqt_setenv_prepend(const char *env, const QByteArray &value, const QByteArray &separator)