strace: update to 5.16
This commit is contained in:
parent
d51177aa78
commit
c1f8de1288
@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=https://strace.io/
|
||||
TERMUX_PKG_DESCRIPTION="Debugging utility to monitor system calls and signals received"
|
||||
TERMUX_PKG_LICENSE="BSD"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=5.14
|
||||
TERMUX_PKG_VERSION=5.16
|
||||
TERMUX_PKG_SRCURL=https://github.com/strace/strace/releases/download/v$TERMUX_PKG_VERSION/strace-$TERMUX_PKG_VERSION.tar.xz
|
||||
TERMUX_PKG_SHA256=901bee6db5e17debad4530dd9ffb4dc9a96c4a656edbe1c3141b7cb307b11e73
|
||||
TERMUX_PKG_SHA256=dc7db230ff3e57c249830ba94acab2b862da1fcaac55417e9b85041a833ca285
|
||||
TERMUX_PKG_AUTO_UPDATE=true
|
||||
TERMUX_PKG_DEPENDS="libdw"
|
||||
|
||||
@ -20,6 +20,5 @@ TERMUX_PKG_RM_AFTER_INSTALL="bin/strace-graph"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
autoreconf # for configure.ac in 5.11fix.patch
|
||||
CPPFLAGS+=" -Dfputs_unlocked=fputs -DPR_SET_VMA=0x53564d41"
|
||||
# remove the -DPR_SET_VMA for >5.13
|
||||
CPPFLAGS+=" -Dfputs_unlocked=fputs"
|
||||
}
|
||||
|
@ -1,10 +1,11 @@
|
||||
--- strace-5.11/src/sigreturn.c 2021-02-16 08:00:00.000000000 +0000
|
||||
+++ strace-5.11.mod/src/sigreturn.c 2021-02-24 13:57:17.100000000 +0000
|
||||
@@ -14,14 +14,16 @@
|
||||
@@ -14,15 +14,17 @@
|
||||
# include <asm/sigcontext.h>
|
||||
#endif
|
||||
|
||||
+#if !(defined(__ANDROID__) && (defined(__arm__) || defined(__aarch64__)))
|
||||
/* The following function might be unused, hence the inline qualifier. */
|
||||
static inline void
|
||||
print_sigmask_addr_size(const void *const addr, const unsigned int size)
|
||||
{
|
||||
|
Loading…
Reference in New Issue
Block a user