move from unstable: distcc

This commit is contained in:
Leonid Pliushch 2021-10-08 17:51:53 +03:00
parent a777f84966
commit c40ac6e543
No known key found for this signature in database
GPG Key ID: 45F2964132545795
3 changed files with 46 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -uNr distcc/Makefile.in distcc.mod/Makefile.in
--- distcc/Makefile.in 2018-07-27 08:08:55.000000000 +0300
+++ distcc.mod/Makefile.in 2019-02-05 15:54:16.980606827 +0200
@@ -85,7 +85,7 @@
# directory names of possible locations for the installation to be
# checked. Change the value of this variable to @bindir@ to check the
# installation at the location determined by 'configure'.
-DISTCC_INSTALLATION = $(RESTRICTED_PATH)
+DISTCC_INSTALLATION = @bindir@
dist_files = \
src/config.h.in \

21
packages/distcc/build.sh Normal file
View File

@ -0,0 +1,21 @@
TERMUX_PKG_HOMEPAGE=http://distcc.org/
TERMUX_PKG_DESCRIPTION="Distributed C/C++ compiler."
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="Leonid Pliushch <leonid.pliushch@gmail.com>"
TERMUX_PKG_VERSION=3.4
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://github.com/distcc/distcc/releases/download/v$TERMUX_PKG_VERSION/distcc-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=2b99edda9dad9dbf283933a02eace6de7423fe5650daa4a728c950e5cd37bd7d
TERMUX_PKG_DEPENDS="libpopt"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--disable-pump-mode
--without-avahi
--without-gtk
--without-libiberty"
termux_step_pre_configure() {
./autogen.sh
export LIBS="-llog"
}

View File

@ -0,0 +1,13 @@
diff -uNr distcc/src/util.c distcc.mod/src/util.c
--- distcc/src/util.c 2018-07-27 08:08:55.000000000 +0300
+++ distcc.mod/src/util.c 2019-02-05 16:49:03.805286863 +0200
@@ -39,6 +39,9 @@
#include <sys/un.h>
#include <sys/socket.h>
+#include <linux/in.h>
+#include <linux/in6.h>
+
#ifdef HAVE_SYS_RESOURCE_H
#include <sys/resource.h>
#endif