glulxe: Clean build script and update to 0.5.4 for real

This commit is contained in:
Henrik Grimler 2019-10-24 21:56:57 +02:00
parent c5c078fd63
commit c528c9a65e
3 changed files with 23 additions and 33 deletions

View File

@ -1,6 +1,5 @@
diff -u -r ../glulxe/Makefile ./Makefile
--- ../glulxe/Makefile 2013-03-11 03:09:38.000000000 +0100
+++ ./Makefile 2014-02-15 13:42:39.000000000 +0100
--- ../Makefile.orig 2017-01-23 20:14:37.000000000 +0100
+++ ./Makefile 2019-10-24 21:25:57.022914016 +0200
@@ -7,9 +7,9 @@
# sets of values appear below; uncomment one of them and change the
# directories appropriately.
@ -14,7 +13,7 @@ diff -u -r ../glulxe/Makefile ./Makefile
#GLKINCLUDEDIR = ../glkterm
#GLKLIBDIR = ../glkterm
@@ -25,9 +25,8 @@
@@ -29,9 +29,8 @@
# Pick a C compiler.
#CC = cc
@ -23,5 +22,5 @@ diff -u -r ../glulxe/Makefile ./Makefile
-OPTIONS = -g -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-unused -DOS_UNIX
+OPTIONS := $(CFLAGS) -DOS_UNIX
include $(GLKINCLUDEDIR)/$(GLKMAKEFILE)
# Locate the libxml2 library. You only need these lines if you are using
# the VM_DEBUGGER option. If so, uncomment these and set appropriately.

View File

@ -1,29 +1,20 @@
TERMUX_PKG_HOMEPAGE=http://www.eblong.com/zarf/glulx/
TERMUX_PKG_HOMEPAGE=https://www.eblong.com/zarf/glulx/
TERMUX_PKG_DESCRIPTION="Interpreter for the Glulx portable VM for interactive fiction (IF) games"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_VERSION=0.5.4
TERMUX_PKG_SRCURL=http://www.eblong.com/zarf/glulx/glulxe-051.tar.gz
TERMUX_PKG_SHA256=33c563bdbd0fdbae625e1a2441e9a6f40f1491f1cdc2a197bbd6cf2c32c3830d
TERMUX_PKG_BUILD_IN_SRC="yes"
TERMUX_PKG_VERSION=(0.5.4
1.0.4)
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=(https://www.eblong.com/zarf/glulx/glulxe-${TERMUX_PKG_VERSION[0]//.}.tar.gz
https://www.eblong.com/zarf/glk/glktermw-${TERMUX_PKG_VERSION[1]//.}.tar.gz)
TERMUX_PKG_SHA256=(1fc26f8aa31c880dbc7c396ede196c5d2cdff9bdefc6b192f320a96c5ef3376e
5968630b45e2fd53de48424559e3579db0537c460f4dc2631f258e1c116eb4ea)
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_DEPENDS="ncurses"
termux_step_configure () {
termux_download http://eblong.com/zarf/glk/glktermw-104.tar.gz \
$TERMUX_PKG_CACHEDIR/glktermw-104.tar.gz \
5968630b45e2fd53de48424559e3579db0537c460f4dc2631f258e1c116eb4ea
tar xf $TERMUX_PKG_CACHEDIR/glktermw-104.tar.gz
}
termux_step_make () {
cd $TERMUX_PKG_SRCDIR/glkterm
patch -p1 < $TERMUX_PKG_BUILDER_DIR/glkterm.patch.special
CC="$CC $CFLAGS $CPPFLAGS $LDFLAGS" PREFIX=$TERMUX_PREFIX make -j 1
cd ..
make
cp glulxe $TERMUX_PREFIX/bin
termux_step_post_configure () {
CC="$CC $CFLAGS $CPPFLAGS $LDFLAGS" PREFIX=$TERMUX_PREFIX make -C glkterm
}
termux_step_make_install () {
echo "Do nothing..."
install glulxe $TERMUX_PREFIX/bin
}

View File

@ -1,6 +1,6 @@
diff -u -r ../../glkterm/Makefile ./Makefile
diff -u -r ../../glkterm/Makefile ./glkterm/Makefile
--- ../../glkterm/Makefile 2012-10-14 19:21:09.000000000 +0200
+++ ./Makefile 2014-02-15 13:43:48.000000000 +0100
+++ ./glkterm/Makefile 2014-02-15 13:43:48.000000000 +0100
@@ -10,21 +10,21 @@
# Pick a C compiler.
@ -38,9 +38,9 @@ diff -u -r ../../glkterm/Makefile ./Makefile
Make.glktermw:
echo LINKLIBS = $(LIBDIRS) $(LIBS) > Make.glktermw
diff -u -r ../../glkterm/cgdate.c ./cgdate.c
diff -u -r ../../glkterm/cgdate.c ./glkterm/cgdate.c
--- ../../glkterm/cgdate.c 2012-10-14 19:21:09.000000000 +0200
+++ ./cgdate.c 2014-02-15 13:45:27.000000000 +0100
+++ ./glkterm/cgdate.c 2014-02-15 13:45:27.000000000 +0100
@@ -7,6 +7,24 @@
#include "glk.h"
#include "glkterm.h"
@ -66,9 +66,9 @@ diff -u -r ../../glkterm/cgdate.c ./cgdate.c
/* This file is copied directly from the cheapglk package.
(Except that warning string constants are changed to L"..." constants.) */
diff -u -r ../../glkterm/gtncursesw.c ./gtncursesw.c
diff -u -r ../../glkterm/gtncursesw.c ./glkterm/gtncursesw.c
--- ../../glkterm/gtncursesw.c 2012-10-14 19:21:09.000000000 +0200
+++ ./gtncursesw.c 2014-02-15 13:43:48.000000000 +0100
+++ ./glkterm/gtncursesw.c 2014-02-15 13:43:48.000000000 +0100
@@ -92,7 +92,7 @@
#else /* LOCAL_NCURSESW */