asciinema: Update from 1.1.1 to 1.2.0
This commit is contained in:
parent
ea46b7443f
commit
c52d3653c8
@ -1,22 +1,14 @@
|
|||||||
diff -u -r ../asciinema-1.1.1/Makefile ./Makefile
|
diff -u -r ../asciinema-1.2.0/Makefile ./Makefile
|
||||||
--- ../asciinema-1.1.1/Makefile 2015-06-21 17:58:14.000000000 +0200
|
--- ../asciinema-1.2.0/Makefile 2016-02-22 06:00:31.000000000 -0500
|
||||||
+++ ./Makefile 2015-08-20 01:39:05.000000000 +0200
|
+++ ./Makefile 2016-03-07 18:42:26.516807994 -0500
|
||||||
@@ -1,6 +1,6 @@
|
@@ -13,8 +13,8 @@
|
||||||
NAME=asciinema
|
|
||||||
VERSION=$(shell grep 'const Version' main.go | awk -F '"' '{print $$2}')
|
|
||||||
-COMMIT=$(shell git rev-parse --short HEAD)
|
|
||||||
+COMMIT=1.1.1
|
|
||||||
|
|
||||||
DIRS=bin
|
|
||||||
INSTALL_DIRS=`find $(DIRS) -type d 2>/dev/null`
|
|
||||||
@@ -14,8 +14,8 @@
|
|
||||||
|
|
||||||
all: build
|
all: build
|
||||||
|
|
||||||
-build: test
|
-build: test
|
||||||
- go build -o bin/asciinema -ldflags "-X main.GitCommit $(COMMIT)"
|
- go build -o bin/asciinema
|
||||||
+build:
|
+build:
|
||||||
+ go build -o bin/asciinema -ldflags "-extldflags=-pie -X main.GitCommit $(COMMIT)"
|
+ go build -o bin/asciinema -ldflags "-extldflags=-pie"
|
||||||
|
|
||||||
test:
|
test:
|
||||||
go test ./...
|
go test ./...
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://asciinema.org/
|
TERMUX_PKG_HOMEPAGE=https://asciinema.org/
|
||||||
TERMUX_PKG_DESCRIPTION="Record and share your terminal sessions, the right way"
|
TERMUX_PKG_DESCRIPTION="Record and share your terminal sessions, the right way"
|
||||||
TERMUX_PKG_VERSION=1.1.1
|
TERMUX_PKG_VERSION=1.2.0
|
||||||
TERMUX_PKG_BUILD_REVISION=2
|
|
||||||
TERMUX_PKG_SRCURL=https://github.com/asciinema/asciinema/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://github.com/asciinema/asciinema/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||||
TERMUX_PKG_FOLDERNAME=asciinema-${TERMUX_PKG_VERSION}
|
TERMUX_PKG_FOLDERNAME=asciinema-${TERMUX_PKG_VERSION}
|
||||||
TERMUX_PKG_BUILD_IN_SRC=yes
|
TERMUX_PKG_BUILD_IN_SRC=yes
|
||||||
|
Loading…
Reference in New Issue
Block a user