Skip checks for reallocarray and recallocarray
This commit is contained in:
parent
81b6aec8f7
commit
c5c24fdff1
@ -1,10 +1,11 @@
|
||||
We actually do want tmux.conf to go into ${prefix}/etc,
|
||||
1. We actually do want tmux.conf to go into ${prefix}/etc,
|
||||
since the real /etc is not writeable on Android.
|
||||
2. Skip both reallocarray and recallocarray checks
|
||||
|
||||
diff -u -r ../tmux-3.1a/configure.ac ./configure.ac
|
||||
--- ../tmux-3.1a/configure.ac 2020-04-27 08:38:04.000000000 +0000
|
||||
diff -u -r ../tmux-3.2/configure.ac ./configure.ac
|
||||
--- ../tmux-3.2/configure.ac 2020-04-27 08:38:04.000000000 +0000
|
||||
+++ ./configure.ac 2020-04-28 22:36:58.650391000 +0000
|
||||
@@ -32,9 +32,6 @@
|
||||
@@ -52,9 +52,6 @@
|
||||
PKG_PROG_PKG_CONFIG
|
||||
AC_USE_SYSTEM_EXTENSIONS
|
||||
|
||||
@ -14,3 +15,28 @@ diff -u -r ../tmux-3.1a/configure.ac ./configure.ac
|
||||
# Is this --enable-debug?
|
||||
case "x$VERSION" in xnext*) enable_debug=yes;; esac
|
||||
AC_ARG_ENABLE(
|
||||
@@ -157,22 +154,8 @@
|
||||
# Clang sanitizers wrap reallocarray even if it isn't available on the target
|
||||
# system. When compiled it always returns NULL and crashes the program. To
|
||||
# detect this we need a more complicated test.
|
||||
-AC_MSG_CHECKING([for working reallocarray])
|
||||
-AC_RUN_IFELSE([AC_LANG_PROGRAM(
|
||||
- [#include <stdlib.h>],
|
||||
- [return (reallocarray(NULL, 1, 1) == NULL);]
|
||||
- )],
|
||||
- AC_MSG_RESULT(yes),
|
||||
- [AC_LIBOBJ(reallocarray) AC_MSG_RESULT([no])]
|
||||
-)
|
||||
-AC_MSG_CHECKING([for working recallocarray])
|
||||
-AC_RUN_IFELSE([AC_LANG_PROGRAM(
|
||||
- [#include <stdlib.h>],
|
||||
- [return (recallocarray(NULL, 1, 1, 1) == NULL);]
|
||||
- )],
|
||||
- AC_MSG_RESULT(yes),
|
||||
- [AC_LIBOBJ(recallocarray) AC_MSG_RESULT([no])]
|
||||
-)
|
||||
+AC_LIBOBJ(reallocarray)
|
||||
+AC_LIBOBJ(recallocarray)
|
||||
|
||||
# Look for clock_gettime. Must come before event_init.
|
||||
AC_SEARCH_LIBS(clock_gettime, rt)
|
||||
|
Loading…
Reference in New Issue
Block a user