gegl: Update from 0.4.16 to 0.4.18

This commit is contained in:
Fredrik Fornwall 2019-12-01 18:08:38 +01:00
parent 63021dc21e
commit c5f65f3407
2 changed files with 52 additions and 8 deletions

View File

@ -0,0 +1,48 @@
From 6bcf95fd0f32cf5e8b1ddbe17b14d9ad049bded8 Mon Sep 17 00:00:00 2001
From: Christoph Reiter <reiter.christoph@gmail.com>
Date: Sun, 27 Oct 2019 14:10:08 +0100
Subject: [PATCH] meson: fix cpu detection
Use host_machine.cpu_family() instead of cpu(). Only the former
provides a stable/defined set of values.
Also don't error out on some arches for no good reason.
This fixes the build on 32bit Windows.
---
meson.build | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)
diff --git a/meson.build b/meson.build
index af133a0f1..540498921 100644
--- a/meson.build
+++ b/meson.build
@@ -73,23 +73,21 @@ if os_osx and cc.get_id() != 'clang'
endif
-host_cpu = host_machine.cpu()
-if host_cpu.startswith('i') and host_cpu.endswith('86')
+host_cpu_family = host_machine.cpu_family()
+if host_cpu_family == 'x86'
have_x86 = true
config.set10('ARCH_X86', true)
-elif host_cpu == 'x86_64'
+elif host_cpu_family == 'x86_64'
have_x86 = true
config.set10('ARCH_X86', true)
config.set10('ARCH_X86_64', true)
-elif host_cpu == 'ppc' or host_cpu == 'powerpc'
+elif host_cpu_family == 'ppc'
have_ppc = true
config.set10('ARCH_PPC', true)
-elif host_cpu == 'ppc64' or host_cpu == 'powerpc64'
+elif host_cpu_family == 'ppc64'
have_ppc = true
config.set10('ARCH_PPC', true)
config.set10('ARCH_PPC64', true)
-else
- error('Unknown host architecture')
endif
################################################################################

View File

@ -1,14 +1,10 @@
TERMUX_PKG_HOMEPAGE=http://gegl.org/
TERMUX_PKG_DESCRIPTION="Data flow based image processing framework"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_VERSION=0.4.16
TERMUX_PKG_REVISION=4
TERMUX_PKG_SRCURL=https://download.gimp.org/pub/gegl/${TERMUX_PKG_VERSION:0:3}/gegl-${TERMUX_PKG_VERSION}.tar.bz2
TERMUX_PKG_SHA256=0112df690301d9eb993cc48965fc71b7751c9021a4f4ee08fcae366c326b5e5a
TERMUX_PKG_VERSION=0.4.18
TERMUX_PKG_SRCURL=https://download.gimp.org/pub/gegl/${TERMUX_PKG_VERSION:0:3}/gegl-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=c946dfb45beb7fe0fb95b89a25395b449eda2b205ba3e8a1ffb1ef992d9eca64
TERMUX_PKG_DEPENDS="libandroid-support, libc++, ffmpeg, babl, json-glib, libjpeg-turbo, libpng, libjasper, littlecms, libtiff, librsvg, zlib"
TERMUX_PKG_BREAKS="gegl-dev"
TERMUX_PKG_REPLACES="gegl-dev"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--without-gdk-pixbuf
ac_cv_func_bind_textdomain_codeset=yes
"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="-Dintrospection=false"