feat(snapcast-server): enable auto-update, upgrade to 0.26.0
Signed-off-by: Aditya Alok <dev.aditya.alok@gmail.com>
This commit is contained in:
parent
c5d3c5e4d6
commit
c69deee0c5
@ -1,14 +1,14 @@
|
|||||||
--- a/CMakeLists.txt
|
--- a/CMakeLists.txt 2022-04-15 02:22:36.772384329 +0530
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt 2022-04-15 03:22:33.096962106 +0530
|
||||||
@@ -91,11 +91,6 @@
|
@@ -91,11 +91,6 @@
|
||||||
if (BUILD_CLIENT)
|
if (BUILD_CLIENT)
|
||||||
message(FATAL_ERROR "Snapclient not yet supported for FreeBSD, use \"-DBUILD_CLIENT=OFF\"")
|
message(FATAL_ERROR "Snapclient not yet supported for FreeBSD, use \"-DBUILD_CLIENT=OFF\"")
|
||||||
endif()
|
endif()
|
||||||
-elseif (${CMAKE_SYSTEM_NAME} MATCHES "Android")
|
-elseif (${CMAKE_SYSTEM_NAME} MATCHES "Android")
|
||||||
- set (ANDROID TRUE)
|
- set (ANDROID TRUE)
|
||||||
- if (BUILD_SERVER)
|
-# if (BUILD_SERVER)
|
||||||
- message(FATAL_ERROR "Snapserver not yet supported for Android, use \"-DBUILD_SERVER=OFF\"")
|
-# message(FATAL_ERROR "Snapserver not yet supported for Android, use \"-DBUILD_SERVER=OFF\"")
|
||||||
- endif()
|
-# endif()
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
# Configure paths
|
# Configure paths
|
||||||
@ -30,7 +30,7 @@
|
|||||||
|
|
||||||
if(MACOSX)
|
if(MACOSX)
|
||||||
set(BONJOUR_FOUND true)
|
set(BONJOUR_FOUND true)
|
||||||
@@ -178,11 +173,6 @@
|
@@ -178,11 +173,7 @@
|
||||||
list(APPEND INCLUDE_DIRS "/usr/local/include")
|
list(APPEND INCLUDE_DIRS "/usr/local/include")
|
||||||
else()
|
else()
|
||||||
|
|
||||||
@ -39,15 +39,16 @@
|
|||||||
- add_definitions(-DHAS_ALSA)
|
- add_definitions(-DHAS_ALSA)
|
||||||
- endif (ALSA_FOUND)
|
- endif (ALSA_FOUND)
|
||||||
-
|
-
|
||||||
|
+
|
||||||
if(BUILD_WITH_PULSE)
|
if(BUILD_WITH_PULSE)
|
||||||
pkg_search_module(PULSE libpulse)
|
pkg_search_module(PULSE libpulse)
|
||||||
if (PULSE_FOUND)
|
if (PULSE_FOUND)
|
||||||
@@ -279,7 +269,7 @@
|
@@ -279,7 +270,7 @@
|
||||||
endif()
|
endif()
|
||||||
endif()
|
endif()
|
||||||
|
|
||||||
-if(NOT ANDROID)
|
-if(NOT ANDROID)
|
||||||
+if(TRUE)
|
+if(TRUE)
|
||||||
find_package(Boost 1.70 REQUIRED)
|
find_package(Boost 1.74 REQUIRED)
|
||||||
else()
|
else()
|
||||||
find_package(oboe REQUIRED CONFIG)
|
find_package(oboe REQUIRED CONFIG)
|
||||||
|
@ -2,16 +2,16 @@ TERMUX_PKG_HOMEPAGE=https://github.com/badaix/snapcast
|
|||||||
TERMUX_PKG_DESCRIPTION="A multiroom client-server audio player (server)"
|
TERMUX_PKG_DESCRIPTION="A multiroom client-server audio player (server)"
|
||||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||||
TERMUX_PKG_MAINTAINER="@termux"
|
TERMUX_PKG_MAINTAINER="@termux"
|
||||||
TERMUX_PKG_VERSION=0.25.0
|
TERMUX_PKG_VERSION=0.26.0
|
||||||
TERMUX_PKG_REVISION=3
|
|
||||||
TERMUX_PKG_SRCURL=https://github.com/badaix/snapcast/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://github.com/badaix/snapcast/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||||
TERMUX_PKG_SHA256=c4e449cb693e091261727421f4965492be049632537e034fa9c59c92d091a846
|
TERMUX_PKG_SHA256=166353267a5c461a3a0e7cbd05d78c4bfdaebeda078801df3b76820b54f27683
|
||||||
TERMUX_PKG_DEPENDS="libc++, libexpat, libflac, libopus, libsoxr, libvorbis"
|
TERMUX_PKG_DEPENDS="libc++, libexpat, libflac, libopus, libsoxr, libvorbis"
|
||||||
TERMUX_PKG_BUILD_DEPENDS="boost, boost-headers"
|
TERMUX_PKG_BUILD_DEPENDS="boost, boost-headers"
|
||||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||||
-DBUILD_TESTS=OFF
|
-DBUILD_TESTS=OFF
|
||||||
-DBoost_INCLUDE_DIR=$TERMUX_PREFIX/include
|
-DBoost_INCLUDE_DIR=$TERMUX_PREFIX/include
|
||||||
"
|
"
|
||||||
|
TERMUX_PKG_AUTO_UPDATE=true
|
||||||
|
|
||||||
termux_step_pre_configure() {
|
termux_step_pre_configure() {
|
||||||
LDFLAGS+=" -llog"
|
LDFLAGS+=" -llog"
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/client/snapclient.cpp
|
--- a/client/snapclient.cpp 2022-04-15 02:22:36.712384329 +0530
|
||||||
+++ b/client/snapclient.cpp
|
+++ b/client/snapclient.cpp 2022-04-15 02:23:43.542384304 +0530
|
||||||
@@ -312,7 +312,7 @@
|
@@ -308,7 +308,7 @@
|
||||||
std::unique_ptr<Daemon> daemon;
|
std::unique_ptr<Daemon> daemon;
|
||||||
if (daemonOption->is_set())
|
if (daemonOption->is_set())
|
||||||
{
|
{
|
||||||
|
24
packages/snapcast-server/server-CMakeLists.txt.patch
Normal file
24
packages/snapcast-server/server-CMakeLists.txt.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
--- a/server/CMakeLists.txt 2022-04-15 02:22:36.942384329 +0530
|
||||||
|
+++ b/server/CMakeLists.txt 2022-04-15 04:16:58.176960860 +0530
|
||||||
|
@@ -41,7 +41,7 @@
|
||||||
|
${CMAKE_SOURCE_DIR}/server
|
||||||
|
${CMAKE_SOURCE_DIR}/common)
|
||||||
|
|
||||||
|
-if (ANDROID)
|
||||||
|
+if (FALSE)
|
||||||
|
find_package(vorbis REQUIRED CONFIG)
|
||||||
|
list(APPEND SERVER_LIBRARIES boost::boost)
|
||||||
|
list(APPEND SERVER_LIBRARIES flac::flac)
|
||||||
|
@@ -90,12 +90,6 @@
|
||||||
|
list(APPEND SERVER_INCLUDE ${OPUS_INCLUDE_DIRS})
|
||||||
|
endif (OPUS_FOUND)
|
||||||
|
|
||||||
|
- if (ALSA_FOUND)
|
||||||
|
- list(APPEND SERVER_SOURCES streamreader/alsa_stream.cpp)
|
||||||
|
- list(APPEND SERVER_LIBRARIES ${ALSA_LIBRARIES})
|
||||||
|
- list(APPEND SERVER_INCLUDE ${ALSA_INCLUDE_DIRS})
|
||||||
|
- endif (ALSA_FOUND)
|
||||||
|
-
|
||||||
|
if (EXPAT_FOUND)
|
||||||
|
list(APPEND SERVER_LIBRARIES ${EXPAT_LIBRARIES})
|
||||||
|
list(APPEND SERVER_INCLUDE ${EXPAT_INCLUDE_DIRS})
|
@ -24,10 +24,10 @@
|
|||||||
# disabled if commented or empty
|
# disabled if commented or empty
|
||||||
-doc_root = /usr/share/snapserver/snapweb
|
-doc_root = /usr/share/snapserver/snapweb
|
||||||
+doc_root = @TERMUX_PREFIX@/share/snapserver/snapweb
|
+doc_root = @TERMUX_PREFIX@/share/snapserver/snapweb
|
||||||
#
|
|
||||||
###############################################################################
|
|
||||||
|
|
||||||
@@ -127,7 +127,7 @@
|
# Hostname or IP under which clients can reach this host
|
||||||
|
# used to serve cached cover art
|
||||||
|
@@ -133,7 +133,7 @@
|
||||||
# tcp client: tcp://<server IP, e.g. 127.0.0.1>:<port>?name=<name>&mode=client
|
# tcp client: tcp://<server IP, e.g. 127.0.0.1>:<port>?name=<name>&mode=client
|
||||||
# alsa: alsa://?name=<name>&device=<alsa device>[&send_silence=false][&idle_threshold=100][&silence_threshold_percent=0.0]
|
# alsa: alsa://?name=<name>&device=<alsa device>[&send_silence=false][&idle_threshold=100][&silence_threshold_percent=0.0]
|
||||||
# meta: meta:///<name of source#1>/<name of source#2>/.../<name of source#N>?name=<name>
|
# meta: meta:///<name of source#1>/<name of source#2>/.../<name of source#N>?name=<name>
|
||||||
@ -35,4 +35,4 @@
|
|||||||
+source = pipe://@TERMUX_PREFIX@/tmp/snapfifo?name=default
|
+source = pipe://@TERMUX_PREFIX@/tmp/snapfifo?name=default
|
||||||
#source = tcp://127.0.0.1?name=mopidy_tcp
|
#source = tcp://127.0.0.1?name=mopidy_tcp
|
||||||
|
|
||||||
# Default sample format
|
# Default sample format: <sample rate>:<bits per sample>:<channels>
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
--- a/test/test_main.cpp
|
--- a/test/test_main.cpp 2022-04-15 02:22:36.962384329 +0530
|
||||||
+++ b/test/test_main.cpp
|
+++ b/test/test_main.cpp 2022-04-15 02:41:15.916963051 +0530
|
||||||
@@ -36,9 +36,9 @@
|
@@ -41,9 +41,9 @@
|
||||||
{
|
{
|
||||||
AixLog::Log::init<AixLog::SinkCout>(AixLog::Severity::debug);
|
AixLog::Log::init<AixLog::SinkCout>(AixLog::Severity::debug);
|
||||||
using namespace streamreader;
|
using namespace streamreader;
|
||||||
- StreamUri uri("pipe:///tmp/snapfifo?name=default&codec=flac");
|
- StreamUri uri("pipe:///tmp/snapfifo?name=default&codec=flac");
|
||||||
+ StreamUri uri("pipe://@TERMUX_PREFIX@/tmp/snapfifo?name=default&codec=flac");
|
+ StreamUri uri("pipe://@TERMUX_PREFIX@/tmp/snapfifo?name=default&codec=flac");
|
||||||
REQUIRE(uri.scheme == "pipe");
|
REQUIRE(uri.scheme == "pipe");
|
||||||
- REQUIRE(uri.path == "/tmp/snapfifo");
|
- REQUIRE(uri.path == "/tmp/snapfifo");
|
||||||
+ REQUIRE(uri.path == "@TERMUX_PREFIX@/tmp/snapfifo");
|
+ REQUIRE(uri.path == "@TERMUX_PREFIX@/tmp/snapfifo");
|
||||||
REQUIRE(uri.host.empty());
|
REQUIRE(uri.host.empty());
|
||||||
|
|
||||||
// uri = StreamUri("scheme:[//host[:port]][/]path[?query=none][#fragment]");
|
// uri = StreamUri("scheme:[//host[:port]][/]path[?query=none][#fragment]");
|
||||||
|
Loading…
Reference in New Issue
Block a user