babl: Update from 0.1.68 to 0.1.70

This commit is contained in:
Fredrik Fornwall 2019-08-08 12:02:36 +02:00
parent f3ceb9a2f4
commit c7d6ee2711
6 changed files with 39 additions and 33 deletions

View File

@ -1,13 +0,0 @@
diff -u -r ../babl-BABL_0_1_62/Makefile.am ./Makefile.am
--- ../babl-BABL_0_1_62/Makefile.am 2019-02-01 16:22:50.000000000 +0000
+++ ./Makefile.am 2019-02-03 21:11:44.103560598 +0000
@@ -3,8 +3,7 @@
SUBDIRS = \
babl \
extensions \
- tools \
- tests
+ tools
if ENABLE_DOCS
SUBDIRS+= docs

View File

@ -0,0 +1,12 @@
diff -u -r ../babl-0.1.70/babl/meson.build ./babl/meson.build
--- ../babl-0.1.70/babl/meson.build 2019-08-02 16:16:52.000000000 +0000
+++ ./babl/meson.build 2019-08-08 09:55:50.648892290 +0000
@@ -128,7 +128,7 @@
c_args: babl_c_args,
link_whole: [ babl_base, ],
link_args: [ babl_link_args, ],
- dependencies: [ math, thread, dl, lcms, ],
+ dependencies: [ math, thread, dl, lcms, log, ],
link_depends: [ version_script_target, ],
version: so_version,
install: true,

View File

@ -1,14 +1,9 @@
TERMUX_PKG_HOMEPAGE=http://gegl.org/babl/
TERMUX_PKG_DESCRIPTION="Dynamic pixel format translation library"
TERMUX_PKG_LICENSE="LGPL-3.0"
TERMUX_PKG_VERSION=0.1.68
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://github.com/GNOME/babl/archive/BABL_${TERMUX_PKG_VERSION//./_}.tar.gz
TERMUX_PKG_SHA256=788f60c6ae9a78c9ed7b6a0f2a1e2c493d81a5b1e5f3c795447b01824331637e
TERMUX_PKG_VERSION=0.1.70
TERMUX_PKG_SRCURL=https://download.gimp.org/pub/babl/0.1/babl-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_SHA256=06ad1f83c33bca265182b1e5af6262574ed4fa9804375ca6641b39f5be69484d
TERMUX_PKG_DEPENDS="littlecms"
TERMUX_PKG_BREAKS="babl-dev"
TERMUX_PKG_REPLACES="babl-dev"
termux_step_pre_configure() {
NOCONFIGURE=1 ./autogen.sh
}

View File

@ -0,0 +1,12 @@
diff -u -r ../babl-0.1.70/tests/meson.build ./tests/meson.build
--- ../babl-0.1.70/tests/meson.build 2019-08-02 16:16:52.000000000 +0000
+++ ./tests/meson.build 2019-08-08 09:58:14.015259147 +0000
@@ -41,7 +41,7 @@
test_name + '.c',
include_directories: [ rootInclude, bablInclude, ],
link_with: [ babl, ],
- dependencies: [ thread, ],
+ dependencies: [ thread, log, ],
export_dynamic: true,
install: false,
)

View File

@ -1,12 +0,0 @@
diff -u -r ../babl-BABL_0_1_34/tools/Makefile.am ./tools/Makefile.am
--- ../babl-BABL_0_1_34/tools/Makefile.am 2017-10-06 15:15:57.000000000 +0200
+++ ./tools/Makefile.am 2017-10-14 20:30:33.268973098 +0200
@@ -2,7 +2,7 @@
AM_LDFLAGS = -no-install
LDADD = $(top_builddir)/babl/libbabl-@BABL_API_VERSION@.la \
- $(MATH_LIB) $(THREAD_LIB)
+ $(MATH_LIB) $(THREAD_LIB) $(LOG_LIB)
noinst_PROGRAMS = \
babl-verify \

View File

@ -0,0 +1,12 @@
diff -u -r ../babl-0.1.70/tools/meson.build ./tools/meson.build
--- ../babl-0.1.70/tools/meson.build 2019-08-02 16:16:52.000000000 +0000
+++ ./tools/meson.build 2019-08-08 09:59:07.362648769 +0000
@@ -17,7 +17,7 @@
tool_name + '.c',
include_directories: [ rootInclude, bablInclude, ],
link_with: [ babl, ],
- dependencies: [ math, thread, ],
+ dependencies: [ math, thread, log, ],
install: false,
)