libgrpc: fix build and bump kubectl and lftp on CI

This commit is contained in:
Butta 2020-08-15 14:48:16 +05:30
parent c75ffc2e21
commit c972481fb3
4 changed files with 7 additions and 51 deletions

View File

@ -20,7 +20,7 @@ termux_step_get_source() {
termux_step_make() { termux_step_make() {
termux_setup_golang termux_setup_golang
# Needed to generate manpages. #Needed to generate manpages.
#( #(
# export GOPATH="$TERMUX_PKG_BUILDDIR/host" # export GOPATH="$TERMUX_PKG_BUILDDIR/host"
# unset GOOS GOARCH CGO_LDFLAGS # unset GOOS GOARCH CGO_LDFLAGS

View File

@ -19,7 +19,7 @@ ac_cv_func_dn_expand=no
termux_step_pre_configure() { termux_step_pre_configure() {
if $TERMUX_DEBUG; then if $TERMUX_DEBUG; then
# When doing debug build, -D_FORTIFY_SOURCE=2 gives this error: #When doing debug build, -D_FORTIFY_SOURCE=2 gives this error:
# /home/builder/.termux-build/_lib/16-aarch64-21-v3/bin/../sysroot/usr/include/bits/fortify/string.h:79:26: error: use of undeclared identifier '__USE_FORTIFY_LEVEL' # /home/builder/.termux-build/_lib/16-aarch64-21-v3/bin/../sysroot/usr/include/bits/fortify/string.h:79:26: error: use of undeclared identifier '__USE_FORTIFY_LEVEL'
export CFLAGS=${CFLAGS/-D_FORTIFY_SOURCE=2/} export CFLAGS=${CFLAGS/-D_FORTIFY_SOURCE=2/}
fi fi

View File

@ -30,6 +30,7 @@ termux_step_post_get_source() {
termux_step_host_build() { termux_step_host_build() {
termux_setup_cmake termux_setup_cmake
termux_setup_ninja
cd $TERMUX_PKG_SRCDIR cd $TERMUX_PKG_SRCDIR
export LD=gcc export LD=gcc
@ -41,11 +42,10 @@ termux_step_host_build() {
# when building version 1.17.2: # when building version 1.17.2:
CXXFLAGS="-Wno-error=class-memaccess" \ CXXFLAGS="-Wno-error=class-memaccess" \
CFLAGS="-Wno-implicit-fallthrough" \ CFLAGS="-Wno-implicit-fallthrough" \
make -j $TERMUX_MAKE_PROCESSES \ cmake -G Ninja -DCMAKE_INSTALL_PREFIX=$TERMUX_PKG_HOSTBUILD_DIR
HAS_SYSTEM_PROTOBUF=false \ ninja -j $TERMUX_MAKE_PROCESSES install
prefix=$TERMUX_PKG_HOSTBUILD_DIR \ ninja -t clean
install rm -rf CMakeCache.txt CMakeFiles
make clean
} }
termux_step_pre_configure() { termux_step_pre_configure() {

View File

@ -1,44 +0,0 @@
--- a/Makefile 2018-06-26 11:07:45.948160976 +0200
+++ b/Makefile 2019-06-26 11:04:25.798966336 +0200
@@ -2820,13 +2820,15 @@
install-headers_c:
$(E) "[INSTALL] Installing public C headers"
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
+ $(Q) for h in $(PUBLIC_HEADERS_C); do \
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
+ done
install-headers_cxx:
$(E) "[INSTALL] Installing public C++ headers"
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
+ $(Q) for h in $(PUBLIC_HEADERS_CXX); do \
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
+ done
install-static: install-static_c install-static_cxx
--- a/templates/Makefile.template 2019-06-26 12:38:36.777292299 +0200
+++ b/templates/Makefile.template 2019-06-26 12:48:35.668550020 +0200
@@ -1302,13 +1302,15 @@
install-headers_c:
$(E) "[INSTALL] Installing public C headers"
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
- $(Q) $(foreach h, $(PUBLIC_HEADERS_C), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
+ $(Q) for h in $(PUBLIC_HEADERS_C); do \
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
+ done
install-headers_cxx:
$(E) "[INSTALL] Installing public C++ headers"
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
+ $(Q) for h in $(PUBLIC_HEADERS_CXX); do \
+ $(INSTALL) -D $$h $(prefix)/$$h ; \
+ done
install-static: install-static_c install-static_cxx