feat(ncspot): update to 0.9.7, enable auto update
Signed-off-by: Aditya Alok <dev.aditya.alok@gmail.com>
This commit is contained in:
parent
61c35730a7
commit
cb5a146977
@ -1,30 +0,0 @@
|
||||
Backported from
|
||||
|
||||
https://github.com/hrkfdn/ncspot/commit/487bc0dba0acac0a57227bc090fc5d82eea0af15
|
||||
|
||||
and modified so that `termion_backend` is used by default.
|
||||
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -45,7 +45,7 @@
|
||||
regex = "1"
|
||||
ioctl-rs = { version = "0.2", optional = true }
|
||||
serde_cbor = "0.11.2"
|
||||
-pancurses = { version = "0.17.0", features = ["win32"] }
|
||||
+pancurses = { version = "0.17.0", features = ["win32"], optional = true }
|
||||
|
||||
[dependencies.rspotify]
|
||||
version = "0.11.3"
|
||||
@@ -65,10 +65,11 @@
|
||||
rodio_backend = ["librespot-playback/rodio-backend"]
|
||||
portaudio_backend = ["librespot-playback/portaudio-backend"]
|
||||
termion_backend = ["cursive/termion-backend"]
|
||||
+pancurses_backend = ["cursive/pancurses-backend"]
|
||||
mpris = ["dbus", "dbus-tree"]
|
||||
notify = ["notify-rust"]
|
||||
cover = ["ioctl-rs"]
|
||||
-default = ["share_clipboard", "pulseaudio_backend", "mpris", "notify", "cursive/pancurses-backend"]
|
||||
+default = ["share_clipboard", "pulseaudio_backend", "mpris", "notify", "termion_backend"]
|
||||
|
||||
[package.metadata.deb]
|
||||
depends = "$auto, pulseaudio"
|
@ -2,17 +2,15 @@ TERMUX_PKG_HOMEPAGE=https://github.com/hrkfdn/ncspot
|
||||
TERMUX_PKG_DESCRIPTION="An ncurses Spotify client written in Rust"
|
||||
TERMUX_PKG_LICENSE="BSD 2-Clause"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=0.9.3
|
||||
TERMUX_PKG_SRCURL=https://github.com/hrkfdn/ncspot/archive/refs/tags/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=ed873d007ce356e8c6eed56226533b686682a98d2a37487668416539d4e10e78
|
||||
TERMUX_PKG_VERSION=0.9.7
|
||||
TERMUX_PKG_SRCURL=https://github.com/hrkfdn/ncspot/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=6a7dec42d7ffde7d455b75dbc846f34463ae1e3c9bd84669382e90c4d1b31e3e
|
||||
TERMUX_PKG_DEPENDS="dbus, pulseaudio"
|
||||
TERMUX_PKG_AUTO_UPDATE=true
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
||||
termux_step_make() {
|
||||
termux_setup_rust
|
||||
cargo build --jobs $TERMUX_MAKE_PROCESSES --target $CARGO_TARGET_NAME --release
|
||||
}
|
||||
|
||||
termux_step_make_install() {
|
||||
install -Dm755 -t $TERMUX_PREFIX/bin target/${CARGO_TARGET_NAME}/release/ncspot
|
||||
}
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--no-default-features
|
||||
--features cursive/termion-backend,share_clipboard,pulseaudio_backend,mpris,notify
|
||||
"
|
||||
# NOTE: ncurses-rs runs a test while building which fails while cross compiling:
|
||||
# therefore, we use cursive/termion-backend instead.
|
||||
|
Loading…
Reference in New Issue
Block a user