libp8-platform: build shared library instead of static one

libcec (and perhaps other) looks only for a shared one.
This commit is contained in:
Henrik Grimler 2022-02-07 22:43:42 +01:00
parent ae08786aae
commit cbb644ef79
No known key found for this signature in database
GPG Key ID: B0076E490B71616B
2 changed files with 12 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- ../CMakeLists.txt.orig 2022-02-07 21:37:34.253637300 +0000
+++ ./CMakeLists.txt 2022-02-07 21:37:47.633618078 +0000
@@ -36,7 +36,7 @@
set(SOURCES src/util/StringUtils.cpp)
-add_library(p8-platform ${SOURCES} ${PLAT_SOURCES})
+add_library(p8-platform SHARED ${SOURCES} ${PLAT_SOURCES})
target_link_libraries(p8-platform ${p8-platform_LIBRARIES})
set_target_properties(p8-platform PROPERTIES VERSION ${p8-platform_VERSION_MAJOR}.${p8-platform_VERSION_MINOR}.${p8-platform_VERSION_PATCH}
SOVERSION ${p8-platform_VERSION_MAJOR})

View File

@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="Platform support library used by libCEC and binary add-o
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.1.0.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://github.com/Pulse-Eight/platform/archive/p8-platform-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=064f8d2c358895c7e0bea9ae956f8d46f3f057772cb97f2743a11d478a0f68a0
TERMUX_PKG_DEPENDS="libc++"