babl: Update to 0.1.90
This commit is contained in:
parent
48de1b3239
commit
cc00db05b9
@ -1,10 +1,37 @@
|
||||
diff -uNr babl-0.1.86/babl/base/meson.build babl-0.1.86.mod/babl/base/meson.build
|
||||
--- babl-0.1.86/babl/base/meson.build 2021-02-26 12:07:12.687609700 +0000
|
||||
+++ babl-0.1.86.mod/babl/base/meson.build 2021-05-03 18:24:40.532776557 +0000
|
||||
@@ -19,5 +19,5 @@
|
||||
--- a/babl/base/meson.build
|
||||
+++ b/babl/base/meson.build
|
||||
@@ -21,7 +21,7 @@
|
||||
babl_base = static_library('babl_base',
|
||||
babl_base_sources,
|
||||
include_directories: [rootInclude, bablInclude],
|
||||
- dependencies: [math, lcms],
|
||||
+ dependencies: [math, lcms, log],
|
||||
)
|
||||
c_args: common_c_flags + [sse2_cflags]
|
||||
)
|
||||
|
||||
@@ -30,14 +30,14 @@
|
||||
babl_base_x86_64_v2 = static_library('babl_base-x86-64-v2',
|
||||
babl_base_sources,
|
||||
include_directories: [rootInclude, bablInclude],
|
||||
- dependencies: [math, lcms],
|
||||
+ dependencies: [math, lcms, log],
|
||||
c_args: common_c_flags + x86_64_v2_flags
|
||||
)
|
||||
|
||||
babl_base_x86_64_v3 = static_library('babl_base-x86-64-v3',
|
||||
babl_base_sources,
|
||||
include_directories: [rootInclude, bablInclude],
|
||||
- dependencies: [math, lcms],
|
||||
+ dependencies: [math, lcms, log],
|
||||
c_args: common_c_flags + x86_64_v3_flags
|
||||
)
|
||||
|
||||
@@ -49,7 +49,7 @@
|
||||
babl_base_arm_neon = static_library('babl_base-arm-neon',
|
||||
babl_base_sources,
|
||||
include_directories: [rootInclude, bablInclude],
|
||||
- dependencies: [math, lcms],
|
||||
+ dependencies: [math, lcms, log],
|
||||
c_args: common_c_flags + arm_neon_flags
|
||||
)
|
||||
|
||||
|
@ -2,9 +2,10 @@ TERMUX_PKG_HOMEPAGE=https://gegl.org/babl/
|
||||
TERMUX_PKG_DESCRIPTION="Dynamic pixel format translation library"
|
||||
TERMUX_PKG_LICENSE="LGPL-3.0"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=0.1.88
|
||||
TERMUX_PKG_SRCURL=https://download.gimp.org/pub/babl/0.1/babl-$TERMUX_PKG_VERSION.tar.xz
|
||||
TERMUX_PKG_SHA256=4f0d7f4aaa0bb2e725f349adf7b351a957d9fb26d555d9895a7af816b4167039
|
||||
_MAJOR_VERSION=0.1
|
||||
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.90
|
||||
TERMUX_PKG_SRCURL=https://download.gimp.org/pub/babl/${_MAJOR_VERSION}/babl-${TERMUX_PKG_VERSION}.tar.xz
|
||||
TERMUX_PKG_SHA256=6e2ebb636f37581588e3d02499b3d2f69f9ac73e34a262f42911d7f5906a9243
|
||||
TERMUX_PKG_DEPENDS="littlecms"
|
||||
TERMUX_PKG_BREAKS="babl-dev"
|
||||
TERMUX_PKG_REPLACES="babl-dev"
|
||||
|
11
packages/babl/tools-babl-benchmark.c.patch
Normal file
11
packages/babl/tools-babl-benchmark.c.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/tools/babl-benchmark.c
|
||||
+++ b/tools/babl-benchmark.c
|
||||
@@ -97,7 +97,7 @@
|
||||
return ((uint64_t)hi << 32 | lo) / 2100;
|
||||
}
|
||||
#else
|
||||
-inline uint64_t bench_ticks (void) { return babl_ticks();}
|
||||
+static inline uint64_t bench_ticks (void) { return babl_ticks();}
|
||||
#endif
|
||||
|
||||
#if 0
|
Loading…
Reference in New Issue
Block a user