finch: Update from 2.11.0 to 2.12.0
This commit is contained in:
parent
a22b3dfe0f
commit
cefb59af16
@ -1,11 +1,23 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://pidgin.im/
|
||||
TERMUX_PKG_HOMEPAGE=https://pidgin.im/
|
||||
TERMUX_PKG_DESCRIPTION="Text-based multi-protocol instant messaging client"
|
||||
TERMUX_PKG_VERSION=2.11.0
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_VERSION=2.12.0
|
||||
TERMUX_PKG_SRCURL=http://downloads.sourceforge.net/project/pidgin/Pidgin/${TERMUX_PKG_VERSION}/pidgin-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=f72613440586da3bdba6d58e718dce1b2c310adf8946de66d8077823e57b3333
|
||||
TERMUX_PKG_SHA256=8c3d3536d6d3c971bd433ff9946678af70a0f6aa4e6969cc2a83bb357015b7f8
|
||||
TERMUX_PKG_DEPENDS="libgnutls, libxml2, ncurses-ui-libs, glib"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-gtkui --disable-gstreamer --disable-vv --disable-idn --disable-meanwhile --disable-avahi --disable-dbus --disable-perl --disable-tcl --without-zephyr --with-ncurses-headers=$TERMUX_PREFIX/include --without-python"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--disable-gtkui
|
||||
--disable-gstreamer
|
||||
--disable-vv
|
||||
--disable-idn
|
||||
--disable-meanwhile
|
||||
--disable-avahi
|
||||
--disable-dbus
|
||||
--disable-perl
|
||||
--disable-tcl
|
||||
--without-zephyr
|
||||
--with-ncurses-headers=$TERMUX_PREFIX/include
|
||||
--without-python
|
||||
"
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="share/sounds/purple lib/purple-2/libmsn.so"
|
||||
|
||||
termux_step_pre_configure () {
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff -u -r ../pidgin-2.10.12/libpurple/protocols/yahoo/Makefile.in ./libpurple/protocols/yahoo/Makefile.in
|
||||
--- ../pidgin-2.10.12/libpurple/protocols/yahoo/Makefile.in 2015-12-31 18:19:53.000000000 -0500
|
||||
+++ ./libpurple/protocols/yahoo/Makefile.in 2016-05-05 04:24:33.584460111 -0400
|
||||
@@ -616,13 +616,13 @@
|
||||
}
|
||||
|
||||
libyahoo.la: $(libyahoo_la_OBJECTS) $(libyahoo_la_DEPENDENCIES) $(EXTRA_libyahoo_la_DEPENDENCIES)
|
||||
- $(AM_V_CCLD)$(libyahoo_la_LINK) $(am_libyahoo_la_rpath) $(libyahoo_la_OBJECTS) $(libyahoo_la_LIBADD) $(LIBS)
|
||||
+ $(AM_V_CCLD)$(libyahoo_la_LINK) $(am_libyahoo_la_rpath) $(libyahoo_la_OBJECTS) $(libyahoo_la_LIBADD) $(LIBS) -lpurple
|
||||
|
||||
libyahoojp.la: $(libyahoojp_la_OBJECTS) $(libyahoojp_la_DEPENDENCIES) $(EXTRA_libyahoojp_la_DEPENDENCIES)
|
||||
- $(AM_V_CCLD)$(libyahoojp_la_LINK) $(am_libyahoojp_la_rpath) $(libyahoojp_la_OBJECTS) $(libyahoojp_la_LIBADD) $(LIBS)
|
||||
+ $(AM_V_CCLD)$(libyahoojp_la_LINK) $(am_libyahoojp_la_rpath) $(libyahoojp_la_OBJECTS) $(libyahoojp_la_LIBADD) $(LIBS) -lpurple
|
||||
|
||||
libymsg.la: $(libymsg_la_OBJECTS) $(libymsg_la_DEPENDENCIES) $(EXTRA_libymsg_la_DEPENDENCIES)
|
||||
- $(AM_V_CCLD)$(libymsg_la_LINK) $(am_libymsg_la_rpath) $(libymsg_la_OBJECTS) $(libymsg_la_LIBADD) $(LIBS)
|
||||
+ $(AM_V_CCLD)$(libymsg_la_LINK) $(am_libymsg_la_rpath) $(libymsg_la_OBJECTS) $(libymsg_la_LIBADD) $(LIBS) -lpurple
|
||||
|
||||
mostlyclean-compile:
|
||||
-rm -f *.$(OBJEXT)
|
Loading…
Reference in New Issue
Block a user