openssh: Update from 7.4 to 7.5
This commit is contained in:
parent
2fb72fe522
commit
cff3a76b91
@ -1,18 +1,44 @@
|
||||
TERMUX_PKG_HOMEPAGE=http://www.openssh.com/
|
||||
TERMUX_PKG_HOMEPAGE=https://www.openssh.com/
|
||||
TERMUX_PKG_DESCRIPTION="Secure shell for logging into a remote machine"
|
||||
TERMUX_PKG_VERSION=7.4p1
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_VERSION=7.5p1
|
||||
TERMUX_PKG_SRCURL=http://mirrors.evowise.com/pub/OpenBSD/OpenSSH/portable/openssh-${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=1b1fc4a14e2024293181924ed24872e6f2e06293f3e8926a376b8aec481f19d1
|
||||
TERMUX_PKG_SHA256=9846e3c5fab9f0547400b4d2c017992f914222b3fd1f8eee6c7dc6bc5e59f9f0
|
||||
TERMUX_PKG_DEPENDS="libandroid-support, ldns, openssl, libutil"
|
||||
# --disable-strip to prevent host "install" command to use "-s", which won't work for target binaries:
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--with-cflags=-Dfd_mask=int --with-ldns --disable-etc-default-login --disable-lastlog --disable-utmp --disable-utmpx --disable-wtmp --disable-wtmpx --disable-libutil --disable-pututline --disable-pututxline --without-stackprotect --with-pid-dir=$TERMUX_PREFIX/var/run --disable-strip --sysconfdir=$TERMUX_PREFIX/etc/ssh --without-ssh1"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" ac_cv_header_sys_un_h=yes ac_cv_func_strnvis=no ac_cv_func_readpassphrase=no ac_cv_search_getrrsetbyname=no ac_cv_func_getlastlogxbyname=no ac_cv_func_fmt_scaled=no ac_cv_func_endgrent=yes"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" --with-privsep-path=$TERMUX_PREFIX/var/empty"
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--disable-etc-default-login
|
||||
--disable-lastlog
|
||||
--disable-libutil
|
||||
--disable-pututline
|
||||
--disable-pututxline
|
||||
--disable-strip
|
||||
--disable-utmp
|
||||
--disable-utmpx
|
||||
--disable-wtmp
|
||||
--disable-wtmpx
|
||||
--sysconfdir=$TERMUX_PREFIX/etc/ssh
|
||||
--with-cflags=-Dfd_mask=int
|
||||
--with-ldns
|
||||
--without-ssh1
|
||||
--without-stackprotect
|
||||
--with-pid-dir=$TERMUX_PREFIX/var/run
|
||||
--with-privsep-path=$TERMUX_PREFIX/var/empty
|
||||
ac_cv_func_endgrent=yes
|
||||
ac_cv_func_fmt_scaled=no
|
||||
ac_cv_func_getlastlogxbyname=no
|
||||
ac_cv_func_readpassphrase=no
|
||||
ac_cv_func_strnvis=no
|
||||
ac_cv_header_sys_un_h=yes
|
||||
ac_cv_search_getrrsetbyname=no
|
||||
"
|
||||
TERMUX_PKG_MAKE_INSTALL_TARGET="install-nokeys"
|
||||
TERMUX_PKG_RM_AFTER_INSTALL="bin/slogin share/man/man1/slogin.1"
|
||||
|
||||
termux_step_pre_configure() {
|
||||
# We patch configure.ac:
|
||||
cd $TERMUX_PKG_SRCDIR
|
||||
autoreconf
|
||||
|
||||
LD=$CC # Needed to link the binaries
|
||||
LDFLAGS+=" -llog" # liblog for android logging in syslog hack
|
||||
}
|
||||
|
13
packages/openssh/configure.ac.patch
Normal file
13
packages/openssh/configure.ac.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Patch submitted upstream at https://bugzilla.mindrot.org/show_bug.cgi?id=2697
|
||||
|
||||
diff -u -r ../openssh-7.5p1/configure.ac ./configure.ac
|
||||
--- ../openssh-7.5p1/configure.ac 2017-03-20 03:39:27.000000000 +0100
|
||||
+++ ./configure.ac 2017-03-23 11:18:49.800171062 +0100
|
||||
@@ -1486,6 +1486,7 @@
|
||||
else
|
||||
LIBS="$LIBS `$LDNSCONFIG --libs`"
|
||||
CPPFLAGS="$CPPFLAGS `$LDNSCONFIG --cflags`"
|
||||
+ ldns=yes
|
||||
fi
|
||||
elif test "x$withval" != "xno" ; then
|
||||
CPPFLAGS="$CPPFLAGS -I${withval}/include"
|
Loading…
Reference in New Issue
Block a user