runit: use git.sr.ht/~grimler/runit for source
Runit there has been converted to use autoconf and automake, and some additional patches from other distros has been added. Not a lot of functional changes for now. Package size has been decreased by ~80 % by moving common code to a shared library.
This commit is contained in:
parent
eb7bdf95ac
commit
d081eb279e
@ -1,14 +0,0 @@
|
|||||||
--- ../src.orig/runit-2.1.2/src/Makefile 2020-06-10 13:15:17.927086588 +0200
|
|
||||||
+++ ./runit-2.1.2/src/Makefile 2020-06-10 13:39:52.277171576 +0200
|
|
||||||
@@ -232,9 +232,8 @@
|
|
||||||
hassgprm.h: choose compile hassgprm.h1 hassgprm.h2 load trysgprm.c
|
|
||||||
./choose cl trysgprm hassgprm.h1 hassgprm.h2 > hassgprm.h
|
|
||||||
|
|
||||||
-hasshsgr.h: chkshsgr choose compile hasshsgr.h1 hasshsgr.h2 load \
|
|
||||||
-tryshsgr.c warn-shsgr
|
|
||||||
- ./chkshsgr || ( cat warn-shsgr; exit 1 )
|
|
||||||
+hasshsgr.h: choose compile hasshsgr.h1 hasshsgr.h2 load \
|
|
||||||
+tryshsgr.c
|
|
||||||
./choose clr tryshsgr hasshsgr.h1 hasshsgr.h2 > hasshsgr.h
|
|
||||||
|
|
||||||
haswaitp.h: choose compile haswaitp.h1 haswaitp.h2 load trywaitp.c
|
|
@ -1,17 +1,14 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=http://smarden.org/runit
|
TERMUX_PKG_HOMEPAGE=http://smarden.org/runit
|
||||||
TERMUX_PKG_DESCRIPTION="Tools to provide service supervision and to manage services"
|
TERMUX_PKG_DESCRIPTION="Tools to provide service supervision and to manage services"
|
||||||
TERMUX_PKG_LICENSE="BSD 3-Clause"
|
TERMUX_PKG_LICENSE="BSD 3-Clause"
|
||||||
TERMUX_PKG_LICENSE_FILE="runit-2.1.2/package/COPYING"
|
|
||||||
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
|
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
|
||||||
TERMUX_PKG_VERSION=2.1.2
|
TERMUX_PKG_VERSION=2.1.2
|
||||||
TERMUX_PKG_REVISION=1
|
TERMUX_PKG_REVISION=2
|
||||||
TERMUX_PKG_SRCURL=http://smarden.org/runit/runit-${TERMUX_PKG_VERSION}.tar.gz
|
_COMMIT=d24ac1333e34a73c5349030aef1c64c5cc1318cc
|
||||||
TERMUX_PKG_SHA256=6fd0160cb0cf1207de4e66754b6d39750cff14bb0aa66ab49490992c0c47ba18
|
TERMUX_PKG_SRCURL=https://git.sr.ht/~grimler/runit/archive/$_COMMIT.tar.gz
|
||||||
TERMUX_PKG_EXTRA_MAKE_ARGS="-C runit-${TERMUX_PKG_VERSION}/src"
|
TERMUX_PKG_SHA256=f6d14f4107ba106bbfef15fd9f71ea3b70c1154169fc7efadd868cceb376b35f
|
||||||
TERMUX_PKG_BUILD_IN_SRC=true
|
TERMUX_PKG_RM_AFTER_INSTALL="bin/runit-init share/man/man8/runit-init.8"
|
||||||
|
|
||||||
termux_step_make_install() {
|
termux_step_pre_configure() {
|
||||||
install -Dm755 runit-${TERMUX_PKG_VERSION}/src/{chpst,runit,runsv,runsvchdir,runsvdir,sv,svlogd,utmpset} $TERMUX_PREFIX/bin/
|
autoreconf -vfi
|
||||||
mkdir -p $TERMUX_PREFIX/share/man/man8
|
|
||||||
install -Dm644 runit-${TERMUX_PKG_VERSION}/man/{chpst,runit,runsv,runsvchdir,runsvdir,sv,svlogd,utmpset}.8 $TERMUX_PREFIX/share/man/man8/
|
|
||||||
}
|
}
|
||||||
|
@ -1,10 +0,0 @@
|
|||||||
--- ../src.orig/runit-2.1.2/src/conf-cc 2020-06-10 13:15:17.927086588 +0200
|
|
||||||
+++ ./runit-2.1.2/src/conf-cc 2020-06-10 13:27:28.210306192 +0200
|
|
||||||
@@ -1,5 +1,5 @@
|
|
||||||
-gcc -O2 -Wall
|
|
||||||
+${CC} ${CPPFLAGS} ${CFLAGS}
|
|
||||||
|
|
||||||
-gcc -O2 -Wimplicit -Wunused -Wcomment -Wchar-subscripts -Wuninitialized -Wshadow -Wcast-qual -Wcast-align -Wwrite-strings
|
|
||||||
+${CC} -Wimplicit -Wunused -Wcomment -Wchar-subscripts -Wuninitialized -Wshadow -Wcast-qual -Wcast-align -Wwrite-strings ${CPPFLAGS} ${CFLAGS}
|
|
||||||
|
|
||||||
This will be used to compile .c files.
|
|
@ -1,7 +0,0 @@
|
|||||||
--- ../src.orig/runit-2.1.2/src/conf-ld 2020-06-10 13:15:17.927086588 +0200
|
|
||||||
+++ ./runit-2.1.2/src/conf-ld 2020-06-10 13:33:42.302118866 +0200
|
|
||||||
@@ -1,3 +1,3 @@
|
|
||||||
-gcc -s
|
|
||||||
+${CC} ${LDFLAGS} -s
|
|
||||||
|
|
||||||
This will be used to link .o files into an executable.
|
|
Loading…
Reference in New Issue
Block a user