add stag package (#425)

This commit is contained in:
Oliver Schmidhauser 2016-09-01 13:24:51 +02:00 committed by Fredrik Fornwall
parent e7b7d707b8
commit d26fc718f7
3 changed files with 29 additions and 0 deletions

View File

@ -0,0 +1,9 @@
--- stag/Makefile 2016-08-31 15:10:57.847902802 +0200
+++ Makefile 2016-08-31 15:09:34.507902834 +0200
@@ -1,5 +1,5 @@
CC ?= gcc
-CFLAGS=-Wall -Werror -Wextra -std=c99 -pedantic -Wno-unused-parameter
+CFLAGS+=-Wall -Werror -Wextra -std=c99 -pedantic -Wno-unused-parameter
# D_BSD_SOURCE for strsep
LIBS=-lncurses -lm -D_DEFAULT_SOURCE
PREFIX ?= /usr/local

9
packages/stag/build.sh Normal file
View File

@ -0,0 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://github.com/seenaburns/stag
TERMUX_PKG_DESCRIPTION="Streaming bar graphs. For stats and stuff."
TERMUX_PKG_VERSION=1.0.0
TERMUX_PKG_SRCURL=https://github.com/seenaburns/stag/archive/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_FOLDERNAME=stag-$TERMUX_PKG_VERSION
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_BUILD_IN_SRC=yes
CFLAGS+=" $CPPFLAGS"
CFLAGS+=" $LDFLAGS"

View File

@ -0,0 +1,11 @@
--- stag/stag.c 2016-08-31 15:03:32.627902972 +0200
+++ stag.c 2016-08-31 15:18:34.487902628 +0200
@@ -87,7 +87,7 @@
// Read options
- char opt;
+ signed char opt;
int option_index = 0;
struct option long_options[] =
{