dar: update to 2.7.0

This commit is contained in:
Leonid Pliushch 2021-05-03 19:02:41 +00:00
parent f148e325c7
commit d5fd9535e1
No known key found for this signature in database
GPG Key ID: 45F2964132545795
3 changed files with 94 additions and 22 deletions

View File

@ -2,9 +2,9 @@ TERMUX_PKG_HOMEPAGE=http://dar.linux.free.fr/
TERMUX_PKG_DESCRIPTION="A full featured command-line backup tool, short for Disk ARchive"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.6.13
TERMUX_PKG_VERSION=2.7.0
TERMUX_PKG_SRCURL=http://downloads.sourceforge.net/project/dar/dar/${TERMUX_PKG_VERSION}/dar-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=3fea9ff9e55fb9827e17a080de7d1a2605b82c2320c0dec969071efefdbfd097
TERMUX_PKG_SHA256=689a8d8b68d9260426ab420e6db01765c98adafbd678fbc7114b70f0eda7070a
TERMUX_PKG_DEPENDS="attr, libbz2, libgcrypt, liblzma, liblzo, zlib"
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -1,16 +1,16 @@
diff -uNr dar-2.6.12/configure dar-2.6.12.mod/configure
--- dar-2.6.12/configure 2020-09-11 14:26:19.000000000 +0000
+++ dar-2.6.12.mod/configure 2020-11-05 21:36:52.997365365 +0000
@@ -23331,7 +23331,7 @@
diff -uNr dar-2.7.0/configure dar-2.7.0.mod/configure
--- dar-2.7.0/configure 2021-04-24 12:18:42.000000000 +0000
+++ dar-2.7.0.mod/configure 2021-05-03 18:46:56.060794046 +0000
@@ -24003,7 +24003,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libgcrypt usability" >&5
$as_echo_n "checking for libgcrypt usability... " >&6; }
- if test "$cross_compiling" = yes; then :
+ if test "$cross_compiling" = "fakeyes"; then :
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
as_fn_error $? "cannot run test program while cross compiling
@@ -23365,13 +23365,13 @@
+ if test "$cross_compiling" = fakeyes; then :
# if cross compiling
@@ -24071,13 +24071,13 @@
}
_ACEOF
@ -26,7 +26,7 @@ diff -uNr dar-2.6.12/configure dar-2.6.12.mod/configure
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
as_fn_error $? "cannot run test program while cross compiling
@@ -23400,7 +23400,7 @@
@@ -24106,7 +24106,7 @@
}
_ACEOF
@ -35,16 +35,7 @@ diff -uNr dar-2.6.12/configure dar-2.6.12.mod/configure
else
libgcrypt_hash_bug="yes"
@@ -25756,7 +25756,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for libthreadar() operationability" >&5
$as_echo_n "checking for libthreadar() operationability... " >&6; }
- if test "$cross_compiling" = yes; then :
+ if test "$cross_compiling" = "fakeyes"; then :
{ { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
as_fn_error $? "cannot run test program while cross compiling
@@ -25799,7 +25799,7 @@
@@ -26596,7 +26596,7 @@
}
_ACEOF

View File

@ -0,0 +1,81 @@
diff -uNr dar-2.7.0/src/Makefile.in dar-2.7.0.mod/src/Makefile.in
--- dar-2.7.0/src/Makefile.in 2021-04-24 12:18:44.000000000 +0000
+++ dar-2.7.0.mod/src/Makefile.in 2021-05-03 18:59:53.520818313 +0000
@@ -142,12 +142,12 @@
am__v_at_1 =
SOURCES =
DIST_SOURCES =
-RECURSIVE_TARGETS = all-recursive check-recursive cscopelist-recursive \
+RECURSIVE_TARGETS = all-recursive cscopelist-recursive \
ctags-recursive dvi-recursive html-recursive info-recursive \
install-data-recursive install-dvi-recursive \
install-exec-recursive install-html-recursive \
install-info-recursive install-pdf-recursive \
- install-ps-recursive install-recursive installcheck-recursive \
+ install-ps-recursive install-recursive \
installdirs-recursive pdf-recursive ps-recursive \
tags-recursive uninstall-recursive
am__can_run_installinfo = \
@@ -184,7 +184,7 @@
done | $(am__uniquify_input)`
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = libdar dar_suite check python examples testing
+DIST_SUBDIRS = libdar dar_suite python examples testing
am__DIST_COMMON = $(srcdir)/Makefile.in README
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
am__relativize = \
@@ -373,7 +373,7 @@
top_srcdir = @top_srcdir@
upx = @upx@
@MAKE_ALL_DIR_TRUE@OPT_SUBDIR = examples testing
-SUBDIRS = libdar dar_suite check python $(OPT_SUBDIR)
+SUBDIRS = libdar dar_suite python $(OPT_SUBDIR)
noinst_HEADERS = my_config.h
dist_noinst_DATA = README gettext.h
all: all-recursive
@@ -572,8 +572,6 @@
|| exit 1; \
fi; \
done
-check-am: all-am
-check: check-recursive
all-am: Makefile $(DATA) $(HEADERS)
installdirs: installdirs-recursive
installdirs-am:
@@ -585,7 +583,6 @@
install-am: all-am
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
-installcheck: installcheck-recursive
install-strip:
if test -z '$(STRIP)'; then \
$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
@@ -653,8 +650,6 @@
install-ps-am:
-installcheck-am:
-
maintainer-clean: maintainer-clean-recursive
-rm -f Makefile
maintainer-clean-am: distclean-am maintainer-clean-generic
@@ -675,15 +670,15 @@
.MAKE: $(am__recursive_targets) install-am install-strip
-.PHONY: $(am__recursive_targets) CTAGS GTAGS TAGS all all-am check \
- check-am clean clean-generic clean-libtool cscopelist-am ctags \
+.PHONY: $(am__recursive_targets) CTAGS GTAGS TAGS all all-am \
+ clean clean-generic clean-libtool cscopelist-am ctags \
ctags-am distclean distclean-generic distclean-libtool \
distclean-tags distdir dvi dvi-am html html-am info info-am \
install install-am install-data install-data-am install-dvi \
install-dvi-am install-exec install-exec-am install-html \
install-html-am install-info install-info-am install-man \
install-pdf install-pdf-am install-ps install-ps-am \
- install-strip installcheck installcheck-am installdirs \
+ install-strip installdirs \
installdirs-am maintainer-clean maintainer-clean-generic \
mostlyclean mostlyclean-generic mostlyclean-libtool pdf pdf-am \
ps ps-am tags tags-am uninstall uninstall-am