screen: Update from 4.4.0 to 4.5.1
Also patch some more.
This commit is contained in:
parent
f703bff492
commit
d6f3cea56f
@ -1,14 +1,24 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/screen/
|
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/screen/
|
||||||
TERMUX_PKG_DESCRIPTION="Terminal multiplexer with VT100/ANSI terminal emulation"
|
TERMUX_PKG_DESCRIPTION="Terminal multiplexer with VT100/ANSI terminal emulation"
|
||||||
TERMUX_PKG_VERSION=4.4.0
|
TERMUX_PKG_VERSION=4.5.1
|
||||||
|
TERMUX_PKG_SHA256=97db2114dd963b016cd4ded34831955dcbe3251e5eee45ac2606e67e9f097b2d
|
||||||
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/screen/screen-${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/screen/screen-${TERMUX_PKG_VERSION}.tar.gz
|
||||||
# TERMUX_PKG_DEPENDS="pcre, openssl, libuuid"
|
TERMUX_PKG_DEPENDS="ncurses, libcrypt"
|
||||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--enable-colors256 --with-ssl=openssl --disable-socket-dir"
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||||
|
--disable-socket-dir
|
||||||
|
--enable-colors256
|
||||||
|
--with-ssl=openssl
|
||||||
|
"
|
||||||
|
|
||||||
termux_step_pre_configure () {
|
termux_step_pre_configure () {
|
||||||
# Run autoreconf since we have patched configure.ac
|
# Run autoreconf since we have patched configure.ac
|
||||||
cd $TERMUX_PKG_SRCDIR
|
cd $TERMUX_PKG_SRCDIR
|
||||||
autoconf
|
autoconf
|
||||||
CFLAGS+=" -DGETUTENT"
|
CFLAGS+=" -DGETUTENT"
|
||||||
LDFLAGS+=" -llog"
|
LDFLAGS+=" -llog -lcrypt"
|
||||||
|
}
|
||||||
|
|
||||||
|
termux_step_post_configure() {
|
||||||
|
echo '#define HAVE_SVR4_PTYS 1' >> $TERMUX_PKG_BUILDDIR/config.h
|
||||||
|
echo 'mousetrack on' > "$TERMUX_PREFIX/etc/screenrc"
|
||||||
}
|
}
|
||||||
|
14
disabled-packages/screen/config.h.in.patch
Normal file
14
disabled-packages/screen/config.h.in.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -u -r ../screen-4.5.1/config.h.in ./config.h.in
|
||||||
|
--- ../screen-4.5.1/config.h.in 2017-02-25 16:36:04.156952072 +0100
|
||||||
|
+++ ./config.h.in 2017-04-24 23:19:53.515909451 +0200
|
||||||
|
@@ -192,7 +192,9 @@
|
||||||
|
* If screen is installed with permissions to update /etc/utmp (such
|
||||||
|
* as if it is installed set-uid root), define UTMPOK.
|
||||||
|
*/
|
||||||
|
-#define UTMPOK
|
||||||
|
+#ifndef __ANDROID__
|
||||||
|
+# define UTMPOK
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
/* Set LOGINDEFAULT to one (1)
|
||||||
|
* if you want entries added to /etc/utmp by default, else set it to
|
14
disabled-packages/screen/fileio.c.patch
Normal file
14
disabled-packages/screen/fileio.c.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -u -r ../screen-4.5.1/fileio.c ./fileio.c
|
||||||
|
--- ../screen-4.5.1/fileio.c 2017-02-25 16:35:35.132808149 +0100
|
||||||
|
+++ ./fileio.c 2017-04-24 23:26:50.355204362 +0200
|
||||||
|
@@ -721,8 +721,8 @@
|
||||||
|
#ifdef SIGPIPE
|
||||||
|
signal(SIGPIPE, SIG_DFL);
|
||||||
|
#endif
|
||||||
|
- execl("/bin/sh", "sh", "-c", cmd, (char *)0);
|
||||||
|
- Panic(errno, "/bin/sh");
|
||||||
|
+ execl("@TERMUX_PREFIX@/bin/sh", "sh", "-c", cmd, (char *)0);
|
||||||
|
+ Panic(errno, "@TERMUX_PREFIX@/bin/sh");
|
||||||
|
default:
|
||||||
|
break;
|
||||||
|
}
|
@ -5,7 +5,7 @@
|
|||||||
int VerboseCreate = 0; /* XXX move this to user.h */
|
int VerboseCreate = 0; /* XXX move this to user.h */
|
||||||
|
|
||||||
-char DefaultShell[] = "/bin/sh";
|
-char DefaultShell[] = "/bin/sh";
|
||||||
+char DefaultShell[] = "/data/data/com.termux/files/home/.termux/shell";
|
+char DefaultShell[] = "@TERMUX_PREFIX@/bin/login";
|
||||||
#ifndef HAVE_EXECVPE
|
#ifndef HAVE_EXECVPE
|
||||||
static char DefaultPath[] = ":/usr/ucb:/bin:/usr/bin";
|
static char DefaultPath[] = ":/usr/ucb:/bin:/usr/bin";
|
||||||
#endif
|
#endif
|
||||||
|
Loading…
x
Reference in New Issue
Block a user