screen: Update to 4.9.0
This commit is contained in:
parent
c681c05e5c
commit
d766e1a4c1
@ -1,7 +1,6 @@
|
|||||||
diff -u -r ../screen-4.5.1/config.h.in ./config.h.in
|
--- a/acconfig.h
|
||||||
--- ../screen-4.5.1/config.h.in 2017-02-25 16:36:04.156952072 +0100
|
+++ b/acconfig.h
|
||||||
+++ ./config.h.in 2017-04-24 23:19:53.515909451 +0200
|
@@ -191,7 +191,9 @@
|
||||||
@@ -192,7 +192,9 @@
|
|
||||||
* If screen is installed with permissions to update /etc/utmp (such
|
* If screen is installed with permissions to update /etc/utmp (such
|
||||||
* as if it is installed set-uid root), define UTMPOK.
|
* as if it is installed set-uid root), define UTMPOK.
|
||||||
*/
|
*/
|
@ -1,20 +1,19 @@
|
|||||||
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/screen/
|
TERMUX_PKG_HOMEPAGE=https://www.gnu.org/software/screen/
|
||||||
TERMUX_PKG_DESCRIPTION="Terminal multiplexer with VT100/ANSI terminal emulation"
|
TERMUX_PKG_DESCRIPTION="Terminal multiplexer with VT100/ANSI terminal emulation"
|
||||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||||
TERMUX_PKG_MAINTAINER="@termux"
|
TERMUX_PKG_MAINTAINER="@termux"
|
||||||
TERMUX_PKG_VERSION=4.8.0
|
TERMUX_PKG_VERSION=4.9.0
|
||||||
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/screen/screen-${TERMUX_PKG_VERSION}.tar.gz
|
TERMUX_PKG_SRCURL=https://mirrors.kernel.org/gnu/screen/screen-${TERMUX_PKG_VERSION}.tar.gz
|
||||||
TERMUX_PKG_SHA256=6e11b13d8489925fde25dfb0935bf6ed71f9eb47eff233a181e078fde5655aa1
|
TERMUX_PKG_SHA256=f9335281bb4d1538ed078df78a20c2f39d3af9a4e91c57d084271e0289c730f4
|
||||||
TERMUX_PKG_DEPENDS="ncurses, libcrypt"
|
TERMUX_PKG_DEPENDS="ncurses, libcrypt"
|
||||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||||
--disable-socket-dir
|
--disable-socket-dir
|
||||||
--enable-colors256
|
--enable-colors256
|
||||||
--with-ssl=openssl
|
|
||||||
"
|
"
|
||||||
|
|
||||||
termux_step_pre_configure() {
|
termux_step_pre_configure() {
|
||||||
# Run autoreconf since we have patched configure.ac
|
# Run autoreconf since we have patched configure.ac
|
||||||
autoconf
|
autoreconf -fi
|
||||||
CFLAGS+=" -DGETUTENT"
|
CFLAGS+=" -DGETUTENT"
|
||||||
export LIBS="-lcrypt"
|
export LIBS="-lcrypt"
|
||||||
}
|
}
|
||||||
|
@ -1,14 +1,13 @@
|
|||||||
diff -u -r ../screen-4.5.1/fileio.c ./fileio.c
|
--- a/fileio.c
|
||||||
--- ../screen-4.5.1/fileio.c 2017-02-25 16:35:35.132808149 +0100
|
+++ b/fileio.c
|
||||||
+++ ./fileio.c 2017-04-24 23:26:50.355204362 +0200
|
@@ -731,8 +731,8 @@
|
||||||
@@ -721,8 +721,8 @@
|
|
||||||
#ifdef SIGPIPE
|
#ifdef SIGPIPE
|
||||||
signal(SIGPIPE, SIG_DFL);
|
signal(SIGPIPE, SIG_DFL);
|
||||||
#endif
|
#endif
|
||||||
- execl("/bin/sh", "sh", "-c", cmd, (char *)0);
|
- execl("/bin/sh", "sh", "-c", cmd, (char *)0);
|
||||||
- Panic(errno, "/bin/sh");
|
- Panic(errno, "/bin/sh");
|
||||||
+ execl("@TERMUX_PREFIX@/bin/sh", "sh", "-c", cmd, (char *)0);
|
+ execl("@TERMUX_PREFIX@/bin/sh", "sh", "-c", cmd, (char *)0);
|
||||||
+ Panic(errno, "@TERMUX_PREFIX@/bin/sh");
|
+ Panic(errno, "@TERMUX_PREFIX@/bin/sh");
|
||||||
default:
|
default:
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
|
Loading…
Reference in New Issue
Block a user