libgit2: Define getloadavg()
This commit is contained in:
parent
f6e0a7a8e3
commit
d8be3e9f55
@ -4,6 +4,7 @@ TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_LICENSE_FILE="COPYING"
|
||||
TERMUX_PKG_MAINTAINER="@termux"
|
||||
TERMUX_PKG_VERSION=1.4.1
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=https://github.com/libgit2/libgit2/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=fccd371a271133e29d002dd207490d22a0c9b06992b874b8edb8366532a94f54
|
||||
TERMUX_PKG_AUTO_UPDATE=true
|
||||
@ -20,4 +21,6 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
termux_step_pre_configure() {
|
||||
find "$TERMUX_PKG_SRCDIR" -name CMakeLists.txt | xargs -n 1 \
|
||||
sed -i 's/\( PROPERTIES C_STANDARD\) 90/\1 99/g'
|
||||
|
||||
cp "$TERMUX_PKG_BUILDER_DIR"/getloadavg.c "$TERMUX_PKG_SRCDIR"/src/
|
||||
}
|
||||
|
48
packages/libgit2/getloadavg.c
Normal file
48
packages/libgit2/getloadavg.c
Normal file
@ -0,0 +1,48 @@
|
||||
/*
|
||||
* Copyright (C) 2018 The Android Open Source Project
|
||||
* All rights reserved.
|
||||
*
|
||||
* Redistribution and use in source and binary forms, with or without
|
||||
* modification, are permitted provided that the following conditions
|
||||
* are met:
|
||||
* * Redistributions of source code must retain the above copyright
|
||||
* notice, this list of conditions and the following disclaimer.
|
||||
* * Redistributions in binary form must reproduce the above copyright
|
||||
* notice, this list of conditions and the following disclaimer in
|
||||
* the documentation and/or other materials provided with the
|
||||
* distribution.
|
||||
*
|
||||
* THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
* "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
* LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS
|
||||
* FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
|
||||
* COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
|
||||
* INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
|
||||
* BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS
|
||||
* OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED
|
||||
* AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
|
||||
* OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
|
||||
* OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
|
||||
* SUCH DAMAGE.
|
||||
*/
|
||||
|
||||
#if defined __ANDROID__ && __ANDROID_API__ < 29
|
||||
|
||||
#include <stdlib.h>
|
||||
|
||||
#include <sys/sysinfo.h>
|
||||
|
||||
int getloadavg(double averages[], int n) {
|
||||
if (n < 0) return -1;
|
||||
if (n > 3) n = 3;
|
||||
|
||||
struct sysinfo si;
|
||||
if (sysinfo(&si) == -1) return -1;
|
||||
|
||||
for (int i = 0; i < n; ++i) {
|
||||
averages[i] = (double)(si.loads[i]) / (double)(1 << SI_LOAD_SHIFT);
|
||||
}
|
||||
return n;
|
||||
}
|
||||
|
||||
#endif
|
13
packages/libgit2/src-rand.c.patch
Normal file
13
packages/libgit2/src-rand.c.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- a/src/rand.c
|
||||
+++ b/src/rand.c
|
||||
@@ -74,6 +74,10 @@
|
||||
|
||||
#else
|
||||
|
||||
+#if defined __ANDROID__ && __ANDROID_API__ < 29
|
||||
+int getloadavg(double[], int);
|
||||
+#endif
|
||||
+
|
||||
GIT_INLINE(int) getseed(uint64_t *seed)
|
||||
{
|
||||
struct timeval tv;
|
Loading…
Reference in New Issue
Block a user