mpdscribble: don't override LDFLAGS
Patch Makefile instead.
This commit is contained in:
parent
fb9839967f
commit
d9197aa09e
12
packages/mpdscribble/Makefile.am.patch
Normal file
12
packages/mpdscribble/Makefile.am.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- ../Makefile.am.orig 2019-07-26 23:06:17.899096875 +0200
|
||||
+++ ./Makefile.am 2019-07-26 23:18:44.680264101 +0200
|
||||
@@ -43,7 +43,8 @@
|
||||
$(LIBMPDCLIENT_LIBS) \
|
||||
$(libgthread_LIBS) \
|
||||
$(libgcrypt_LIBS) \
|
||||
- $(libglib_LIBS)
|
||||
+ $(libglib_LIBS) \
|
||||
+ -llog
|
||||
|
||||
AM_CPPFLAGS += -DFILE_CONF='"$(sysconfdir)/mpdscribble.conf"'
|
||||
|
@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="A Music Player Daemon (MPD) client which submits informa
|
||||
TERMUX_PKG_LICENSE="GPL-2.0"
|
||||
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
|
||||
TERMUX_PKG_VERSION=0.22
|
||||
TERMUX_PKG_REVISION=1
|
||||
TERMUX_PKG_SRCURL=https://github.com/MusicPlayerDaemon/mpdscribble/archive/v${TERMUX_PKG_VERSION}.tar.gz
|
||||
TERMUX_PKG_SHA256=9f6d73e1d0d44bf782c199732acc91bb07efc1c02ae04d037d711860dd8e4012
|
||||
TERMUX_PKG_DEPENDS="libcurl, mpd, libmpdclient, glib"
|
||||
@ -10,7 +11,6 @@ TERMUX_PKG_CONFFILES="$TERMUX_PREFIX/etc/mpdscribble.conf"
|
||||
|
||||
termux_step_pre_configure () {
|
||||
NOCONFIGURE=1 ./autogen.sh
|
||||
export LDFLAGS=" -llog"
|
||||
}
|
||||
|
||||
termux_step_post_make_install () {
|
||||
|
Loading…
Reference in New Issue
Block a user