glib: Update to 2.72.0

This commit is contained in:
Tee KOBAYASHI 2022-03-24 21:31:30 +09:00 committed by xtkoba
parent b85d60663f
commit da601e3943
2 changed files with 13 additions and 13 deletions

View File

@ -2,10 +2,10 @@ TERMUX_PKG_HOMEPAGE=https://developer.gnome.org/glib/
TERMUX_PKG_DESCRIPTION="Library providing core building blocks for libraries and applications written in C"
TERMUX_PKG_LICENSE="LGPL-2.1"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.70.2
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://ftp.gnome.org/pub/gnome/sources/glib/${TERMUX_PKG_VERSION:0:4}/glib-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=0551459c85cd3da3d58ddc9016fd28be5af503f5e1615a71ba5b512ac945806f
_MAJOR_VERSION=2.72
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.0
TERMUX_PKG_SRCURL=https://ftp.gnome.org/pub/gnome/sources/glib/${_MAJOR_VERSION}/glib-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=d7bef0d4c4e7a62e08efb8e5f252a01357007b9588a87ff2b463a3857011f79d
TERMUX_PKG_DEPENDS="libffi, libiconv, pcre, libandroid-support, zlib"
TERMUX_PKG_BREAKS="glib-dev"
TERMUX_PKG_REPLACES="glib-dev"

View File

@ -1,14 +1,14 @@
--- ./meson.build.orig 2021-12-03 15:29:15.000000000 +0530
+++ ./meson.build 2021-12-31 12:02:24.204785929 +0530
@@ -443,7 +443,6 @@
# A zero-length format string shouldn't be considered an issue.
--- a/meson.build
+++ b/meson.build
@@ -464,7 +464,6 @@
'-Wno-format-zero-length',
'-Werror=declaration-after-statement',
# We explicitly require variadic macros
'-Wno-variadic-macros',
- '-Werror=format=2',
'-Werror=implicit-function-declaration',
'-Werror=init-self',
'-Werror=missing-include-dirs',
@@ -511,7 +510,6 @@
'-Werror=pointer-arith',
@@ -545,7 +544,6 @@
'getresuid',
'getvfsstat',
'gmtime_r',
@ -16,11 +16,11 @@
'inotify_init1',
'issetugid',
'kevent',
@@ -2047,9 +2045,8 @@
@@ -2088,9 +2086,8 @@
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []
-if cc.has_function('ngettext', args : osx_ldflags)
-if cc.has_function('ngettext')
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
-else
+have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')