new package: rubiks-cube

This commit is contained in:
Tee KOBAYASHI 2022-01-25 17:11:09 +09:00 committed by xtkoba
parent 60a48e7e65
commit dafb16e23c
2 changed files with 24 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- a/Makefile
+++ b/Makefile
@@ -3,7 +3,7 @@
endif
default: 3d.c CAM-curses-ascii-matcher/CAM.c menu.c
- cc 3d.c CAM-curses-ascii-matcher/CAM.c menu.c -Wall -O3 -ffast-math -lm -lncurses -o rubiks_cube
+ $(CC) $(CFLAGS) $(CPPFLAGS) 3d.c CAM-curses-ascii-matcher/CAM.c menu.c -Wall -O3 -ffast-math -lm -lncurses -o rubiks_cube $(LDFLAGS)
install: rubiks_cube
install -d $(DESTDIR)$(PREFIX)/bin

View File

@ -0,0 +1,13 @@
TERMUX_PKG_HOMEPAGE=https://github.com/been-jamming/rubiks_cube
TERMUX_PKG_DESCRIPTION="A rubik's cube that runs in your terminal"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.2
TERMUX_PKG_SRCURL=https://github.com/been-jamming/rubiks_cube.git
TERMUX_PKG_DEPENDS="ncurses"
TERMUX_PKG_BUILD_IN_SRC=true
TERMUX_PKG_GROUPS="games"
termux_step_make_install() {
install -Dm700 -t $TERMUX_PREFIX/bin rubiks_cube
}