emacs: dump in postinst script with portable dumper
This commit is contained in:
parent
39b750c222
commit
dbc96ede7a
11
packages/emacs/Makefile.patch
Normal file
11
packages/emacs/Makefile.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ../Makefile.in.orig 2020-09-14 22:21:34.172699093 +0200
|
||||
+++ ./Makefile.in 2020-09-15 21:43:19.212824716 +0200
|
||||
@@ -365,7 +365,7 @@
|
||||
sed < ${srcdir}/src/epaths.in > epaths.h.$$$$ \
|
||||
-e 's;\(#.*PATH_LOADSEARCH\).*$$;\1 "${standardlisppath}";' \
|
||||
-e 's;\(#.*PATH_SITELOADSEARCH\).*$$;\1 "${locallisppath}";' \
|
||||
- -e 's;\(#.*PATH_DUMPLOADSEARCH\).*$$;\1 "${buildlisppath}";' \
|
||||
+ -e 's;\(#.*PATH_DUMPLOADSEARCH\).*$$;\1 "${standardlisppath}";' \
|
||||
-e '/^#define PATH_[^ ]*SEARCH /s/\([":]\):*/\1/g' \
|
||||
-e '/^#define PATH_[^ ]*SEARCH /s/:"/"/' \
|
||||
-e 's;\(#.*PATH_EXEC\).*$$;\1 "${archlibdir}";' \
|
@ -24,6 +24,8 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
|
||||
--without-dbus
|
||||
--without-selinux
|
||||
--with-modules
|
||||
--with-pdumper=yes
|
||||
--with-dumping=none
|
||||
"
|
||||
# Ensure use of system malloc:
|
||||
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" emacs_cv_sanitize_address=yes"
|
||||
@ -75,11 +77,6 @@ termux_step_post_get_source() {
|
||||
# Termux only use info pages for emacs. Remove the info directory
|
||||
# to get a clean Info directory file dir.
|
||||
rm -Rf $TERMUX_PREFIX/share/info
|
||||
|
||||
# We cannot run a dumped emacs on Android 5.0+ due to the pie requirement.
|
||||
# Also, the native emacs we build (bootstrap-emacs) cannot used dumps when
|
||||
# building inside docker: https://github.com/docker/docker/issues/22801
|
||||
export CANNOT_DUMP=yes
|
||||
}
|
||||
|
||||
termux_step_host_build() {
|
||||
@ -115,6 +112,10 @@ termux_step_create_debscripts() {
|
||||
$TERMUX_PREFIX/bin/editor editor $TERMUX_PREFIX/bin/emacs 40
|
||||
fi
|
||||
fi
|
||||
|
||||
cd $TERMUX_PREFIX/share/emacs/$TERMUX_PKG_VERSION/lisp
|
||||
LC_ALL=C $TERMUX_PREFIX/bin/emacs -batch -l loadup --temacs=pdump
|
||||
mv $TERMUX_PREFIX/bin/emacs*.pdmp $TERMUX_PREFIX/libexec/emacs/$TERMUX_PKG_VERSION/${TERMUX_ARCH}-linux-android*/
|
||||
EOF
|
||||
|
||||
cat <<- EOF > ./prerm
|
||||
|
Loading…
Reference in New Issue
Block a user