glew: update Makefile.patch

Do not run 'strip -x' on static libraries, use option '--strip-unneeded'
for shared instead of '-x' (--discard-all).
This commit is contained in:
Leonid Pliushch 2021-11-04 18:20:03 +02:00 committed by Yaksh Bariya
parent 24c4c557fd
commit dd0670a457
No known key found for this signature in database
GPG Key ID: F7486BA7D3D27581
1 changed files with 42 additions and 23 deletions

View File

@ -1,28 +1,6 @@
diff -uNr glew-2.2.0/Makefile glew-2.2.0.mod/Makefile
--- glew-2.2.0/Makefile 2020-03-15 13:53:59.000000000 +0200
+++ glew-2.2.0.mod/Makefile 2021-07-23 23:03:17.535567124 +0300
@@ -40,12 +40,12 @@
$(error "Platform '$(SYSTEM)' not supported")
endif
-GLEW_PREFIX ?= /usr
-GLEW_DEST ?= /usr
-BINDIR ?= $(GLEW_DEST)/bin
-LIBDIR ?= $(GLEW_DEST)/lib
-INCDIR ?= $(GLEW_DEST)/include/GL
-PKGDIR ?= $(GLEW_DEST)/lib/pkgconfig
+GLEW_PREFIX = @TERMUX_PREFIX@
+GLEW_DEST = @TERMUX_PREFIX@
+BINDIR = $(GLEW_DEST)/bin
+LIBDIR = $(GLEW_DEST)/lib
+INCDIR = $(GLEW_DEST)/include/GL
+PKGDIR = $(GLEW_DEST)/lib/pkgconfig
ifneq ($(GLEW_NO_GLU), -DGLEW_NO_GLU)
LIBGLU = glu
diff -uNr glew-2.2.0/config/Makefile.linux glew-2.2.0.mod/config/Makefile.linux
--- glew-2.2.0/config/Makefile.linux 2020-03-15 13:53:59.000000000 +0200
+++ glew-2.2.0.mod/config/Makefile.linux 2021-07-23 23:11:42.151780238 +0300
+++ glew-2.2.0.mod/config/Makefile.linux 2021-11-04 18:03:36.790712457 +0200
@@ -1,32 +1,17 @@
NAME = $(GLEW_NAME)
-CC = cc
@ -68,3 +46,44 @@ diff -uNr glew-2.2.0/config/Makefile.linux glew-2.2.0.mod/config/Makefile.linux
LIB.STATIC = lib$(NAME).a
-LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
+LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME) -Wl,-rpath=@TERMUX_PREFIX@/lib -Wl,--enable-new-dtags
diff -uNr glew-2.2.0/Makefile glew-2.2.0.mod/Makefile
--- glew-2.2.0/Makefile 2020-03-15 13:53:59.000000000 +0200
+++ glew-2.2.0.mod/Makefile 2021-11-04 18:06:35.454704596 +0200
@@ -40,12 +40,12 @@
$(error "Platform '$(SYSTEM)' not supported")
endif
-GLEW_PREFIX ?= /usr
-GLEW_DEST ?= /usr
-BINDIR ?= $(GLEW_DEST)/bin
-LIBDIR ?= $(GLEW_DEST)/lib
-INCDIR ?= $(GLEW_DEST)/include/GL
-PKGDIR ?= $(GLEW_DEST)/lib/pkgconfig
+GLEW_PREFIX = @TERMUX_PREFIX@
+GLEW_DEST = @TERMUX_PREFIX@
+BINDIR = $(GLEW_DEST)/bin
+LIBDIR = $(GLEW_DEST)/lib
+INCDIR = $(GLEW_DEST)/include/GL
+PKGDIR = $(GLEW_DEST)/lib/pkgconfig
ifneq ($(GLEW_NO_GLU), -DGLEW_NO_GLU)
LIBGLU = glu
@@ -115,9 +115,6 @@
else ifneq ($(LIBTOOL),)
$(LIBTOOL) $@ $^
endif
-ifneq ($(STRIP),)
- $(STRIP) -x $@
-endif
$(LIB.SHARED.DIR)/$(LIB.SHARED): $(LIB.SOBJS)
$(LD) $(LDFLAGS.SO) -o $@ $^ $(LIB.LDFLAGS) $(LIB.LIBS)
@@ -126,7 +123,7 @@
$(LN) $(LIB.SHARED) $(LIB.SHARED.DIR)/$(LIB.DEVLNK)
endif
ifneq ($(STRIP),)
- $(STRIP) -x $@
+ $(STRIP) --strip-unneeded $@
endif
tmp/$(SYSTEM)/default/static/glew.o: src/glew.c include/GL/glew.h include/GL/wglew.h include/GL/glxew.h