hydra: Update from 9.0 to 9.1
This commit is contained in:
parent
e357e9eecc
commit
dd4ca01609
@ -1,16 +1,16 @@
|
||||
TERMUX_PKG_HOMEPAGE=https://github.com/vanhauser-thc/thc-hydra
|
||||
TERMUX_PKG_DESCRIPTION="Network logon cracker supporting different services"
|
||||
TERMUX_PKG_LICENSE="GPL-3.0"
|
||||
TERMUX_PKG_VERSION=9.0
|
||||
TERMUX_PKG_VERSION=9.1
|
||||
TERMUX_PKG_SRCURL=https://github.com/vanhauser-thc/thc-hydra/archive/v$TERMUX_PKG_VERSION.tar.gz
|
||||
TERMUX_PKG_SHA256=56672e253c128abaa6fb19e77f6f59ba6a93762a9ba435505a009ef6d58e8d0e
|
||||
TERMUX_PKG_SHA256=ce08a5148c0ae5ff4b0a4af2f7f15c5946bc939a57eae1bbb6dda19f34410273
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
TERMUX_PKG_DEPENDS="openssl, pcre, libssh"
|
||||
|
||||
termux_step_configure() {
|
||||
# Skip the ./configure file (which does not support cross compilation)
|
||||
# and configure the build manually.
|
||||
CFLAGS+=" -Dindex=strchr -DLIBOPENSSL -DNO_RINDEX -DHAVE_MATH_H -DHAVE_PCRE -DLIBSSH"
|
||||
CFLAGS+=" -Dindex=strchr -Drindex=strrchr -DLIBOPENSSL -DNO_RINDEX -DHAVE_MATH_H -DHAVE_PCRE -DLIBSSH"
|
||||
export MANDIR=/share/man/man1
|
||||
export XLIBS="-lcrypto -lssl -lpcre -lssh"
|
||||
cat Makefile.am | sed 's/^install:.*/install: all/' >> Makefile
|
||||
|
@ -1,17 +0,0 @@
|
||||
It's probably safe to assume color support in terminals without
|
||||
linking against and checking with ncurses.
|
||||
|
||||
diff -u -r ../thc-hydra-8.4/hydra.c ./hydra.c
|
||||
--- ../thc-hydra-8.4/hydra.c 2017-01-27 17:19:18.000000000 +0100
|
||||
+++ ./hydra.c 2017-01-31 13:37:34.496298083 +0100
|
||||
@@ -2622,10 +2622,6 @@
|
||||
colored_output = 0;
|
||||
}
|
||||
}
|
||||
-#else
|
||||
- //don't want border line effect so disabling color output
|
||||
- //if we are not sure about the term
|
||||
- colored_output = 0;
|
||||
#endif
|
||||
|
||||
if (debug)
|
Loading…
Reference in New Issue
Block a user