tcsh: Update from 6.20.00 to 6.21.00

This commit is contained in:
Fredrik Fornwall 2019-05-11 23:32:54 +02:00
parent 60fd8dcfbe
commit e05f85ed42
3 changed files with 26 additions and 2 deletions

View File

@ -0,0 +1,12 @@
diff -u -r ../tcsh-TCSH6_21_00/Makefile.in ./Makefile.in
--- ../tcsh-TCSH6_21_00/Makefile.in 2019-05-08 18:39:28.000000000 +0000
+++ ./Makefile.in 2019-05-11 21:18:26.577655692 +0000
@@ -447,7 +447,7 @@
gethost: gethost.c sh.err.h tc.const.h sh.h
rm -f gethost
- ${CC_FOR_GETHOST} -o gethost ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} $(srcdir)/gethost.c
+ ${CC_FOR_GETHOST} -o gethost -I. -I$(srcdir) $(srcdir)/gethost.c
tc.defs.c: gethost host.defs
@rm -f $@.tmp

View File

@ -1,7 +1,7 @@
TERMUX_PKG_HOMEPAGE=http://www.tcsh.org
TERMUX_PKG_DESCRIPTION="TENEX C Shell, an enhanced version of Berkeley csh"
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_VERSION=6.20.00
TERMUX_PKG_VERSION=6.21.00
TERMUX_PKG_SHA256=046502a77c8fb1b6113678b752deceea3e5facf0d1ee7af79e7383950075c89f
TERMUX_PKG_SRCURL=https://github.com/tcsh-org/tcsh/archive/TCSH${TERMUX_PKG_VERSION//./_}.tar.gz
TERMUX_PKG_SHA256=5559d9508c4d90506a8a03a2ae62441944b99b60710268adb9aafd64f092f2d4
TERMUX_PKG_DEPENDS="ncurses, libcrypt"

12
packages/tcsh/sh.h.patch Normal file
View File

@ -0,0 +1,12 @@
diff -u -r ../tcsh-TCSH6_21_00/sh.h ./sh.h
--- ../tcsh-TCSH6_21_00/sh.h 2019-05-08 18:39:28.000000000 +0000
+++ ./sh.h 2019-05-11 21:11:35.458175126 +0000
@@ -91,6 +91,8 @@
#define TMP_TEMPLATE ".XXXXXX"
+#include <wctype.h>
+
#ifdef SHORT_STRINGS
# ifdef WIDE_STRINGS
#include <wchar.h>