Merge pull request #222 from michalbednarski/gnupg-x86-asm-pie

gnupg: Don't have text relocations on x86
This commit is contained in:
Fredrik Fornwall 2016-04-19 23:20:24 +02:00
commit e07331bb1e
1 changed files with 11 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- gnupg-1.4.20/mpi/Makefile.in 2015-12-20 08:53:15.000000000 +0100
+++ src/mpi/Makefile.in 2016-04-19 19:33:55.167315560 +0200
@@ -713,7 +713,7 @@
# cancel the default rules used by libtool which do not really
# work and add one to cpp .S files
.S.o:
- $(CPP) $(INCLUDES) $(DEFS) $< | grep -v '^#' > _$*.s
+ $(CPP) $(INCLUDES) $(DEFS) -DPIC $< | grep -v '^#' > _$*.s
$(COMPILE) $(AM_CCASFLAGS) -c _$*.s
mv -f _$*.o $*.o