move from unstable: smalltalk

This commit is contained in:
Leonid Pliushch 2021-10-08 18:56:39 +03:00
parent a2fd5963d6
commit e1c0b46459
No known key found for this signature in database
GPG Key ID: 45F2964132545795
4 changed files with 107 additions and 0 deletions

View File

@ -0,0 +1,22 @@
--- ../Makefile.in.orig 2019-01-30 19:27:09.473293877 +0000
+++ ./Makefile.in 2019-01-30 20:10:23.813275682 +0000
@@ -498,8 +498,8 @@
# Running gst inside the build directory...
GST_OPTS = --kernel-dir "@srcdir@/kernel" --image gst.im
-GST = $(WINEWRAPPER) ./gst$(EXEEXT) --no-user-files $(GST_OPTS)
-GST_PACKAGE = XZIP="$(XZIP)" $(WINEWRAPPER) ./gst-tool$(EXEEXT) gst-package $(GST_OPTS)
+GST = $(WINEWRAPPER) ../host-build/.libs/gst --no-user-files $(GST_OPTS)
+GST_PACKAGE = XZIP="$(XZIP)" $(WINEWRAPPER) ../host-build/.libs/gst-tool gst-package $(GST_OPTS)
###########################################################
#
@@ -1508,7 +1508,7 @@
--srcdir "$(srcdir)" $(srcdir)/packages.xml
$(mkdir_p) $(DESTDIR)$(imagedir)
cd $(DESTDIR)$(imagedir) && \
- $(WINEWRAPPER) "$(abs_top_builddir)/gst$(EXEEXT)" --no-user-files -iS \
+ $(WINEWRAPPER) "@TERMUX_PKG_HOSTBUILD_DIR@/.libs/gst" --no-user-files -iS \
--kernel-dir "$(DESTDIR)$(pkgdatadir)/kernel" \
--image "$(DESTDIR)$(imagedir)/gst.im" \
-f "@abs_top_srcdir@/scripts/Finish.st" \

View File

@ -0,0 +1,33 @@
TERMUX_PKG_HOMEPAGE=http://smalltalk.gnu.org/
TERMUX_PKG_DESCRIPTION="A free implementation of the Smalltalk-80 language"
TERMUX_PKG_LICENSE="GPL-2.0, LGPL-2.1"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION=3.2.91
TERMUX_PKG_REVISION=12
TERMUX_PKG_SRCURL=ftp://alpha.gnu.org/gnu/smalltalk/smalltalk-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=13a7480553c182dbb8092bd4f215781b9ec871758d1db7045c2d8587e4d1bef9
TERMUX_PKG_DEPENDS="glib, libandroid-support, libffi, libltdl, libsigsegv, zlib"
TERMUX_PKG_BREAKS="smalltalk-dev"
TERMUX_PKG_REPLACES="smalltalk-dev"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-gtk"
TERMUX_PKG_HOSTBUILD=true
termux_step_host_build() {
(cd "$TERMUX_PKG_SRCDIR"
autoreconf -i
sed 's/int yylineno = 1;//g' -i libgst/genpr-scan.l
sed 's/int yylineno = 1;//g' -i libgst/genvm-scan.l
sed 's/int yylineno = 1;//g' -i libgst/genbc-scan.l
)
# Building bloxtk on archlinux fails with this error: https://bugs.gentoo.org/582936
"$TERMUX_PKG_SRCDIR"/configure --disable-gtk --disable-bloxtk
make
}
termux_step_pre_configure() {
export LD_LIBRARY_PATH="$TERMUX_PKG_HOSTBUILD_DIR/libgst/.libs"
sed -i \
"s%@TERMUX_PKG_HOSTBUILD_DIR@%$TERMUX_PKG_HOSTBUILD_DIR%g" \
"$TERMUX_PKG_SRCDIR"/Makefile.in
}

View File

@ -0,0 +1,33 @@
--- ../configure.orig 2019-01-30 20:21:43.973270891 +0000
+++ ./configure 2019-01-30 20:22:28.683270592 +0000
@@ -5478,30 +5478,7 @@
$as_echo "no, using $LN_S" >&6; }
fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether ln works" >&5
-$as_echo_n "checking whether ln works... " >&6; }
-rm -f conf$$ conf$$.exe conf$$.file
-echo >conf$$.file
-if ln conf$$.file conf$$ 2>/dev/null; then
- # We could just check for DJGPP; but this test works, is more generic
- # and will remain valid once DJGPP supports symlinks (DJGPP 2.04).
- if test -f conf$$.exe; then
- # Don't use ln at all; we don't have any links
- LN='cp -p'
- else
- LN='ln'
- fi
-else
LN=$as_ln_s
-fi
-rm -f conf$$ conf$$.exe conf$$.file
-if test "$LN" = ln; then
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
-$as_echo "yes" >&6; }
-else
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no, using $LN" >&5
-$as_echo "no, using $LN" >&6; }
-fi

View File

@ -0,0 +1,19 @@
iff --git a/lib-src/getdtablesize.c b/lib-src/getdtablesize.c
index 417f127f..a4764235 100644
--- a/lib-src/getdtablesize.c
+++ b/lib-src/getdtablesize.c
@@ -78,14 +78,5 @@ getdtablesize(void)
int tableSize = -1;
#endif
-#ifdef RLIMIT_NOFILE /* who is non POSIX but has this? */
- struct rlimit res;
- if (tableSize >= 0)
- return tableSize;
-
- if (getrlimit(RLIMIT_NOFILE, &rlimit) != -1)
- tableSize = rlimit.rlim_max;
-#endif
-
if (tableSize >= 0)
return tableSize;