tmux: update to 3.2a (#7051)

This commit is contained in:
buttaface 2021-06-29 00:39:58 +05:30 committed by GitHub
parent f920e2dfae
commit e251d79ea5
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 25 additions and 13 deletions

View File

@ -4,9 +4,9 @@ TERMUX_PKG_LICENSE="BSD"
TERMUX_PKG_MAINTAINER="@termux"
# Link against libandroid-support for wcwidth(), see https://github.com/termux/termux-packages/issues/224
TERMUX_PKG_DEPENDS="ncurses, libevent, libandroid-support, libandroid-glob"
TERMUX_PKG_VERSION=3.2
TERMUX_PKG_VERSION=3.2a
TERMUX_PKG_SRCURL=https://github.com/tmux/tmux/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=290a2f25a2f26c649f7ec7f2880586b8d3f43e24d7cb42c691f430941edb4fcf
TERMUX_PKG_SHA256=497bc4ee16f10b53b161bf0253b6f9e20cd0f86c5d0104f149212cb0778ae13a
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="--disable-static"
TERMUX_PKG_BUILD_IN_SRC=true

View File

@ -1,10 +1,6 @@
1. We actually do want tmux.conf to go into ${prefix}/etc,
since the real /etc is not writeable on Android.
2. Skip both reallocarray and recallocarray checks
diff -u -r ../tmux-3.2/configure.ac ./configure.ac
--- ../tmux-3.2/configure.ac 2020-04-27 08:38:04.000000000 +0000
+++ ./configure.ac 2020-04-28 22:36:58.650391000 +0000
diff -uNr tmux-3.2a/configure.ac tmux-3.2a.mod/configure.ac
--- tmux-3.2a/configure.ac 2021-06-10 11:24:57.000000000 +0300
+++ tmux-3.2a.mod/configure.ac 2021-06-28 22:07:57.708407636 +0300
@@ -52,9 +52,6 @@
PKG_PROG_PKG_CONFIG
AC_USE_SYSTEM_EXTENSIONS
@ -15,16 +11,30 @@ diff -u -r ../tmux-3.2/configure.ac ./configure.ac
# Is this --enable-debug?
case "x$VERSION" in xnext*) enable_debug=yes;; esac
AC_ARG_ENABLE(
@@ -157,22 +154,8 @@
# Clang sanitizers wrap reallocarray even if it isn't available on the target
# system. When compiled it always returns NULL and crashes the program. To
# detect this we need a more complicated test.
@@ -153,37 +150,9 @@
])
AC_FUNC_STRNLEN
-# Check if strtonum works.
-AC_MSG_CHECKING([for working strtonum])
-AC_RUN_IFELSE([AC_LANG_PROGRAM(
- [#include <stdlib.h>],
- [return (strtonum("0", 0, 1, NULL) == 0 ? 0 : 1);]
- )],
- [AC_DEFINE(HAVE_STRTONUM) AC_MSG_RESULT(yes)],
- [AC_LIBOBJ(strtonum) AC_MSG_RESULT(no)]
-)
-
-# Clang sanitizers wrap reallocarray even if it isn't available on the target
-# system. When compiled it always returns NULL and crashes the program. To
-# detect this we need a more complicated test.
-AC_MSG_CHECKING([for working reallocarray])
-AC_RUN_IFELSE([AC_LANG_PROGRAM(
- [#include <stdlib.h>],
- [return (reallocarray(NULL, 1, 1) == NULL);]
- )],
- AC_MSG_RESULT(yes),
- [AC_LIBOBJ(reallocarray) AC_MSG_RESULT([no])],
- [AC_LIBOBJ(reallocarray) AC_MSG_RESULT([no])]
-)
-AC_MSG_CHECKING([for working recallocarray])
@ -33,8 +43,10 @@ diff -u -r ../tmux-3.2/configure.ac ./configure.ac
- [return (recallocarray(NULL, 1, 1, 1) == NULL);]
- )],
- AC_MSG_RESULT(yes),
- [AC_LIBOBJ(recallocarray) AC_MSG_RESULT([no])],
- [AC_LIBOBJ(recallocarray) AC_MSG_RESULT([no])]
-)
+AC_LIBOBJ(strtonum)
+AC_LIBOBJ(reallocarray)
+AC_LIBOBJ(recallocarray)