feh: update to 3.0
This commit is contained in:
parent
ad7759da3f
commit
e4bb70011b
@ -2,9 +2,9 @@ TERMUX_PKG_MAINTAINER="Leonid Plyushch <leonid.plyushch@gmail.com> @xeffyr"
|
||||
|
||||
TERMUX_PKG_HOMEPAGE=https://feh.finalrewind.org/
|
||||
TERMUX_PKG_DESCRIPTION="Fast and light imlib2-based image viewer"
|
||||
TERMUX_PKG_VERSION=2.28.1
|
||||
TERMUX_PKG_VERSION=3.0
|
||||
TERMUX_PKG_SRCURL=https://feh.finalrewind.org/feh-${TERMUX_PKG_VERSION}.tar.bz2
|
||||
TERMUX_PKG_SHA256=97066765c61d7413ed40b20f3f62b5d934e94ec91cadd491ebce836e1fb02a72
|
||||
TERMUX_PKG_SHA256=b67b4e5c6e1fb45dd2a4567e395b413c7565246db6780a46fb1bcdf33d72dc01
|
||||
TERMUX_PKG_DEPENDS="imlib2, libandroid-shmem, libcurl, libexif, libpng, libx11, libxinerama"
|
||||
TERMUX_PKG_BUILD_DEPENDS="libxt"
|
||||
TERMUX_PKG_BUILD_IN_SRC=true
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -uNr feh-2.25.1/src/events.c feh-2.25.1.mod/src/events.c
|
||||
--- feh-2.25.1/src/events.c 2018-03-07 18:53:33.000000000 +0200
|
||||
+++ feh-2.25.1.mod/src/events.c 2018-06-21 17:31:53.783526575 +0300
|
||||
@@ -124,7 +124,7 @@
|
||||
|
||||
free(confpath);
|
||||
|
||||
- if (!conf && ((conf = fopen("/etc/feh/buttons", "r")) == NULL))
|
||||
+ if (!conf && ((conf = fopen("/data/data/com.termux/files/usr/etc/feh/buttons", "r")) == NULL))
|
||||
return;
|
||||
|
||||
while (fgets(line, sizeof(line), conf)) {
|
@ -1,12 +0,0 @@
|
||||
diff -uNr feh-2.25.1/src/filelist.c feh-2.25.1.mod/src/filelist.c
|
||||
--- feh-2.25.1/src/filelist.c 2018-03-07 18:53:33.000000000 +0200
|
||||
+++ feh-2.25.1.mod/src/filelist.c 2018-06-21 17:31:53.786859909 +0300
|
||||
@@ -159,7 +159,7 @@
|
||||
{
|
||||
char buf[1024];
|
||||
size_t readsize;
|
||||
- char *sfn = estrjoin("_", "/tmp/feh_stdin", "XXXXXX", NULL);
|
||||
+ char *sfn = estrjoin("_", "/data/data/com.termux/files/usr/tmp/feh_stdin", "XXXXXX", NULL);
|
||||
int fd = mkstemp(sfn);
|
||||
FILE *outfile;
|
||||
|
@ -1,31 +0,0 @@
|
||||
diff --git a/src/imlib.c b/src/imlib.c
|
||||
index d9c5cd0..b91d8b2 100644
|
||||
--- a/src/imlib.c
|
||||
+++ b/src/imlib.c
|
||||
@@ -102,7 +102,7 @@ void init_imlib_fonts(void)
|
||||
{
|
||||
/* Set up the font stuff */
|
||||
imlib_add_path_to_font_path(".");
|
||||
- imlib_add_path_to_font_path(PREFIX "/share/feh/fonts");
|
||||
+ imlib_add_path_to_font_path("/data/data/com.termux/files/usr/share/feh/fonts");
|
||||
|
||||
return;
|
||||
}
|
||||
@@ -320,7 +320,7 @@ static char *feh_magick_load_image(char *filename)
|
||||
else
|
||||
basename++;
|
||||
|
||||
- tmpname = feh_unique_filename("/tmp/", basename);
|
||||
+ tmpname = feh_unique_filename("/data/data/com.termux/files/usr/tmp/", basename);
|
||||
|
||||
if (strlen(tmpname) > (NAME_MAX-6))
|
||||
tmpname[NAME_MAX-7] = '\0';
|
||||
@@ -407,7 +407,7 @@ static char *feh_http_load_image(char *url)
|
||||
else
|
||||
path = "";
|
||||
} else
|
||||
- path = "/tmp/";
|
||||
+ path = "/data/data/com.termux/files/usr/tmp/";
|
||||
|
||||
curl = curl_easy_init();
|
||||
if (!curl) {
|
@ -1,12 +0,0 @@
|
||||
diff -uNr feh-2.25.1/src/keyevents.c feh-2.25.1.mod/src/keyevents.c
|
||||
--- feh-2.25.1/src/keyevents.c 2018-03-07 18:53:33.000000000 +0200
|
||||
+++ feh-2.25.1.mod/src/keyevents.c 2018-06-21 17:31:53.800193243 +0300
|
||||
@@ -226,7 +226,7 @@
|
||||
|
||||
free(confpath);
|
||||
|
||||
- if (!conf && ((conf = fopen("/etc/feh/keys", "r")) == NULL))
|
||||
+ if (!conf && ((conf = fopen("/data/data/com.termux/files/usr/etc/feh/keys", "r")) == NULL))
|
||||
return;
|
||||
|
||||
while (fgets(line, sizeof(line), conf)) {
|
@ -1,21 +0,0 @@
|
||||
diff -uNr feh-2.25.1/src/options.c feh-2.25.1.mod/src/options.c
|
||||
--- feh-2.25.1/src/options.c 2018-03-07 18:53:33.000000000 +0200
|
||||
+++ feh-2.25.1.mod/src/options.c 2018-06-21 17:31:53.803526576 +0300
|
||||
@@ -62,7 +62,7 @@
|
||||
opt.scroll_step = 20;
|
||||
opt.menu_font = estrdup(DEFAULT_MENU_FONT);
|
||||
opt.font = NULL;
|
||||
- opt.menu_bg = estrdup(PREFIX "/share/feh/images/menubg_default.png");
|
||||
+ opt.menu_bg = estrdup("/data/data/com.termux/files/usr/share/feh/images/menubg_default.png");
|
||||
opt.max_height = opt.max_width = UINT_MAX;
|
||||
|
||||
opt.start_list_at = NULL;
|
||||
@@ -159,7 +159,7 @@
|
||||
|
||||
free(oldrcpath);
|
||||
|
||||
- if (!fp && ((fp = fopen("/etc/feh/themes", "r")) == NULL))
|
||||
+ if (!fp && ((fp = fopen("/data/data/com.termux/files/usr/etc/feh/themes", "r")) == NULL))
|
||||
return;
|
||||
|
||||
/* Oooh. We have an options file :) */
|
@ -1,12 +0,0 @@
|
||||
diff -uNr feh-2.25.1/src/slideshow.c feh-2.25.1.mod/src/slideshow.c
|
||||
--- feh-2.25.1/src/slideshow.c 2018-03-07 18:53:33.000000000 +0200
|
||||
+++ feh-2.25.1.mod/src/slideshow.c 2018-06-21 17:31:53.803526576 +0300
|
||||
@@ -482,7 +482,7 @@
|
||||
if (filelist_tmppath != NULL) {
|
||||
strncat(ret, filelist_tmppath, sizeof(ret) - strlen(ret) - 1);
|
||||
} else {
|
||||
- filelist_tmppath = feh_unique_filename("/tmp/","filelist");
|
||||
+ filelist_tmppath = feh_unique_filename("/data/data/com.termux/files/usr/tmp/","filelist");
|
||||
feh_write_filelist(filelist, filelist_tmppath);
|
||||
strncat(ret, filelist_tmppath, sizeof(ret) - strlen(ret) - 1);
|
||||
}
|
@ -1,7 +1,7 @@
|
||||
diff -uNr feh-2.25.1/src/Makefile feh-2.25.1.mod/src/Makefile
|
||||
--- feh-2.25.1/src/Makefile 2018-03-07 18:53:33.000000000 +0200
|
||||
+++ feh-2.25.1.mod/src/Makefile 2018-06-21 17:32:38.113526904 +0300
|
||||
@@ -41,7 +41,7 @@
|
||||
diff -uNr feh-3.0/src/Makefile feh-3.0.mod/src/Makefile
|
||||
--- feh-3.0/src/Makefile 2018-11-09 18:17:58.000000000 +0200
|
||||
+++ feh-3.0.mod/src/Makefile 2018-11-23 23:26:11.165786637 +0200
|
||||
@@ -40,7 +40,7 @@
|
||||
I_DSTS = ${I_SRCS:.raw=.inc}
|
||||
|
||||
feh: deps.mk ${OBJECTS} ${I_DSTS}
|
12
x11-packages/feh/feh-3.0_src_events.c.patch
Normal file
12
x11-packages/feh/feh-3.0_src_events.c.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr feh-3.0/src/events.c feh-3.0.mod/src/events.c
|
||||
--- feh-3.0/src/events.c 2018-11-09 18:17:58.000000000 +0200
|
||||
+++ feh-3.0.mod/src/events.c 2018-11-23 23:29:54.923941949 +0200
|
||||
@@ -124,7 +124,7 @@
|
||||
|
||||
free(confpath);
|
||||
|
||||
- if (!conf && ((conf = fopen("/etc/feh/buttons", "r")) == NULL))
|
||||
+ if (!conf && ((conf = fopen("@TERMUX_PREFIX@/etc/feh/buttons", "r")) == NULL))
|
||||
return;
|
||||
|
||||
while (fgets(line, sizeof(line), conf)) {
|
12
x11-packages/feh/feh-3.0_src_filelist.c.patch
Normal file
12
x11-packages/feh/feh-3.0_src_filelist.c.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr feh-3.0/src/filelist.c feh-3.0.mod/src/filelist.c
|
||||
--- feh-3.0/src/filelist.c 2018-11-09 18:17:58.000000000 +0200
|
||||
+++ feh-3.0.mod/src/filelist.c 2018-11-23 23:30:02.490608366 +0200
|
||||
@@ -160,7 +160,7 @@
|
||||
{
|
||||
char buf[1024];
|
||||
size_t readsize;
|
||||
- char *sfn = estrjoin("_", "/tmp/feh_stdin", "XXXXXX", NULL);
|
||||
+ char *sfn = estrjoin("_", "@TERMUX_PREFIX@/tmp/feh_stdin", "XXXXXX", NULL);
|
||||
int fd = mkstemp(sfn);
|
||||
FILE *outfile;
|
||||
|
21
x11-packages/feh/feh-3.0_src_imlib.c.patch
Normal file
21
x11-packages/feh/feh-3.0_src_imlib.c.patch
Normal file
@ -0,0 +1,21 @@
|
||||
diff -uNr feh-3.0/src/imlib.c feh-3.0.mod/src/imlib.c
|
||||
--- feh-3.0/src/imlib.c 2018-11-09 18:17:58.000000000 +0200
|
||||
+++ feh-3.0.mod/src/imlib.c 2018-11-23 23:30:25.020611522 +0200
|
||||
@@ -361,7 +361,7 @@
|
||||
else
|
||||
basename++;
|
||||
|
||||
- tmpname = feh_unique_filename("/tmp/", basename);
|
||||
+ tmpname = feh_unique_filename("@TERMUX_PREFIX@/tmp/", basename);
|
||||
|
||||
if (strlen(tmpname) > (NAME_MAX-6))
|
||||
tmpname[NAME_MAX-7] = '\0';
|
||||
@@ -559,7 +559,7 @@
|
||||
else
|
||||
path = "";
|
||||
} else
|
||||
- path = "/tmp/";
|
||||
+ path = "@TERMUX_PREFIX@/tmp/";
|
||||
|
||||
curl = curl_easy_init();
|
||||
if (!curl) {
|
12
x11-packages/feh/feh-3.0_src_keyevents.c.patch
Normal file
12
x11-packages/feh/feh-3.0_src_keyevents.c.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr feh-3.0/src/keyevents.c feh-3.0.mod/src/keyevents.c
|
||||
--- feh-3.0/src/keyevents.c 2018-11-09 18:17:58.000000000 +0200
|
||||
+++ feh-3.0.mod/src/keyevents.c 2018-11-23 23:30:45.083952428 +0200
|
||||
@@ -226,7 +226,7 @@
|
||||
|
||||
free(confpath);
|
||||
|
||||
- if (!conf && ((conf = fopen("/etc/feh/keys", "r")) == NULL))
|
||||
+ if (!conf && ((conf = fopen("@TERMUX_PREFIX@/etc/feh/keys", "r")) == NULL))
|
||||
return;
|
||||
|
||||
while (fgets(line, sizeof(line), conf)) {
|
12
x11-packages/feh/feh-3.0_src_options.c.patch
Normal file
12
x11-packages/feh/feh-3.0_src_options.c.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr feh-3.0/src/options.c feh-3.0.mod/src/options.c
|
||||
--- feh-3.0/src/options.c 2018-11-09 18:17:58.000000000 +0200
|
||||
+++ feh-3.0.mod/src/options.c 2018-11-23 23:28:22.666746861 +0200
|
||||
@@ -158,7 +158,7 @@
|
||||
|
||||
free(oldrcpath);
|
||||
|
||||
- if (!fp && ((fp = fopen("/etc/feh/themes", "r")) == NULL))
|
||||
+ if (!fp && ((fp = fopen("@TERMUX_PREFIX@/etc/feh/themes", "r")) == NULL))
|
||||
return;
|
||||
|
||||
/* Oooh. We have an options file :) */
|
12
x11-packages/feh/feh-3.0_src_slideshow.c.patch
Normal file
12
x11-packages/feh/feh-3.0_src_slideshow.c.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -uNr feh-3.0/src/slideshow.c feh-3.0.mod/src/slideshow.c
|
||||
--- feh-3.0/src/slideshow.c 2018-11-09 18:17:58.000000000 +0200
|
||||
+++ feh-3.0.mod/src/slideshow.c 2018-11-23 23:31:02.923962780 +0200
|
||||
@@ -455,7 +455,7 @@
|
||||
if (filelist_tmppath != NULL) {
|
||||
strncat(ret, filelist_tmppath, sizeof(ret) - strlen(ret) - 1);
|
||||
} else {
|
||||
- filelist_tmppath = feh_unique_filename("/tmp/","filelist");
|
||||
+ filelist_tmppath = feh_unique_filename("@TERMUX_PREFIX@/tmp/","filelist");
|
||||
feh_write_filelist(filelist, filelist_tmppath);
|
||||
strncat(ret, filelist_tmppath, sizeof(ret) - strlen(ret) - 1);
|
||||
}
|
Loading…
Reference in New Issue
Block a user