mpd: Update from 0.21.5 to 0.21.7

This commit is contained in:
Fredrik Fornwall 2019-04-12 01:32:10 +02:00
parent 3cb66bc5ea
commit e6ba34915f
3 changed files with 17 additions and 13 deletions

View File

@ -1,11 +1,12 @@
--- ../HybridDsdDecoderPlugin.cxx.orig 2019-01-07 20:58:59.223328152 +0100
+++ ./src/decoder/plugins/HybridDsdDecoderPlugin.cxx 2019-01-07 21:00:02.953327686 +0100
@@ -40,8 +40,6 @@
diff -u -r ../MPD-0.21.7/src/decoder/plugins/HybridDsdDecoderPlugin.cxx ./src/decoder/plugins/HybridDsdDecoderPlugin.cxx
--- ../MPD-0.21.7/src/decoder/plugins/HybridDsdDecoderPlugin.cxx 2019-04-03 10:18:29.000000000 +0000
+++ ./src/decoder/plugins/HybridDsdDecoderPlugin.cxx 2019-04-11 23:28:00.503100747 +0000
@@ -39,8 +39,6 @@
without a DSD DAC, the PCM (=ALAC) part of the file is
better */
if (block.GetBlockParam("enabled") == nullptr) {
- LogInfo(hybrid_dsd_domain,
- "The Hybrid DSD decoder is disabled because it was not explicitly enabled");
- LogDebug(hybrid_dsd_domain,
- "The Hybrid DSD decoder is disabled because it was not explicitly enabled");
return false;
}

View File

@ -1,9 +1,9 @@
TERMUX_PKG_HOMEPAGE=https://www.musicpd.org
TERMUX_PKG_DESCRIPTION="Music player daemon"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_VERSION=0.21.6
TERMUX_PKG_VERSION=0.21.7
TERMUX_PKG_REVISION=1
TERMUX_PKG_SHA256=ad164cb90e8cafcaef10cc64bbe7969c85c7b31246eff907cc6012cbfa85ec82
TERMUX_PKG_SHA256=b33b03e813851387e28970536cd8513fad36ad47bde0928be25ca84a30bc8758
TERMUX_PKG_SRCURL=https://github.com/MusicPlayerDaemon/MPD/archive/v$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_DEPENDS="libcurl, libid3tag, libopus, libpulseaudio, libmpdclient, openal-soft, libvorbis, libsqlite, ffmpeg, libmp3lame, libbz2, libogg, libnfs"
TERMUX_PKG_BUILD_DEPENDS="boost"

View File

@ -1,9 +1,12 @@
diff -u -r ../MPD-0.21.3/src/lib/gcrypt/meson.build ./src/lib/gcrypt/meson.build
--- ../MPD-0.21.3/src/lib/gcrypt/meson.build 2018-11-16 12:27:58.000000000 +0000
+++ ./src/lib/gcrypt/meson.build 2019-01-06 23:35:51.108609898 +0000
@@ -1,4 +1,4 @@
diff -u -r ../MPD-0.21.7/src/lib/gcrypt/meson.build ./src/lib/gcrypt/meson.build
--- ../MPD-0.21.7/src/lib/gcrypt/meson.build 2019-04-03 10:18:29.000000000 +0000
+++ ./src/lib/gcrypt/meson.build 2019-04-11 23:30:00.477643167 +0000
@@ -8,7 +8,7 @@
# will falsly assume it has found the gcrypt library for the target.
#
# See: https://github.com/MusicPlayerDaemon/MPD/pull/495
-gcrypt_dep = c_compiler.find_library('gcrypt', required: get_option('qobuz'))
+gcrypt_dep = c_compiler.find_library('gcrypt_disabled', required: get_option('qobuz'))
if not gcrypt_dep.found()
subdir_done()
if gcrypt_dep.found()
gcrypt_dep = dependency('libgcrypt')
endif