fix building syncthing and fzf

This commit is contained in:
its-pointless 2018-02-24 11:14:15 +11:00 committed by Fredrik Fornwall
parent 2e7375e50e
commit e809105ae9
2 changed files with 7 additions and 6 deletions

View File

@ -1,12 +1,11 @@
diff -u -r ../fzf-0.16.8/Makefile ./Makefile
--- ../fzf-0.16.8/Makefile 2017-06-05 16:21:50.000000000 +0200
+++ ./Makefile 2017-07-10 10:00:29.145783026 +0200
--- ../cache/fzf-0.17.3/Makefile 2017-12-03 14:55:24.000000000 +0000
+++ ./Makefile 2018-02-24 00:04:59.992543575 +0000
@@ -99,7 +99,7 @@
ln -sf $(ROOT_DIR)/vendor $(VENDOR_LINK)
vendor: $(GLIDE_YAML)
- go get -u github.com/Masterminds/glide && $(GOPATH)/bin/glide install && touch $@
+ GOOS= GOARCH= CGO_ENABLED= go get -u github.com/Masterminds/glide && $(GOPATH)/bin/glide install && touch $@
+ GOOS= CC= GOARCH= CGO_ENABLED= go get -u github.com/Masterminds/glide && $(GOPATH)/bin/glide install && touch $@
test: $(SOURCES) vendor
SHELL=/bin/sh GOOS= go test -v -tags "$(TAGS)" \

View File

@ -21,10 +21,12 @@ termux_step_make(){
# Unset GOARCH so building build.go is works.
export GO_ARCH=$GOARCH
unset GOOS GOARCH
export _CC=$CC
unset GOOS GOARCH CC
# Now file structure is same as go get etc.
go build build.go
export CC=$_CC
./build -goos android \
-goarch $GO_ARCH \
-no-upgrade \